]> git.pld-linux.org Git - packages/mosh.git/blob - mosh.spec
- release 3 (by relup.sh)
[packages/mosh.git] / mosh.spec
1 #
2 # Conditional build:
3 %bcond_with     agent           # with ssh agent forwarding patch
4
5 %define         protobuf_ver    2.6.1
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Mosh mobile shell
8 Summary(pl.UTF-8):      Mosh - przenośna powłoka
9 Name:           mosh
10 Version:        1.3.2
11 Release:        3
12 License:        GPL v3+
13 Group:          Applications/Networking
14 Source0:        https://mosh.org/%{name}-%{version}.tar.gz
15 # Source0-md5:  5122f4d2b973ab7c38dcdac8c35cb61e
16 Patch0:         https://github.com/keithw/mosh/pull/583.patch
17 Patch1:         %{name}-Werror.patch
18 # Patch0-md5:   7eb14665ef06072591e5bcd80780c0e4
19 URL:            https://mosh.org/
20 BuildRequires:  autoconf >= 2.61
21 BuildRequires:  automake
22 BuildRequires:  binutils >= 2.20.51.0.2
23 BuildRequires:  libstdc++-devel >= 5:4.0
24 BuildRequires:  libtool
25 BuildRequires:  libutempter-devel
26 BuildRequires:  ncurses-devel
27 BuildRequires:  openssl-devel
28 BuildRequires:  patchutils
29 BuildRequires:  perl-base >= 1:5.14
30 BuildRequires:  pkgconfig
31 BuildRequires:  protobuf >= %{protobuf_ver}
32 BuildRequires:  protobuf-devel >= %{protobuf_ver}
33 BuildRequires:  rpm-perlprov >= 4.1-13
34 BuildRequires:  sed >= 4.0
35 BuildRequires:  zlib-devel
36 Requires:       protobuf-libs >= %{protobuf_ver}
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 # PLD stack protector flags are weaker than upstream, filter them out
40 # https://github.com/keithw/mosh/issues/203
41 %define         _ssp_cflags     %{nil}
42
43 %define         specflags       -Wno-error=non-virtual-dtor
44
45 %description
46 Remote terminal application that allows roaming, supports intermittent
47 connectivity, and provides intelligent local echo and line editing of
48 user keystrokes.
49
50 Mosh is a replacement for SSH. It's more robust and responsive,
51 especially over Wi-Fi, cellular, and long-distance links.
52
53 %description -l pl.UTF-8
54 Zdalna aplikacja terminala, pozwalająca na przemieszczanie,
55 obsługująca przerywaną łączność i zapewniająca inteligentne lokalne
56 echo oraz edycję linii.
57
58 Mosh to zamiennik SSH. Jest potężniejszy i responsywny, w
59 szczególności po połączeniach Wi-Fi, komórkowych i długodystansowych.
60
61 %prep
62 %setup -q
63 %if %{with agent}
64 %patch0 -p1
65 %endif
66 %patch1 -p1
67 %{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
68
69 %build
70 %{__libtoolize}
71 %{__aclocal} -I m4
72 %{__autoconf}
73 %{__autoheader}
74 %{__automake}
75 %configure \
76         --disable-silent-rules \
77         --enable-compile-warnings=error
78 %{__make}
79
80 %install
81 rm -rf $RPM_BUILD_ROOT
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %files
89 %defattr(644,root,root,755)
90 %doc AUTHORS ChangeLog NEWS THANKS
91 %attr(755,root,root) %{_bindir}/%{name}
92 %attr(755,root,root) %{_bindir}/%{name}-client
93 %attr(755,root,root) %{_bindir}/%{name}-server
94 %{_mandir}/man1/%{name}.1*
95 %{_mandir}/man1/%{name}-client.1*
96 %{_mandir}/man1/%{name}-server.1*
This page took 0.070805 seconds and 3 git commands to generate.