]> git.pld-linux.org Git - packages/mosh.git/blame_incremental - mosh.spec
- release 3 (by relup.sh)
[packages/mosh.git] / mosh.spec
... / ...
CommitLineData
1#
2# Conditional build:
3%bcond_with agent # with ssh agent forwarding patch
4
5%define protobuf_ver 2.6.1
6%include /usr/lib/rpm/macros.perl
7Summary: Mosh mobile shell
8Summary(pl.UTF-8): Mosh - przenośna powłoka
9Name: mosh
10Version: 1.3.2
11Release: 3
12License: GPL v3+
13Group: Applications/Networking
14Source0: https://mosh.org/%{name}-%{version}.tar.gz
15# Source0-md5: 5122f4d2b973ab7c38dcdac8c35cb61e
16Patch0: https://github.com/keithw/mosh/pull/583.patch
17Patch1: %{name}-Werror.patch
18# Patch0-md5: 7eb14665ef06072591e5bcd80780c0e4
19URL: https://mosh.org/
20BuildRequires: autoconf >= 2.61
21BuildRequires: automake
22BuildRequires: binutils >= 2.20.51.0.2
23BuildRequires: libstdc++-devel >= 5:4.0
24BuildRequires: libtool
25BuildRequires: libutempter-devel
26BuildRequires: ncurses-devel
27BuildRequires: openssl-devel
28BuildRequires: patchutils
29BuildRequires: perl-base >= 1:5.14
30BuildRequires: pkgconfig
31BuildRequires: protobuf >= %{protobuf_ver}
32BuildRequires: protobuf-devel >= %{protobuf_ver}
33BuildRequires: rpm-perlprov >= 4.1-13
34BuildRequires: sed >= 4.0
35BuildRequires: zlib-devel
36Requires: protobuf-libs >= %{protobuf_ver}
37BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39# PLD stack protector flags are weaker than upstream, filter them out
40# https://github.com/keithw/mosh/issues/203
41%define _ssp_cflags %{nil}
42
43%define specflags -Wno-error=non-virtual-dtor
44
45%description
46Remote terminal application that allows roaming, supports intermittent
47connectivity, and provides intelligent local echo and line editing of
48user keystrokes.
49
50Mosh is a replacement for SSH. It's more robust and responsive,
51especially over Wi-Fi, cellular, and long-distance links.
52
53%description -l pl.UTF-8
54Zdalna aplikacja terminala, pozwalająca na przemieszczanie,
55obsługująca przerywaną łączność i zapewniająca inteligentne lokalne
56echo oraz edycję linii.
57
58Mosh to zamiennik SSH. Jest potężniejszy i responsywny, w
59szczególności po połączeniach Wi-Fi, komórkowych i długodystansowych.
60
61%prep
62%setup -q
63%if %{with agent}
64%patch0 -p1
65%endif
66%patch1 -p1
67%{__sed} -i -e '1s,^#!.*perl,#!%{__perl},' scripts/mosh.pl
68
69%build
70%{__libtoolize}
71%{__aclocal} -I m4
72%{__autoconf}
73%{__autoheader}
74%{__automake}
75%configure \
76 --disable-silent-rules \
77 --enable-compile-warnings=error
78%{__make}
79
80%install
81rm -rf $RPM_BUILD_ROOT
82%{__make} install \
83 DESTDIR=$RPM_BUILD_ROOT
84
85%clean
86rm -rf $RPM_BUILD_ROOT
87
88%files
89%defattr(644,root,root,755)
90%doc AUTHORS ChangeLog NEWS THANKS
91%attr(755,root,root) %{_bindir}/%{name}
92%attr(755,root,root) %{_bindir}/%{name}-client
93%attr(755,root,root) %{_bindir}/%{name}-server
94%{_mandir}/man1/%{name}.1*
95%{_mandir}/man1/%{name}-client.1*
96%{_mandir}/man1/%{name}-server.1*
This page took 0.071804 seconds and 4 git commands to generate.