]> git.pld-linux.org Git - packages/mono-tools.git/blob - mono-tools.spec
- updated to 3.10
[packages/mono-tools.git] / mono-tools.spec
1 #
2 # Conditional build:
3 %bcond_with     gecko           # gecko html renderer
4 #
5 %include        /usr/lib/rpm/macros.mono
6 Summary:        Mono Tools
7 Summary(pl.UTF-8):      Narzędzia do mono
8 Name:           mono-tools
9 Version:        3.10
10 Release:        1
11 License:        GPL v2+
12 Group:          Development/Tools
13 #Source0:       http://download.mono-project.com/sources/mono-tools/%{name}-%{version}.tar.gz
14 # 3.10 tarball is broken, temporarily use github
15 Source0:        https://github.com/mono/mono-tools/archive/%{version}/%{name}-%{version}.tar.gz
16 # Source0-md5:  8df1eed41d5ff6dc6d48541f1c593319
17 Patch0:         %{name}-build.patch
18 Patch1:         %{name}-pwd.patch
19 Patch2:         %{name}-configure.patch
20 Patch3:         %{name}-sdkver.patch
21 URL:            http://www.mono-project.com/
22 BuildRequires:  autoconf
23 BuildRequires:  automake
24 BuildRequires:  dotnet-gconf-sharp-devel >= 2.16.0
25 %{?with_gecko:BuildRequires:    dotnet-gecko-sharp2-devel >= 0.12}
26 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
27 # gtk-sharp-2.0, glade-sharp-2.0
28 BuildRequires:  dotnet-gtk-sharp2-devel
29 BuildRequires:  dotnet-webkit-sharp-devel >= 0.2-1
30 BuildRequires:  gettext-devel
31 BuildRequires:  glib2-devel >= 2.0
32 BuildRequires:  libgdiplus
33 BuildRequires:  mono-compat-links
34 BuildRequires:  mono-csharp
35 BuildRequires:  mono-devel >= 2.10
36 BuildRequires:  mono-monodoc >= 3.2.5-2
37 BuildRequires:  pkgconfig
38 BuildRequires:  rpmbuild(monoautodeps)
39 BuildRequires:  sed >= 4.0
40 Requires:       hicolor-icon-theme
41 Requires:       mono >= 2.10
42 Requires:       mono-tools-html-renderer
43 Obsoletes:      mono-tools-gtkhtml
44 ExcludeArch:    i386
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 Mono Tools is a collection of development and testing programs and
49 utilities for use with Mono.
50
51 %description -l pl.UTF-8
52 Mono Tools jest kolekcją rozwojowych i testowych programów oraz
53 narzędzi do użycia z Mono.
54
55 %package gecko
56 Summary:        Gecko based monodoc HTML renderer
57 Summary(pl.UTF-8):      Oparty na gecko wyświetlacz HTML-a dla monodoc
58 Group:          Development/Tools
59 Requires:       %{name} = %{version}-%{release}
60 Provides:       mono-tools-html-renderer
61
62 %description gecko
63 Gecko based monodoc HTML renderer.
64
65 %description gecko -l pl.UTF-8
66 Oparty na gecko wyświetlacz HTML-a dla monodoc.
67
68 %package webkit
69 Summary:        WebKit based monodoc HTML renderer
70 Summary(pl.UTF-8):      Oparty na WebKit wyświetlacz HTML-a dla monodoc
71 Group:          Development/Tools
72 Requires:       %{name} = %{version}-%{release}
73 Provides:       mono-tools-html-renderer
74
75 %description webkit
76 WebKit based monodoc HTML renderer.
77
78 %description webkit -l pl.UTF-8
79 Oparty na WebKit wyświetlacz HTML-a dla monodoc.
80
81 %package monowebbrowser
82 Summary:        Mono.WebBrowser based monodoc HTML renderer
83 Summary(pl.UTF-8):      Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc
84 Group:          Development/Tools
85 Requires:       %{name} = %{version}-%{release}
86 Provides:       mono-tools-html-renderer
87
88 %description monowebbrowser
89 Mono.WebBrowser based monodoc HTML renderer.
90
91 %description monowebbrowser -l pl.UTF-8
92 Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc.
93
94 %package gendarme
95 Summary:        A tool to find problems in .NET applications and libraries
96 Summary(pl.UTF-8):      Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
97 Group:          Development/Tools
98 Requires:       monodoc >= 2.10
99
100 %description gendarme
101 Gendarme is a extensible rule-based tool to find problems in .NET
102 applications and libraries. Gendarme inspects programs and libraries
103 that contain code in ECMA CIL format (Mono and .NET) and looks for
104 common problems with the code, problems that compiler do not typically
105 check or have not historically checked.
106
107 %description gendarme -l pl.UTF-8
108 Gendarme to rozszerzalne narzędzie oparte o regułki, znajdujące
109 problemy w aplikacjach i bibliotekach .NET. Gendarme przeprowadza
110 inspekcję programów i bibliotek w formacie ECMA CIL (Mono i .NET)
111 szukając typowych problemów, których często kompilator nie sprawdza,
112 lub tych które nie były kiedyś sprawdzane.
113
114 %package gui-compare
115 Summary:        Compares API changes between different assemblies
116 Summary(pl.UTF-8):      Porównuje zmiany API między różnymi assembly
117 Group:          Development/Tools
118
119 %description gui-compare
120 Compares API changes between different assemblies.
121
122 %description gui-compare -l pl.UTF-8
123 Porównuje zmiany API między różnymi assembly.
124
125 %package mprof-decoder
126 Summary:        Console decoder for the logging profiler output files
127 Summary(pl.UTF-8):      Konsolowy dekoder dla plików tworzonych przez logujący profiler
128 Group:          Development/Tools
129
130 %description mprof-decoder
131 Decodes the contents of a logging profiler output file and prints the
132 data on standard output.
133
134 %description mprof-decoder -l pl.UTF-8
135 Dekoduje zawartość pliku wynikowego profilera logującego i wypisuje
136 dane na standardowe wyjście.
137
138 %package mprof-heap-viewer
139 Summary:        GUI viewer for the logging profiler heap snapshots
140 Summary(pl.UTF-8):      Narzędzie do oglądania migawek sterty profilera logującego
141 Group:          Development/Tools
142
143 %description mprof-heap-viewer
144 This program decodes the contents of a logging profiler output file
145 and locates all the heap snapshots inside it. The user can then select
146 each individual snapshot and decide to load it in memory and explore
147 its contents.
148
149 %description mprof-heap-viewer -l pl.UTF-8
150 Ten program dekoduje plik wynikowy profilera logującego i lokalizuje
151 wszystkie znajdujące się w nim migawki sterty. Umożliwia wybranie
152 dowolnej migawki i załadowanie jej do pamięci w celu obejrzenia
153 zawartości.
154
155 %prep
156 %setup -q
157 %patch0 -p1
158 %patch1 -p1
159 %patch2 -p1
160 %patch3 -p1
161
162 # as expected by ilcontrast script
163 %{__sed} -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
164
165 # mono-2.8 path for gasnview.exe
166 %{__sed} -i -e 's,mono/1.0,mono/2.0,' asn1view/gtk/Makefile.am
167
168 %build
169 %{__glib_gettextize}
170 %{__aclocal}
171 %{__autoconf}
172 %{__automake}
173 %configure
174 %{__make} -j1
175
176 %install
177 rm -rf $RPM_BUILD_ROOT
178
179 %{__make} install \
180         DESTDIR=$RPM_BUILD_ROOT \
181         pkgconfigdir=%{_pkgconfigdir} \
182         pkglibdir=%{_prefix}/lib/mono-tools
183
184 # debug
185 %{__rm} $RPM_BUILD_ROOT%{_prefix}/lib/mono-tools/{Mono.Profiler.Widgets.dll,emveepee.exe}.mdb
186
187 %find_lang %{name}
188
189 %clean
190 rm -rf $RPM_BUILD_ROOT
191
192 %post
193 %update_icon_cache hicolor
194
195 %postun
196 %update_icon_cache hicolor
197
198 %files -f %{name}.lang
199 %defattr(644,root,root,755)
200 %doc AUTHORS ChangeLog README
201 %attr(755,root,root) %{_bindir}/create-native-map
202 %attr(755,root,root) %{_bindir}/emveepee
203 %attr(755,root,root) %{_bindir}/gasnview
204 %attr(755,root,root) %{_bindir}/gsharp
205 %attr(755,root,root) %{_bindir}/ilcontrast
206 %attr(755,root,root) %{_bindir}/minvoke
207 %attr(755,root,root) %{_bindir}/monodoc
208 %attr(755,root,root) %{_bindir}/mperfmon
209 %dir %{_prefix}/lib/gsharp
210 %attr(755,root,root) %{_prefix}/lib/gsharp/gsharp.exe
211 %{_prefix}/lib/gsharp/gsharp.exe.config
212 %attr(755,root,root) %{_prefix}/lib/mono/2.0/gasnview.exe
213 %{_prefix}/lib/create-native-map
214 %dir %{_prefix}/lib/ilcontrast
215 %attr(755,root,root) %{_prefix}/lib/ilcontrast/ilcontrast.exe
216 %dir %{_prefix}/lib/minvoke
217 %attr(755,root,root) %{_prefix}/lib/minvoke/minvoke.exe
218 %dir %{_prefix}/lib/mperfmon
219 %{_prefix}/lib/mperfmon/config
220 %attr(755,root,root) %{_prefix}/lib/mperfmon/mperfmon.exe
221 %dir %{_prefix}/lib/mono-tools
222 %{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll
223 %attr(755,root,root) %{_prefix}/lib/mono-tools/emveepee.exe
224 %attr(755,root,root) %{_prefix}/lib/monodoc/browser.exe
225 %{_prefix}/lib/monodoc/web
226 %{_desktopdir}/gsharp.desktop
227 %{_desktopdir}/ilcontrast.desktop
228 %{_desktopdir}/monodoc.desktop
229 %{_pixmapsdir}/ilcontrast.png
230 %{_pixmapsdir}/monodoc.png
231 %{_iconsdir}/hicolor/*x*/apps/monodoc.png
232 %{_pkgconfigdir}/create-native-map.pc
233 %{_mandir}/man1/create-native-map.1*
234 %{_mandir}/man1/mperfmon.1*
235
236 %if %{with gecko}
237 %files gecko
238 %defattr(644,root,root,755)
239 %attr(755,root,root) %{_bindir}/ilcontrast
240 %{_prefix}/lib/ilcontrast
241 %{_prefix}/lib/monodoc/GeckoHtmlRender.dll
242 %{_desktopdir}/ilcontrast.desktop
243 %{_pixmapsdir}/ilcontrast.png
244 %endif
245
246 %files webkit
247 %defattr(644,root,root,755)
248 %{_prefix}/lib/monodoc/WebKitHtmlRender.dll
249
250 %files monowebbrowser
251 %defattr(644,root,root,755)
252 %{_prefix}/lib/monodoc/MonoWebBrowserHtmlRender.dll
253
254 %files gendarme
255 %defattr(644,root,root,755)
256 %attr(755,root,root) %{_bindir}/gd2i
257 %attr(755,root,root) %{_bindir}/gendarme
258 %attr(755,root,root) %{_bindir}/gendarme-wizard
259 %{_prefix}/lib/gendarme
260 %{_prefix}/lib/monodoc/sources/Gendarme*
261 %{_prefix}/lib/monodoc/sources/gendarme*
262 %{_desktopdir}/gendarme-wizard.desktop
263 %{_pkgconfigdir}/gendarme-framework.pc
264 %{_pixmapsdir}/gendarme.svg
265 %{_mandir}/man1/gd2i.1*
266 %{_mandir}/man1/gendarme.1*
267 %{_mandir}/man5/gendarme.5*
268
269 %files gui-compare
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{_bindir}/gui-compare
272 %{_prefix}/lib/gui-compare
273
274 %files mprof-decoder
275 %defattr(644,root,root,755)
276 %attr(755,root,root) %{_bindir}/mprof-decoder
277 %{_prefix}/lib/mono-tools/mprof-decoder-library.*
278 %{_prefix}/lib/mono-tools/mprof-decoder.*
279 %{_mandir}/man1/mprof-decoder.1*
280
281 %files mprof-heap-viewer
282 %defattr(644,root,root,755)
283 %attr(755,root,root) %{_bindir}/mprof-heap-viewer
284 %{_prefix}/lib/mono-tools/mprof-heap-snapshot-explorer.*
285 %{_prefix}/lib/mono-tools/mprof-heap-viewer.*
286 %{_mandir}/man1/mprof-heap-viewer.1*
This page took 0.164444 seconds and 3 git commands to generate.