]> git.pld-linux.org Git - packages/mono-tools.git/blob - mono-tools.spec
4b3d96a67166d100ad33f0f6fe56cc3dff4a2889
[packages/mono-tools.git] / mono-tools.spec
1 #
2 # Conditional build:
3 %bcond_without  gecko           # don't build gecko html renderer
4 #
5 %include        /usr/lib/rpm/macros.mono
6 Summary:        Mono Tools
7 Summary(pl.UTF-8):      Narzędzia do mono
8 Name:           mono-tools
9 Version:        1.9
10 Release:        3
11 License:        GPL v2
12 Group:          Development/Tools
13 # latest downloads summary at http://ftp.novell.com/pub/mono/sources-stable/
14 Source0:        http://ftp.novell.com/pub/mono/sources/mono-tools/%{name}-%{version}.tar.bz2
15 # Source0-md5:  f00eb74bd0f467f81fad3ab62e215e1a
16 URL:            http://www.mono-project.com/
17 BuildRequires:  autoconf
18 BuildRequires:  automake
19 %{?with_gecko:BuildRequires:    dotnet-gecko-sharp2-devel >= 0.12}
20 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
21 BuildRequires:  dotnet-gnome-desktop-sharp-devel
22 BuildRequires:  mono-compat-links
23 BuildRequires:  monodoc >= 1.2.6
24 BuildRequires:  mono-jscript
25 BuildRequires:  pkgconfig
26 BuildRequires:  rpmbuild(monoautodeps)
27 BuildRequires:  sed >= 4.0
28 Requires:       mono-tools-html-renderer
29 ExcludeArch:    i386
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Mono Tools is a collection of development and testing programs and
34 utilities for use with Mono.
35
36 %description -l pl.UTF-8
37 Mono Tools jest kolekcją rozwojowych i testowych programów oraz
38 narzędzi do użycia z Mono.
39
40 %package gecko
41 Summary:        Gecko based monodoc HTML renderer
42 Summary(pl.UTF-8):      Oparty na gecko wyświetlacz HTML-a dla monodoc
43 Group:          Development/Tools
44 Requires:       %{name} = %{version}-%{release}
45 Provides:       mono-tools-html-renderer
46
47 %description gecko
48 Gecko based monodoc HTML renderer. Used instead of GtkHTML based
49 renderer.
50
51 %description gecko -l pl.UTF-8
52 Oparty na gecko wyświetlacz HTML-a dla monodoc. Jest używany zamiast
53 wyświetlacza opartego na GtkHTML.
54
55 %package gtkhtml
56 Summary:        GtkHTML based monodoc HTML renderer
57 Summary(pl.UTF-8):      Oparty na GtkHTML wyświetlacz HTML-a dla monodoc
58 Group:          Development/Tools
59 Requires:       %{name} = %{version}-%{release}
60 Provides:       mono-tools-html-renderer
61
62 %description gtkhtml
63 GtkHTML based monodoc HTML renderer.
64
65 %description gtkhtml -l pl.UTF-8
66 Oparty na GtkHTML wyświetlacz HTML-a dla monodoc.
67
68 %package gendarme
69 Summary:        A tool to find problems in .NET applications and libraries
70 Summary(pl.UTF-8):      Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
71 Group:          Development/Tools
72
73 %description gendarme
74 Gendarme is a extensible rule-based tool to find problems in .NET
75 applications and libraries. Gendarme inspects programs and libraries
76 that contain code in ECMA CIL format (Mono and .NET) and looks for
77 common problems with the code, problems that compiler do not typically
78 check or have not historically checked.
79
80 %description gendarme -l pl.UTF-8
81 Gendarme to rozszerzalne narzędzie oparte o regułki, znajdujące
82 problemy w aplikacjach i bibliotekach .NET. Gendarme przeprowadza
83 inspekcję programów i bibliotek w formacie ECMA CIL (Mono i .NET)
84 szukając typowych problemów, których często kompilator nie sprawdza,
85 lub tych które nie były kiedyś sprawdzane.
86
87 %package gui-compare
88 Summary:        Compares API changes between different assemblies
89 Summary(pl.UTF-8):      Porównuje zmiany API między różnymi assembly
90 Group:          Development/Tools
91
92 %description gui-compare
93 Compares API changes between different assemblies.
94
95 %description gui-compare -l pl.UTF-8
96 Porównuje zmiany API między różnymi assembly.
97
98 %prep
99 %setup -q
100
101 # as expected by ilcontrast script
102 sed -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
103
104 %build
105 %{__aclocal}
106 %{__autoconf}
107 %{__automake}
108 %configure
109 %{__make}
110
111 %install
112 rm -rf $RPM_BUILD_ROOT
113
114 %{__make} install \
115         DESTDIR=$RPM_BUILD_ROOT \
116         monodocdir=%{_libdir}/monodoc \
117         pkgconfigdir=%{_pkgconfigdir}
118
119 %find_lang %{name}
120
121 %clean
122 rm -rf $RPM_BUILD_ROOT
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc AUTHORS ChangeLog README
127 %attr(755,root,root) %{_bindir}/create-native-map
128 %attr(755,root,root) %{_bindir}/gasnview
129 %attr(755,root,root) %{_bindir}/gnunit
130 %attr(755,root,root) %{_bindir}/gnunit2
131 %{_prefix}/lib/mono/1.0/gasnview.exe
132 %{_prefix}/lib/mono/1.0/gnunit.exe
133 %{_prefix}/lib/mono/2.0/gnunit2.exe
134 %{_prefix}/lib/create-native-map
135 %{_libdir}/monodoc/browser.exe
136 %{_desktopdir}/monodoc.desktop
137 %{_pixmapsdir}/monodoc.png
138 %{_pkgconfigdir}/create-native-map.pc
139 %{_mandir}/man1/create-native-map.1*
140
141 %if %{with gecko}
142 %files gecko
143 %defattr(644,root,root,755)
144 %attr(755,root,root) %{_bindir}/ilcontrast
145 %{_prefix}/lib/ilcontrast
146 %{_libdir}/monodoc/GeckoHtmlRender.dll
147 %{_desktopdir}/ilcontrast.desktop
148 %{_pixmapsdir}/ilcontrast.png
149 %endif
150
151 %files gtkhtml
152 %defattr(644,root,root,755)
153 %{_libdir}/monodoc/GtkHtmlHtmlRender.dll
154
155 %files gendarme
156 %defattr(644,root,root,755)
157 %attr(755,root,root) %{_bindir}/gendarme
158 %{_prefix}/lib/gendarme
159 %{_pkgconfigdir}/gendarme-framework.pc
160 %{_mandir}/man1/gendarme.1*
161
162 %files gui-compare
163 %defattr(644,root,root,755)
164 %attr(755,root,root) %{_bindir}/gui-compare
165 %{_prefix}/lib/gui-compare
This page took 0.097282 seconds and 2 git commands to generate.