]> git.pld-linux.org Git - packages/mono-tools.git/blob - mono-tools.spec
- release 4 (by relup.sh)
[packages/mono-tools.git] / mono-tools.spec
1 # NOTE: 2.11 tarball is broken
2 #
3 # Conditional build:
4 %bcond_with     gecko           # don't build gecko html renderer
5 #
6 %include        /usr/lib/rpm/macros.mono
7 Summary:        Mono Tools
8 Summary(pl.UTF-8):      Narzędzia do mono
9 Name:           mono-tools
10 Version:        2.10
11 Release:        4
12 License:        GPL v2+
13 Group:          Development/Tools
14 Source0:        http://download.mono-project.com/sources/mono-tools/%{name}-%{version}.tar.bz2
15 # Source0-md5:  da178df2c119c696c08c09dc9eb01994
16 Patch0:         %{name}-pwd.patch
17 Patch1:         %{name}-configure.patch
18 Patch2:         %{name}-am.patch
19 Patch3:         %{name}-mono3.patch
20 URL:            http://www.mono-project.com/
21 BuildRequires:  autoconf
22 BuildRequires:  automake
23 %{?with_gecko:BuildRequires:    dotnet-gecko-sharp2-devel >= 0.12}
24 BuildRequires:  dotnet-gnome-desktop-sharp-devel
25 BuildRequires:  dotnet-gnome-sharp-devel >= 2.16.0
26 BuildRequires:  dotnet-gtk-sharp2-devel
27 BuildRequires:  dotnet-webkit-sharp-devel >= 0.2-1
28 BuildRequires:  gettext-devel
29 BuildRequires:  glib2-devel
30 BuildRequires:  libgdiplus
31 BuildRequires:  mono-compat-links
32 BuildRequires:  mono-csharp
33 BuildRequires:  mono-devel >= 2.10
34 BuildRequires:  mono-monodoc >= 2.10
35 BuildRequires:  pkgconfig
36 BuildRequires:  rpmbuild(monoautodeps)
37 BuildRequires:  sed >= 4.0
38 Requires:       hicolor-icon-theme
39 Requires:       mono >= 2.10
40 Requires:       mono-tools-html-renderer
41 Obsoletes:      mono-tools-gtkhtml
42 ExcludeArch:    i386
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Mono Tools is a collection of development and testing programs and
47 utilities for use with Mono.
48
49 %description -l pl.UTF-8
50 Mono Tools jest kolekcją rozwojowych i testowych programów oraz
51 narzędzi do użycia z Mono.
52
53 %package gecko
54 Summary:        Gecko based monodoc HTML renderer
55 Summary(pl.UTF-8):      Oparty na gecko wyświetlacz HTML-a dla monodoc
56 Group:          Development/Tools
57 Requires:       %{name} = %{version}-%{release}
58 Provides:       mono-tools-html-renderer
59
60 %description gecko
61 Gecko based monodoc HTML renderer.
62
63 %description gecko -l pl.UTF-8
64 Oparty na gecko wyświetlacz HTML-a dla monodoc.
65
66 %package webkit
67 Summary:        WebKit based monodoc HTML renderer
68 Summary(pl.UTF-8):      Oparty na WebKit wyświetlacz HTML-a dla monodoc
69 Group:          Development/Tools
70 Requires:       %{name} = %{version}-%{release}
71 Provides:       mono-tools-html-renderer
72
73 %description webkit
74 WebKit based monodoc HTML renderer.
75
76 %description webkit -l pl.UTF-8
77 Oparty na WebKit wyświetlacz HTML-a dla monodoc.
78
79 %package monowebbrowser
80 Summary:        Mono.WebBrowser based monodoc HTML renderer
81 Summary(pl.UTF-8):      Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc
82 Group:          Development/Tools
83 Requires:       %{name} = %{version}-%{release}
84 Provides:       mono-tools-html-renderer
85
86 %description monowebbrowser
87 Mono.WebBrowser based monodoc HTML renderer.
88
89 %description monowebbrowser -l pl.UTF-8
90 Oparty na Mono.WebBrowser wyświetlacz HTML-a dla monodoc.
91
92 %package gendarme
93 Summary:        A tool to find problems in .NET applications and libraries
94 Summary(pl.UTF-8):      Narzędzie znajdujące problemy w aplikacjach i bibliotekach .NET
95 Group:          Development/Tools
96 Requires:       monodoc >= 2.10
97
98 %description gendarme
99 Gendarme is a extensible rule-based tool to find problems in .NET
100 applications and libraries. Gendarme inspects programs and libraries
101 that contain code in ECMA CIL format (Mono and .NET) and looks for
102 common problems with the code, problems that compiler do not typically
103 check or have not historically checked.
104
105 %description gendarme -l pl.UTF-8
106 Gendarme to rozszerzalne narzędzie oparte o regułki, znajdujące
107 problemy w aplikacjach i bibliotekach .NET. Gendarme przeprowadza
108 inspekcję programów i bibliotek w formacie ECMA CIL (Mono i .NET)
109 szukając typowych problemów, których często kompilator nie sprawdza,
110 lub tych które nie były kiedyś sprawdzane.
111
112 %package gui-compare
113 Summary:        Compares API changes between different assemblies
114 Summary(pl.UTF-8):      Porównuje zmiany API między różnymi assembly
115 Group:          Development/Tools
116
117 %description gui-compare
118 Compares API changes between different assemblies.
119
120 %description gui-compare -l pl.UTF-8
121 Porównuje zmiany API między różnymi assembly.
122
123 %package mprof-decoder
124 Summary:        Console decoder for the logging profiler output files
125 Summary(pl.UTF-8):      Konsolowy dekoder dla plików tworzonych przez logujący profiler
126 Group:          Development/Tools
127
128 %description mprof-decoder
129 Decodes the contents of a logging profiler output file and prints the
130 data on standard output.
131
132 %description mprof-decoder -l pl.UTF-8
133 Dekoduje zawartość pliku wynikowego profilera logującego i wypisuje
134 dane na standardowe wyjście.
135
136 %package mprof-heap-viewer
137 Summary:        GUI viewer for the logging profiler heap snapshots
138 Summary(pl.UTF-8):      Narzędzie do oglądania migawek sterty profilera logującego
139 Group:          Development/Tools
140
141 %description mprof-heap-viewer
142 This program decodes the contents of a logging profiler output file
143 and locates all the heap snapshots inside it. The user can then select
144 each individual snapshot and decide to load it in memory and explore
145 its contents.
146
147 %description mprof-heap-viewer -l pl.UTF-8
148 Ten program dekoduje plik wynikowy profilera logującego i lokalizuje
149 wszystkie znajdujące się w nim migawki sterty. Umożliwia wybranie
150 dowolnej migawki i załadowanie jej do pamięci w celu obejrzenia
151 zawartości.
152
153 %prep
154 %setup -q
155 %patch0 -p1
156 %patch1 -p1
157 %patch2 -p1
158 %patch3 -p1
159
160 # as expected by ilcontrast script
161 %{__sed} -i -e 's,\$(libdir)/ilcontrast,$(prefix)/lib/ilcontrast,' ilcontrast/Makefile.am
162
163 # mono-2.8 path for gasnview.exe
164 %{__sed} -i -e 's,mono/1.0,mono/2.0,' asn1view/gtk/Makefile.am
165
166 %build
167 %{__aclocal}
168 %{__autoconf}
169 %{__automake}
170 %configure
171 %{__make} -j1
172
173 %install
174 rm -rf $RPM_BUILD_ROOT
175
176 %{__make} install \
177         DESTDIR=$RPM_BUILD_ROOT \
178         pkglibdir=%{_prefix}/lib/mono-tools \
179         pkgconfigdir=%{_pkgconfigdir}
180
181 %find_lang %{name}
182
183 %clean
184 rm -rf $RPM_BUILD_ROOT
185
186 %post
187 %update_icon_cache hicolor
188
189 %postun
190 %update_icon_cache hicolor
191
192 %files -f %{name}.lang
193 %defattr(644,root,root,755)
194 %doc AUTHORS ChangeLog README
195 %attr(755,root,root) %{_bindir}/create-native-map
196 %attr(755,root,root) %{_bindir}/emveepee
197 %attr(755,root,root) %{_bindir}/gasnview
198 %attr(755,root,root) %{_bindir}/gsharp
199 %attr(755,root,root) %{_bindir}/ilcontrast
200 %attr(755,root,root) %{_bindir}/minvoke
201 %attr(755,root,root) %{_bindir}/monodoc
202 %attr(755,root,root) %{_bindir}/mperfmon
203 %dir %{_prefix}/lib/gsharp
204 %attr(755,root,root) %{_prefix}/lib/gsharp/gsharp.exe
205 %{_prefix}/lib/gsharp/gsharp.exe.config
206 %attr(755,root,root) %{_prefix}/lib/mono/2.0/gasnview.exe
207 %{_prefix}/lib/create-native-map
208 %dir %{_prefix}/lib/ilcontrast
209 %attr(755,root,root) %{_prefix}/lib/ilcontrast/ilcontrast.exe
210 %dir %{_prefix}/lib/minvoke
211 %attr(755,root,root) %{_prefix}/lib/minvoke/minvoke.exe
212 %dir %{_prefix}/lib/mperfmon
213 %{_prefix}/lib/mperfmon/config
214 %attr(755,root,root) %{_prefix}/lib/mperfmon/mperfmon.exe
215 %dir %{_prefix}/lib/mono-tools
216 %{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll
217 %exclude %{_prefix}/lib/mono-tools/Mono.Profiler.Widgets.dll.mdb
218 %attr(755,root,root) %{_prefix}/lib/mono-tools/emveepee.exe
219 %exclude %{_prefix}/lib/mono-tools/emveepee.exe.mdb
220 %attr(755,root,root) %{_prefix}/lib/monodoc/browser.exe
221 %{_prefix}/lib/monodoc/web
222 %{_desktopdir}/gsharp.desktop
223 %{_desktopdir}/ilcontrast.desktop
224 %{_desktopdir}/monodoc.desktop
225 %{_pixmapsdir}/ilcontrast.png
226 %{_pixmapsdir}/monodoc.png
227 %{_iconsdir}/hicolor/*/*/*.png
228 %{_pkgconfigdir}/create-native-map.pc
229 %{_mandir}/man1/create-native-map.1*
230 %{_mandir}/man1/mperfmon.1*
231
232 %if %{with gecko}
233 %files gecko
234 %defattr(644,root,root,755)
235 %attr(755,root,root) %{_bindir}/ilcontrast
236 %{_prefix}/lib/ilcontrast
237 %{_prefix}/lib/monodoc/GeckoHtmlRender.dll
238 %{_desktopdir}/ilcontrast.desktop
239 %{_pixmapsdir}/ilcontrast.png
240 %endif
241
242 %files webkit
243 %defattr(644,root,root,755)
244 %{_prefix}/lib/monodoc/WebKitHtmlRender.dll
245
246 %files monowebbrowser
247 %defattr(644,root,root,755)
248 %{_prefix}/lib/monodoc/MonoWebBrowserHtmlRender.dll
249
250 %files gendarme
251 %defattr(644,root,root,755)
252 %attr(755,root,root) %{_bindir}/gd2i
253 %attr(755,root,root) %{_bindir}/gendarme
254 %attr(755,root,root) %{_bindir}/gendarme-wizard
255 %{_prefix}/lib/gendarme
256 %{_prefix}/lib/monodoc/sources/Gendarme*
257 %{_prefix}/lib/monodoc/sources/gendarme*
258 %{_desktopdir}/gendarme-wizard.desktop
259 %{_pkgconfigdir}/gendarme-framework.pc
260 %{_pixmapsdir}/gendarme.svg
261 %{_mandir}/man1/gd2i.1*
262 %{_mandir}/man1/gendarme.1*
263 %{_mandir}/man5/gendarme.5*
264
265 %files gui-compare
266 %defattr(644,root,root,755)
267 %attr(755,root,root) %{_bindir}/gui-compare
268 %{_prefix}/lib/gui-compare
269
270 %files mprof-decoder
271 %defattr(644,root,root,755)
272 %attr(755,root,root) %{_bindir}/mprof-decoder
273 %{_prefix}/lib/mono-tools/mprof-decoder-library.*
274 %{_prefix}/lib/mono-tools/mprof-decoder.*
275 %{_mandir}/man1/mprof-decoder.1*
276
277 %files mprof-heap-viewer
278 %defattr(644,root,root,755)
279 %attr(755,root,root) %{_bindir}/mprof-heap-viewer
280 %{_prefix}/lib/mono-tools/mprof-heap-snapshot-explorer.*
281 %{_prefix}/lib/mono-tools/mprof-heap-viewer.*
282 %{_mandir}/man1/mprof-heap-viewer.1*
This page took 0.145653 seconds and 3 git commands to generate.