]> git.pld-linux.org Git - packages/monit.git/blob - monit.spec
- ahh, what the hell: openssl 0.9.7c
[packages/monit.git] / monit.spec
1 %define snap    20030908
2 Summary:        Process monitor and restart utility
3 Summary(pl):    Narzêdzie do monitorowania procesów i ich restartowania
4 Name:           monit
5 Version:        4.0
6 Release:        0.%{snap}.2
7 Group:          Applications/Console
8 License:        GPL
9 # http://www.tildeslash.com/monit/dist/
10 Source0:        %{name}-%{version}-%{snap}.tar.gz
11 # Source0-md5:  94efc952513af389f7a9e562692ccefc
12 Source1:        %{name}.init
13 Patch0:         %{name}-meminfo-vs-kcore.patch
14 URL:            http://www.tildeslash.com/monit/
15 BuildRequires:  bison
16 BuildRequires:  flex
17 BuildRequires:  openssl-devel >= 0.9.7c
18 PreReq:         rc-scripts
19 Requires(post,preun):   /sbin/chkconfig
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 monit is an utility for monitoring daemons or similar programs running
24 on a Unix system. It will start specified programs if they are not
25 running and restart programs not responding.
26
27 %description -l pl
28 monit jest narzêdziem do monitorowania demonów oraz podonych programów
29 pracuj±cych w systemie Unix. monit zrestartuje podany program w
30 momencie gdy przestaje on pracowaæ lub w momencie gdy program
31 przestaje odpowiadaæ.
32
33 %prep
34 %setup -q
35 %patch0 -p1
36
37 %build
38 ./make_man
39 ./autogen.sh
40 %configure
41 %{__make}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45 install -d $RPM_BUILD_ROOT/etc/rc.d/init.d
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
51 install monitrc $RPM_BUILD_ROOT%{_sysconfdir}
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %post
57 /sbin/chkconfig --add %{name}
58 if [ -f %{_var}/lock/subsys/%{name} ]; then
59         /etc/rc.d/init.d/%{name} restart 1>&2
60 else
61         echo "Run \"/etc/rc.d/init.d/%{name} start\" to start %{name} daemon."
62 fi
63
64 %preun
65 if [ "$1" = "0" ]; then
66         if [ -f %{_var}/lock/subsys/%{name} ]; then
67                 /etc/rc.d/init.d/%{name} stop 1>&2
68         fi
69         /sbin/chkconfig --del %{name}
70 fi
71
72 %files
73 %defattr(644,root,root,755)
74 %doc web/*.html CHANGES.txt CONTRIBUTORS FAQ.txt README*
75 %attr(755,root,root) %{_bindir}/*
76 %{_mandir}/man?/*
77 %attr(754,root,root) /etc/rc.d/init.d/%{name}
78 %attr(600,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}rc
This page took 0.081632 seconds and 3 git commands to generate.