]> git.pld-linux.org Git - packages/mongodb.git/blame_incremental - mongodb.spec
- updated to 2.0.1 (1.8.x left on MONGODB_1_8 branch)
[packages/mongodb.git] / mongodb.spec
... / ...
CommitLineData
1# TODO: pass rpmldflags
2Summary: MongoDB client shell and tools
3Summary(pl.UTF-8): Powłoka kliencka i narzędzia dla bazy danych MongoDB
4Name: mongodb
5Version: 2.0.1
6Release: 1
7License: AGPL v3
8Group: Applications/Databases
9Source0: http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
10# Source0-md5: cb8579074b7c9752eb382a2094ac4523
11Source1: %{name}.logrotate
12Source2: %{name}.init
13Patch0: config.patch
14Patch1: %{name}-system-libs.patch
15Patch2: %{name}-build.patch
16URL: http://www.mongodb.org/
17BuildRequires: boost-devel >= 1.42
18BuildRequires: libpcap-devel
19BuildRequires: libstdc++-devel >= 6:4.0
20BuildRequires: pcre-cxx-devel
21BuildRequires: pcre-devel
22BuildRequires: readline-devel
23BuildRequires: rpmbuild(macros) >= 1.228
24BuildRequires: scons >= 1.2
25BuildRequires: sed >= 4.0
26BuildRequires: snappy-devel
27BuildRequires: v8-devel
28BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30%description
31Mongo (from "huMONGOus") is a schema-free document-oriented database.
32It features dynamic profileable queries, full indexing, replication
33and fail-over support, efficient storage of large binary data objects,
34and auto-sharding.
35
36This package provides the mongo shell, import/export tools, and other
37client utilities.
38
39%description -l pl.UTF-8
40Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
41pozbawione schematu. Obsługuje dynamicznie profilowane zapytania,
42pełne indeksowanie, replikację i fail-over, wydajne składowanie dużych
43obiektów danych binarnych oraz automatyczne dzielenie.
44
45Ten pakiet zawiera powłokę mongo, narzędzia do eksportu/importu danych
46oraz inne narzędzia klienckie.
47
48%package libs
49Summary: MongoDB client library
50Summary(pl.UTF-8): Biblioteka kliencka MongoDB
51Group: Libraries
52
53%description libs
54Mongo (from "huMONGOus") is a schema-free document-oriented database.
55
56This package provides the mongo client library.
57
58%description libs -l pl.UTF-8
59Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
60pozbawione schematu.
61
62Ten pakiet zawiera bibliotekę kliencką mongo.
63
64%package devel
65Summary: Header files for MongoDB client library
66Summary(pl.UTF-8): Pliki nagłówkowe biblioteki klienckiej MongoDB
67Group: Development/Libraries
68Requires: %{name}-libs = %{version}-%{release}
69
70%description devel
71Mongo (from "huMONGOus") is a schema-free document-oriented database.
72
73This package provides the header files needed to develop MongoDB
74client software.
75
76%description devel -l pl.UTF-8
77Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
78pozbawione schematu.
79
80Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia
81oprogramowania klienckiego dla MongoDB.
82
83%package static
84Summary: Static MongoDB client library
85Summary(pl.UTF-8): Statyczna biblioteka kliencka MongoDB
86Group: Development/Libraries
87Requires: %{name}-libs = %{version}-%{release}
88
89%description static
90Mongo (from "huMONGOus") is a schema-free document-oriented database.
91
92This package provides the MongoDB static client library.
93
94%description static -l pl.UTF-8
95Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
96pozbawione schematu.
97
98Ten pakiet zawiera statyczną bibliotekę kliencką MongoDB.
99
100%package server
101Summary: MongoDB server, sharding server, and support scripts
102Summary(pl.UTF-8): Serwer MongoDB, serwer dzielący oraz skrypty pomocnicze
103Group: Applications/Databases
104Requires: %{name} = %{version}-%{release}
105Provides: group(mongod)
106Provides: user(mongod)
107Requires(post,preun): /sbin/chkconfig
108Requires(postun): /usr/sbin/groupdel
109Requires(postun): /usr/sbin/userdel
110Requires(pre): /bin/id
111Requires(pre): /usr/bin/getgid
112Requires(pre): /usr/sbin/groupadd
113Requires(pre): /usr/sbin/useradd
114Requires: rc-scripts
115
116%description server
117Mongo (from "huMONGOus") is a schema-free document-oriented database.
118
119This package provides the mongo server software, mongo sharding server
120software, default configuration files, and init.d scripts.
121
122%description server -l pl.UTF-8
123Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
124pozbawione schematu.
125
126Ten pakiet zawiera serwer mongo, serwer dzielący, pliki domyślnej
127konfiguracji oraz skrypty init.d.
128
129%prep
130%setup -q -n %{name}-src-r%{version}
131%patch0 -p1
132%patch1 -p1
133%patch2 -p1
134%{__sed} -i -e 's,-O3,%{rpmcxxflags} %{rpmcppflags},' SConstruct
135
136# Fix permissions
137find -type f -executable | xargs chmod a-x
138
139# force system pcre/js/snappy
140%{__rm} -r third_party/{js-1.7,pcre-7.4,snappy,*.py}
141
142%build
143%scons \
144 --prefix=$RPM_BUILD_ROOT%{_prefix} \
145 --sharedclient \
146 --full all \
147 --usev8 \
148 --cxx=%{__cxx}
149
150%install
151rm -rf $RPM_BUILD_ROOT
152install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1} \
153 $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig} \
154 $RPM_BUILD_ROOT%{_var}/{lib,log}/mongo
155
156# XXX: scons is so great, recompiles everything here!
157%scons install \
158 --prefix=$RPM_BUILD_ROOT%{_prefix} \
159 --sharedclient \
160 --full \
161 --usev8 \
162 --cxx=%{__cxx}
163
164cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/mongod
165install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mongod
166cp -p rpm/mongod.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/mongod
167cp -p rpm/mongod.conf $RPM_BUILD_ROOT%{_sysconfdir}/mongod.conf
168cp -p debian/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
169
170touch $RPM_BUILD_ROOT%{_var}/log/mongo/mongod.log
171
172%clean
173rm -rf $RPM_BUILD_ROOT
174
175%post libs -p /sbin/ldconfig
176%postun libs -p /sbin/ldconfig
177
178%pre server
179%groupadd -g 258 -r mongod
180%useradd -u 258 -r -g mongod -d %{_var}/lib/mongo -s /bin/false -c "MongoDB Database Server" mongod
181
182%post server
183/sbin/chkconfig --add mongod
184%service mongod restart
185
186%preun server
187if [ "$1" = "0" ]; then
188 %service -q mongod stop
189 /sbin/chkconfig --del mongod
190fi
191
192%postun server
193if [ "$1" = "0" ]; then
194 %userremove mongod
195 %groupremove mongod
196fi
197
198%files
199%defattr(644,root,root,755)
200%doc README GNU-AGPL-3.0.txt
201%attr(755,root,root) %{_bindir}/bsondump
202%attr(755,root,root) %{_bindir}/mongo
203%attr(755,root,root) %{_bindir}/mongodump
204%attr(755,root,root) %{_bindir}/mongoexport
205%attr(755,root,root) %{_bindir}/mongofiles
206%attr(755,root,root) %{_bindir}/mongoimport
207%attr(755,root,root) %{_bindir}/mongorestore
208%attr(755,root,root) %{_bindir}/mongosniff
209%attr(755,root,root) %{_bindir}/mongostat
210%attr(755,root,root) %{_bindir}/mongotop
211%{_mandir}/man1/bsondump.1*
212%{_mandir}/man1/mongo.1*
213%{_mandir}/man1/mongodump.1*
214%{_mandir}/man1/mongoexport.1*
215%{_mandir}/man1/mongofiles.1*
216%{_mandir}/man1/mongoimport.1*
217%{_mandir}/man1/mongosniff.1*
218%{_mandir}/man1/mongostat.1*
219%{_mandir}/man1/mongorestore.1*
220
221%files libs
222%defattr(644,root,root,755)
223%attr(755,root,root) %{_libdir}/libmongoclient.so
224
225%files devel
226%defattr(644,root,root,755)
227%{_includedir}/mongo
228
229%files static
230%defattr(644,root,root,755)
231%{_libdir}/libmongoclient.a
232
233%files server
234%defattr(644,root,root,755)
235%dir %{_sysconfdir}
236%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mongod.conf
237%attr(754,root,root) /etc/rc.d/init.d/mongod
238%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mongod
239%config(noreplace) /etc/logrotate.d/mongod
240%attr(755,root,root) %{_bindir}/mongod
241%attr(755,root,root) %{_bindir}/mongos
242%{_mandir}/man1/mongod.1*
243%{_mandir}/man1/mongos.1*
244%attr(755,mongod,mongod) %dir %{_var}/lib/mongo
245%attr(755,mongod,mongod) %dir %{_var}/log/mongo
246%attr(640,mongod,mongod) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/mongo/mongod.log
This page took 1.081354 seconds and 4 git commands to generate.