]> git.pld-linux.org Git - packages/mongodb.git/blame_incremental - mongodb.spec
- fix for "'swap' is not a member of 'std'" in gcc 4
[packages/mongodb.git] / mongodb.spec
... / ...
CommitLineData
1# TODO:
2# - add support for sharding server (init scripts, systemd units, sample config)
3#
4Summary: MongoDB client shell and tools
5Summary(pl.UTF-8): Powłoka kliencka i narzędzia dla bazy danych MongoDB
6Name: mongodb
7Version: 2.2.4
8Release: 3
9License: AGPL v3
10Group: Applications/Databases
11Source0: http://downloads.mongodb.org/src/%{name}-src-r%{version}.tar.gz
12# Source0-md5: 033354c543c053f5d539b573ac8c28b0
13Source1: %{name}.logrotate
14Source2: %{name}.init
15Source3: mongod-default.conf
16Source4: mongod@.service
17Patch0: %{name}-cflags.patch
18Patch1: %{name}-system-libs.patch
19Patch2: boost-1.50.patch
20Patch3: %{name}-install.patch
21Patch4: %{name}-shared.patch
22Patch5: gcc4.patch
23URL: http://www.mongodb.org/
24BuildRequires: boost-devel >= 1.50
25BuildRequires: libpcap-devel
26BuildRequires: libstdc++-devel >= 6:4.0
27%ifarch %{x8664}
28BuildRequires: libtcmalloc-devel
29%endif
30BuildRequires: pcre-cxx-devel
31BuildRequires: pcre-devel >= 8.30
32BuildRequires: readline-devel
33BuildRequires: rpmbuild(macros) >= 1.644
34BuildRequires: scons >= 1.2
35BuildRequires: sed >= 4.0
36BuildRequires: snappy-devel
37BuildRequires: v8-devel
38Requires: %{name}-libs = %{version}-%{release}
39BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41%description
42Mongo (from "huMONGOus") is a schema-free document-oriented database.
43It features dynamic profileable queries, full indexing, replication
44and fail-over support, efficient storage of large binary data objects,
45and auto-sharding.
46
47This package provides the mongo shell, import/export tools, and other
48client utilities.
49
50%description -l pl.UTF-8
51Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
52pozbawione schematu. Obsługuje dynamicznie profilowane zapytania,
53pełne indeksowanie, replikację i fail-over, wydajne składowanie dużych
54obiektów danych binarnych oraz automatyczne dzielenie.
55
56Ten pakiet zawiera powłokę mongo, narzędzia do eksportu/importu danych
57oraz inne narzędzia klienckie.
58
59%package libs
60Summary: MongoDB client library
61Summary(pl.UTF-8): Biblioteka kliencka MongoDB
62Group: Libraries
63
64%description libs
65Mongo (from "huMONGOus") is a schema-free document-oriented database.
66
67This package provides the mongo client library.
68
69%description libs -l pl.UTF-8
70Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
71pozbawione schematu.
72
73Ten pakiet zawiera bibliotekę kliencką mongo.
74
75%package devel
76Summary: Header files for MongoDB client library
77Summary(pl.UTF-8): Pliki nagłówkowe biblioteki klienckiej MongoDB
78Group: Development/Libraries
79Requires: %{name}-libs = %{version}-%{release}
80
81%description devel
82Mongo (from "huMONGOus") is a schema-free document-oriented database.
83
84This package provides the header files needed to develop MongoDB
85client software.
86
87%description devel -l pl.UTF-8
88Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
89pozbawione schematu.
90
91Ten pakiet zawiera pliki nagłówkowe potrzebne do tworzenia
92oprogramowania klienckiego dla MongoDB.
93
94%package static
95Summary: Static MongoDB client library
96Summary(pl.UTF-8): Statyczna biblioteka kliencka MongoDB
97Group: Development/Libraries
98Requires: %{name}-devel = %{version}-%{release}
99
100%description static
101Mongo (from "huMONGOus") is a schema-free document-oriented database.
102
103This package provides the MongoDB static client library.
104
105%description static -l pl.UTF-8
106Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
107pozbawione schematu.
108
109Ten pakiet zawiera statyczną bibliotekę kliencką MongoDB.
110
111%package server
112Summary: MongoDB server, sharding server, and support scripts
113Summary(pl.UTF-8): Serwer MongoDB, serwer dzielący oraz skrypty pomocnicze
114Group: Applications/Databases
115Requires: %{name} = %{version}-%{release}
116Requires: systemd-units >= 38
117Requires(post,preun): /sbin/chkconfig
118Requires(postun): /usr/sbin/groupdel
119Requires(postun): /usr/sbin/userdel
120Requires(pre): /bin/id
121Requires(pre): /usr/bin/getgid
122Requires(pre): /usr/sbin/groupadd
123Requires(pre): /usr/sbin/useradd
124Requires: rc-scripts
125Provides: group(mongod)
126Provides: user(mongod)
127Conflicts: logrotate < 3.8.0
128
129%description server
130Mongo (from "huMONGOus") is a schema-free document-oriented database.
131
132This package provides the mongo server software, mongo sharding server
133software, default configuration files, and init.d scripts.
134
135%description server -l pl.UTF-8
136Mongo (od "huMONGOus") to baza danych zorientowana na dokumenty
137pozbawione schematu.
138
139Ten pakiet zawiera serwer mongo, serwer dzielący, pliki domyślnej
140konfiguracji oraz skrypty init.d.
141
142%prep
143%setup -q -n %{name}-src-r%{version}
144%patch0 -p1
145%patch1 -p1
146%patch2 -p1
147%patch3 -p1
148%patch4 -p1
149%patch5 -p1
150
151# Fix permissions
152find -type f -executable | xargs chmod a-x
153
154# force system pcre/js/snappy
155%{__rm} -r src/third_party/{js-1.7,pcre-8.30,snappy,boost}
156
157%build
158%scons \
159 CPPFLAGS="%{rpmcppflags} -DXP_UNIX" \
160 --use-system-all=yes \
161 --extralib=pcrecpp,pcre,snappy \
162 --prefix=$RPM_BUILD_ROOT%{_prefix} \
163 --full=all \
164 --sharedclient \
165 --usev8 \
166 --cxx=%{__cxx}
167
168%install
169rm -rf $RPM_BUILD_ROOT
170install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_mandir}/man1} \
171 $RPM_BUILD_ROOT/etc/{logrotate.d,rc.d/init.d,sysconfig,mongod} \
172 $RPM_BUILD_ROOT%{_var}/{lib,log{,/archive}}/mongodb \
173 $RPM_BUILD_ROOT%{systemdunitdir}
174
175# XXX: scons is so great, recompiles everything here!
176%scons install \
177 CPPFLAGS="%{rpmcppflags} -DXP_UNIX" \
178 --use-system-all=yes \
179 --extralib=pcrecpp,pcre,snappy \
180 --prefix=$RPM_BUILD_ROOT%{_prefix} \
181 --full=all \
182 --sharedclient \
183 --usev8 \
184 --cxx=%{__cxx}
185
186cp -p %{SOURCE1} $RPM_BUILD_ROOT/etc/logrotate.d/mongod
187install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/mongod
188cp -p rpm/mongod.sysconfig $RPM_BUILD_ROOT/etc/sysconfig/mongod
189cp -p %{SOURCE3} $RPM_BUILD_ROOT%{_sysconfdir}/mongod/default.conf
190cp -p debian/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
191
192# mask out the LSB service
193ln -s /dev/null $RPM_BUILD_ROOT%{systemdunitdir}/mongod.service
194cp -p %{SOURCE4} $RPM_BUILD_ROOT%{systemdunitdir}/mongod@.service
195
196touch $RPM_BUILD_ROOT%{_var}/log/mongodb/mongod.log
197
198# for some reason these are installed twice, remove unwanted copies
199for f in $RPM_BUILD_ROOT%{_includedir}/mongo/*; do
200 rm -r "$RPM_BUILD_ROOT%{_includedir}/$(basename $f)" || :
201done
202
203%ifarch %{x8664}
204chmod -R a+rX $RPM_BUILD_ROOT/usr/lib
205%{__rm} -r $RPM_BUILD_ROOT/usr/lib
206%endif
207
208%clean
209rm -rf $RPM_BUILD_ROOT
210
211%post libs -p /sbin/ldconfig
212%postun libs -p /sbin/ldconfig
213
214%pre server
215%groupadd -g 258 -r mongod
216%useradd -u 258 -r -g mongod -d %{_var}/lib/mongodb -s /bin/false -c "MongoDB Database Server" mongod
217
218%post server
219/sbin/chkconfig --add mongod
220%service mongod restart
221# our systemd macros cannot handle template (multi-instance) units yet
222export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
223/bin/systemd_booted && /bin/systemctl --quiet daemon-reload || :
224if [ $1 -eq 1 ]; then
225 /bin/systemctl --quiet enable mongod@.service || :
226 /bin/systemd_booted && echo 'Run "/bin/systemctl start mongod@default.service" to start mongod.' || :
227else
228 /bin/systemd_booted && /bin/systemctl --quiet try-restart mongod@default.service || :
229fi
230
231%preun server
232if [ "$1" = "0" ]; then
233 %service -q mongod stop
234 /sbin/chkconfig --del mongod
235 export SYSTEMD_LOG_LEVEL=warning SYSTEMD_LOG_TARGET=syslog
236 /bin/systemd_booted && /bin/systemctl --quiet stop mongod@default.service || :
237 /bin/systemctl --quiet disable mongod@.service || :
238fi
239
240%postun server
241if [ "$1" = "0" ]; then
242 %userremove mongod
243 %groupremove mongod
244fi
245%systemd_reload
246
247%triggerpostun server -- %{name}-server < 2.0.6-3
248if [ -f %{_sysconfdir}/mongod.conf.rpmsave ] ; then
249 cp -f %{_sysconfdir}/mongod/default.conf{,.rpmnew} || :
250 echo "Moving %{_sysconfdir}/mongod.conf to %{_sysconfdir}/mongod/default.conf"
251 mv -f %{_sysconfdir}/mongod.conf.rpmsave %{_sysconfdir}/mongod/default.conf
252 %service mongod restart
253fi
254
255%files
256%defattr(644,root,root,755)
257%doc README GNU-AGPL-3.0.txt
258%attr(755,root,root) %{_bindir}/bsondump
259%attr(755,root,root) %{_bindir}/mongo
260%attr(755,root,root) %{_bindir}/mongodump
261%attr(755,root,root) %{_bindir}/mongoexport
262%attr(755,root,root) %{_bindir}/mongofiles
263%attr(755,root,root) %{_bindir}/mongoimport
264%attr(755,root,root) %{_bindir}/mongooplog
265%attr(755,root,root) %{_bindir}/mongoperf
266%attr(755,root,root) %{_bindir}/mongorestore
267%attr(755,root,root) %{_bindir}/mongosniff
268%attr(755,root,root) %{_bindir}/mongostat
269%attr(755,root,root) %{_bindir}/mongotop
270%{_mandir}/man1/bsondump.1*
271%{_mandir}/man1/mongo.1*
272%{_mandir}/man1/mongodump.1*
273%{_mandir}/man1/mongoexport.1*
274%{_mandir}/man1/mongofiles.1*
275%{_mandir}/man1/mongoimport.1*
276%{_mandir}/man1/mongosniff.1*
277%{_mandir}/man1/mongostat.1*
278%{_mandir}/man1/mongorestore.1*
279
280%files libs
281%defattr(644,root,root,755)
282%attr(755,root,root) %{_libdir}/libmongoclient.so
283
284%files devel
285%defattr(644,root,root,755)
286%{_includedir}/mongo
287
288%files static
289%defattr(644,root,root,755)
290%{_libdir}/libmongoclient.a
291
292%files server
293%defattr(644,root,root,755)
294%dir %{_sysconfdir}/mongod
295%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mongod/default.conf
296%attr(754,root,root) /etc/rc.d/init.d/mongod
297%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/mongod
298%config(noreplace) /etc/logrotate.d/mongod
299%{systemdunitdir}/mongod.service
300%{systemdunitdir}/mongod@.service
301%attr(755,root,root) %{_bindir}/mongod
302%attr(755,root,root) %{_bindir}/mongos
303%{_mandir}/man1/mongod.1*
304%{_mandir}/man1/mongos.1*
305%attr(755,mongod,mongod) %dir %{_var}/lib/mongodb
306%attr(775,root,mongod) %dir %{_var}/log/mongodb
307%attr(775,root,mongod) %dir %{_var}/log/archive/mongodb
308%attr(640,mongod,mongod) %config(noreplace) %verify(not md5 mtime size) %{_var}/log/mongodb/mongod.log
This page took 0.058969 seconds and 4 git commands to generate.