]> git.pld-linux.org Git - packages/microcode-data-intel.git/blob - microcode-data-intel.spec
use https url
[packages/microcode-data-intel.git] / microcode-data-intel.spec
1 Summary:        Microcode definitions for Intel processors
2 Summary(pl.UTF-8):      Definicje mikrokodu dla procesorów Intela
3 Name:           microcode-data-intel
4 Version:        20180108
5 Release:        1
6 License:        INTEL SOFTWARE LICENSE AGREEMENT
7 Group:          Base
8 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
9 Source0:        https://downloadmirror.intel.com/27431/eng/microcode-%{version}.tgz
10 # Source0-md5:  871df55f0ab010ee384dabfc424f2c12
11 # Tool for splitting Intel's microcode file. From Fedora
12 Source1:        intel-microcode2ucode.c
13 # Produces single file for use by boot loader (like grub)
14 Source2:        intel-microcode2ucode-single.c
15 Provides:       microcode-data
16 BuildArch:      noarch
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 The microcode data file for Linux contains the latest microcode
21 definitions for all Intel processors.
22
23 %description -l pl.UTF-8
24 Te pliki danych mikrokodu dla Linuksa zawierają najnowsze definicje
25 mikrokodu dla procesorów Intela.
26
27 %package initrd
28 Summary:        Microcode for initrd
29 Summary(pl.UTF-8):      Mikrokod dla initrd
30 Group:          Base
31
32 %description initrd
33 Intel microcode for initrd.
34
35 %description initrd -l pl.UTF-8
36 Mikrokod dla procesorów Intel dla initrd.
37
38 %prep
39 %setup -qc
40
41 %build
42 if ! grep -q 0x00000000 microcode.dat; then
43         echo >&2 "microcode.dat contains giberrish"
44         exit 1
45 fi
46
47 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
48 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode-single %{SOURCE2}
49
50 ./intel-microcode2ucode microcode.dat > 1.log
51 ./intel-microcode2ucode-single microcode.dat > 2.log
52
53 install -d kernel/x86/microcode
54 ln microcode.bin kernel/x86/microcode/GenuineIntel.bin
55 echo kernel/x86/microcode/GenuineIntel.bin | cpio -o -H newc -R 0:0 > intel-ucode.img
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59 install -d $RPM_BUILD_ROOT{/lib/firmware,/boot}
60
61 cp -a intel-ucode $RPM_BUILD_ROOT/lib/firmware
62 cp -p intel-ucode.img $RPM_BUILD_ROOT/boot
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 /lib/firmware/intel-ucode
70
71 %files initrd
72 %defattr(644,root,root,755)
73 /boot/intel-ucode.img
This page took 0.131071 seconds and 3 git commands to generate.