]> git.pld-linux.org Git - packages/microcode-data-intel.git/blob - microcode-data-intel.spec
55d431ca41130a58bdb4ee01df0c044c79128421
[packages/microcode-data-intel.git] / microcode-data-intel.spec
1 Summary:        Microcode definitions for Intel processors
2 Summary(pl.UTF-8):      Definicje mikrokodu dla procesorów Intela
3 Name:           microcode-data-intel
4 Version:        20180108
5 Release:        1
6 License:        INTEL SOFTWARE LICENSE AGREEMENT
7 Group:          Base
8 # http://downloadcenter.intel.com/, enter "processor microcode data file" to the search
9 Source0:        http://downloadmirror.intel.com/27431/eng/microcode-%{version}.tgz
10 # Source0-md5:  871df55f0ab010ee384dabfc424f2c12
11 # Tool for splitting Intel's microcode file. From Fedora
12 Source1:        intel-microcode2ucode.c
13 # Produces single file for use by boot loader (like grub)
14 Source2:        intel-microcode2ucode-single.c
15 BuildRequires:  cpio
16 Provides:       microcode-data
17 BuildArch:      noarch
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 The microcode data file for Linux contains the latest microcode
22 definitions for all Intel processors.
23
24 %description -l pl.UTF-8
25 Te pliki danych mikrokodu dla Linuksa zawierają najnowsze definicje
26 mikrokodu dla procesorów Intela.
27
28 %package initrd
29 Summary:        Microcode for initrd
30 Summary(pl.UTF-8):      Mikrokod dla initrd
31 Group:          Base
32
33 %description initrd
34 Intel microcode for initrd.
35
36 %description initrd -l pl.UTF-8
37 Mikrokod dla procesorów Intel dla initrd.
38
39 %prep
40 %setup -qc
41
42
43 %build
44 if ! grep -q 0x00000000 microcode.dat; then
45         echo >&2 microcode.dat contains giberrish
46         exit 1
47 fi
48
49 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode %{SOURCE1}
50 %{__cc} %{rpmcflags} %{rpmcppflags} %{rpmldflags} -Wall -o intel-microcode2ucode-single %{SOURCE2}
51
52 ./intel-microcode2ucode microcode.dat > 1.log
53 ./intel-microcode2ucode-single microcode.dat > 2.log
54
55 install -d kernel/x86/microcode
56 ln microcode.bin kernel/x86/microcode/GenuineIntel.bin
57 echo kernel/x86/microcode/GenuineIntel.bin | cpio -o -H newc -R 0:0 > intel-ucode.img
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61 install -d $RPM_BUILD_ROOT{/lib/firmware,/boot}
62
63 cp -a intel-ucode $RPM_BUILD_ROOT/lib/firmware
64 cp -p intel-ucode.img $RPM_BUILD_ROOT/boot
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 /lib/firmware/intel-ucode
72
73 %files initrd
74 %defattr(644,root,root,755)
75 /boot/intel-ucode.img
This page took 0.032629 seconds and 2 git commands to generate.