]> git.pld-linux.org Git - packages/meson.git/blob - meson.spec
d23202e7e4f387e6c2d970f3e5f88874939f6357
[packages/meson.git] / meson.spec
1 Summary:        High productivity build system
2 Summary(pl.UTF-8):      System budowania o dużej produktywności
3 Name:           meson
4 Version:        0.54.0
5 Release:        1
6 License:        Apache v2.0
7 Group:          Development/Tools
8 #Source0Download: https://github.com/mesonbuild/meson/releases/
9 Source0:        https://github.com/mesonbuild/meson/releases/download/%{version}/%{name}-%{version}.tar.gz
10 # Source0-md5:  4968f07219c6bb4df2f83b12b94fe485
11 Patch0:         %{name}-gtkdocdir.patch
12 URL:            http://mesonbuild.com/
13 BuildRequires:  ninja >= 1.5
14 BuildRequires:  python3 >= 1:3.5.2
15 BuildRequires:  python3-modules >= 1:3.5.2
16 BuildRequires:  python3-setuptools
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  sed >= 4.0
20 Requires:       python3-devel-tools >= 1:3.5.2
21 Requires:       python3-libs >= 1:3.5.2
22 Requires:       python3-modules >= 1:3.5.2
23 Requires:       python3-setuptools
24 Conflicts:      ninja < 1.5
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Meson is a build system designed to optimize programmer productivity.
29 It aims to do this by providing simple, out-of-the-box support for
30 modern software development tools and practices, such as unit tests,
31 coverage reports, Valgrind, CCache and the like.
32
33 %description -l pl.UTF-8
34 Meson to system budowania zaprojektowany z myślą o optymalizacji
35 produktywności programisty. Celem jest dostarczenie prostej, od razu
36 działającej obsługi nowoczesnych narzędzi i praktyk programistycznych,
37 takich jak testy jednostkowe, raporty pokrycia, Valgrind, CCache itp.
38
39 %package polkit
40 Summary:        PolKit integration - handle projects installation via Meson
41 Summary(pl.UTF-8):      Integracja z PolKitem - obsługa instalowania projektów przy użyciu Mesona
42 Group:          Development/Tools
43 Requires:       %{name} = %{version}-%{release}
44 Requires:       polkit
45
46 %description polkit
47 PolKit integration - handle projects installation via Meson.
48
49 %description polkit -l pl.UTF-8
50 Integracja z PolKitem - obsługa instalowania projektów przy użyciu
51 Mesona.
52
53 %prep
54 %setup -q
55 %patch0 -p1
56
57 %{__sed} -i -e '1s,/usr/bin/env python3,%{__python3},' \
58         meson.py \
59         mesonbuild/cmake/data/run_ctgt.py
60
61 %build
62 %py3_build
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %py3_install
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(644,root,root,755)
74 %doc README.md
75 %attr(755,root,root) %{_bindir}/meson
76 %{_mandir}/man1/meson.1*
77 %{py3_sitescriptdir}/meson-%{version}-py*.egg-info
78 %{py3_sitescriptdir}/mesonbuild
79
80 %files polkit
81 %defattr(644,root,root,755)
82 %{_datadir}/polkit-1/actions/com.mesonbuild.install.policy
This page took 0.940454 seconds and 2 git commands to generate.