]> git.pld-linux.org Git - packages/mediastreamer.git/commitdiff
- updated to 4.4.2
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 5 Jul 2021 15:46:28 +0000 (17:46 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Mon, 5 Jul 2021 15:47:06 +0000 (17:47 +0200)
- enhanced build patch (autotools became more bitrotten)
- removed obsolete libsrtp2 patch

build.patch
libsrtp2.patch [deleted file]
libupnp-1.14.patch
mediastreamer.spec

index 6d87df04f342a4d68344e6bbefe71544fd212811..e823e36b3629ac7c17329a59529238e4b02554c7 100644 (file)
 @@ -1,5 +1,5 @@
  dnl Process this file with autoconf to produce a configure script.
 -AC_INIT([mediastreamer],[2.15.1])
-+AC_INIT([mediastreamer],[2.16.1])
++AC_INIT([mediastreamer],[4.4.2])
  
  AC_MSG_NOTICE([$PACKAGE_NAME-$PACKAGE_VERSION         A mediastreaming library for telephony application.])
  AC_MSG_NOTICE([licensed under the terms of the General Public License (GPL)])
---- mediastreamer-2.16.1/src/Makefile.am~      2017-04-06 11:27:56.000000000 +0200
-+++ mediastreamer-2.16.1/src/Makefile.am       2018-09-26 12:58:10.680232083 +0200
-@@ -467,7 +467,7 @@ endif
+--- mediastreamer2-4.4.2/src/Makefile.am.orig  2020-09-24 11:44:00.000000000 +0200
++++ mediastreamer2-4.4.2/src/Makefile.am       2020-09-27 14:14:05.564721694 +0200
+@@ -83,6 +83,7 @@
+                                       base/mswebcam.c \
+                                       base/mtu.c \
+                                       base/msasync.c \
++                                      utils/box-plot.c \
+                                       otherfilters/void.c \
+                                       otherfilters/itc.c
+ libmediastreamer_voip_la_SOURCES=
+@@ -117,6 +118,8 @@
+                                       voip/bandwidthcontroller.c \
+                                       crypto/zrtp.c \
+                                       voip/stun.c \
++                                      voip/offeranswer.c \
++                                      voip/turn_tcp.cpp \
+                                       crypto/ms_srtp.c \
+                                       crypto/dtls_srtp.c \
+                                       voip/msiframerequestslimiter.c \
+@@ -152,6 +155,8 @@
+                                       utils/g722.h \
+                                       utils/g722_decode.c \
+                                       utils/g722_encode.c \
++                                      utils/filter-wrapper/decoding-filter-wrapper.cpp \
++                                      utils/filter-wrapper/encoding-filter-wrapper.cpp \
+                                       audiofilters/msg722.c \
+                                       audiofilters/l16.c \
+                                       audiofilters/genericplc.h \
+@@ -257,7 +262,7 @@
+ libmediastreamer_voip_la_SOURCES+=    videofilters/msv4l2.c
+ endif
+-if BUILD_WIN32 AND NOT(ENABLE_MICROSOFT_STORE_APP)
++if BUILD_WIN32
+ libmediastreamer_voip_la_SOURCES+=    videofilters/drawdib-display.c
+ endif
+@@ -270,17 +275,16 @@
+ endif
+ if BUILD_MATROSKA
+-libmediastreamer_voip_la_SOURCES+=    videofilters/mkv.c \
++libmediastreamer_voip_la_SOURCES+=    videofilters/mkv.cpp \
+                                       utils/mkv_reader.c utils/mkv_reader.h
+ endif
+ if BUILD_AVCODEC
+ libmediastreamer_voip_la_SOURCES+=    videofilters/videoenc.c \
+                                       videofilters/videodec.c \
+-                                      utils/swscale.h \
+                                       utils/ffmpeg-priv.h \
+                                       utils/ffmpeg-priv.c \
+-                                      videofilters/h264dec.c \
++                                      videofilters/h264dec.cpp \
+                                       videofilters/ffmpegjpegwriter.c
+ endif
+@@ -303,7 +307,6 @@
+                                       voip/msvideoqualitycontroller.c \
+                                       voip/msvideo_neon.c \
+                                       voip/msvideo_neon.h \
+-                                      voip/rfc3984.c \
+                                       voip/videostarter.c \
+                                       voip/vp8rtpfmt.c \
+                                       voip/vp8rtpfmt.h \
+@@ -313,10 +316,22 @@
+                                       utils/bits_rw.c \
+                                       utils/x11_helper.c \
+                                       utils/stream_regulator.c utils/stream_regulator.h \
+-                                      utils/h264utils.c utils/h264utils.h \
+                                       voip/layouts.c voip/layouts.h \
+                                       voip/video_preset_high_fps.c
++libmediastreamer_voip_la_SOURCES+=    voip/h26x/h26x-encoder-filter.cpp \
++                                      voip/h26x/h26x-decoder-filter.cpp \
++                                      voip/h26x/h26x-utils.cpp \
++                                      voip/h26x/h264-nal-packer.cpp \
++                                      voip/h26x/h264-nal-unpacker.cpp \
++                                      voip/h26x/h264-utils.cpp \
++                                      voip/h26x/h265-nal-packer.cpp \
++                                      voip/h26x/h265-nal-unpacker.cpp \
++                                      voip/h26x/h265-utils.cpp \
++                                      voip/h26x/nal-packer.cpp \
++                                      voip/h26x/nal-unpacker.cpp \
++                                      voip/h26x/rfc3984.cpp
++
+ if ORTP_ENABLED
+ libmediastreamer_voip_la_SOURCES+=    voip/videostream.c
+ endif
+@@ -468,7 +483,7 @@
  
  AM_OBJCFLAGS=$(AM_CFLAGS)
  
 -imgdir=$(datadir)/images/
-+imgdir=$(datadir)/pixmaps/
++imgdir=$(pkgdatadir)/images/
  
  img_DATA=voip/nowebcamCIF.jpg
  
---- mediastreamer-2.16.1/src/base/msfactory.c~ 2017-07-20 15:56:05.000000000 +0200
-+++ mediastreamer-2.16.1/src/base/msfactory.c  2018-09-26 13:00:39.631224915 +0200
-@@ -231,7 +231,7 @@ void ms_factory_init(MSFactory *obj){
+--- mediastreamer2-4.4.2/src/base/msfactory.c.orig     2020-09-24 11:44:00.000000000 +0200
++++ mediastreamer2-4.4.2/src/base/msfactory.c  2020-09-26 18:00:06.215992977 +0200
+@@ -236,7 +236,7 @@
        ms_message("ms_factory_init() done: platform_tags=%s", tags);
        ms_free(tags);
-       obj->echo_canceller_filtername = ms_strdup("MSWebRTCAECM");
 -      obj->image_resources_dir = bctbx_strdup_printf("%s/images", PACKAGE_DATA_DIR);
-+      obj->image_resources_dir = bctbx_strdup_printf("/usr/share/pixmaps");
++      obj->image_resources_dir = bctbx_strdup_printf("%s/mediastreamer/images", PACKAGE_DATA_DIR);
  }
  
  
diff --git a/libsrtp2.patch b/libsrtp2.patch
deleted file mode 100644 (file)
index 91cbae0..0000000
+++ /dev/null
@@ -1,241 +0,0 @@
-diff -u -r mediastreamer2-2.16.1/configure.ac mediastreamer2-2.16.1-libsrtp2/configure.ac
---- mediastreamer2-2.16.1/configure.ac 2017-07-21 15:00:47.000000000 +0200
-+++ mediastreamer2-2.16.1-libsrtp2/configure.ac        2018-01-13 00:06:22.194089121 +0100
-@@ -1041,7 +1041,7 @@
- dnl check for libsrtp support (secure rtp)
- AC_ARG_WITH(srtp,
--      AC_HELP_STRING([--with-srtp], [Set prefix where libsrtp can be found or "none" to disable (ex:/usr or /usr/local) [[default=/usr]]]),
-+      AC_HELP_STRING([--with-srtp], [Set prefix where libsrtp2 can be found or "none" to disable (ex:/usr or /usr/local) [[default=/usr]]]),
-       [srtp_prefix=$withval],
-       [if test "$prefix" != "NONE"; then
-               srtp_prefix=$prefix
-@@ -1051,22 +1051,22 @@
- if test "${srtp_prefix}" != "none" ; then
-       if test "${srtp_prefix}" != "/usr" ; then
--              SRTP_CFLAGS="-I${srtp_prefix}/include -I${srtp_prefix}/include/srtp"
-+              SRTP_CFLAGS="-I${srtp_prefix}/include -I${srtp_prefix}/include/srtp2"
-               SRTP_LIBS="-L${srtp_prefix}/lib"
-       fi
--      SRTP_LIBS="$SRTP_LIBS -lsrtp"
-+      SRTP_LIBS="$SRTP_LIBS -lsrtp2"
-       dnl check srtp headers
-       CPPFLAGS_save=$CPPFLAGS
-       CPPFLAGS="$CPPFLAGS $SRTP_CFLAGS"
--      AC_CHECK_HEADER([srtp/srtp.h],have_srtp_headers=yes)
-+      AC_CHECK_HEADER([srtp2/srtp.h],have_srtp_headers=yes)
-       CPPFLAGS=$CPPFLAGS_save
-       dnl check for srtp lib
-       LDFLAGS_save=$LDFLAGS
-       LDFLAGS="$LDFLAGS $SRTP_LIBS"
-       LIBS_save=$LIBS
--      AC_CHECK_LIB(srtp,[srtp_init, crypto_policy_set_aes_cm_256_hmac_sha1_80, crypto_policy_set_aes_cm_256_hmac_sha1_32], have_srtp_lib=yes)
-+      AC_CHECK_LIB(srtp2,[srtp_init, srtp_crypto_policy_set_aes_cm_256_hmac_sha1_80, srtp_crypto_policy_set_aes_cm_256_hmac_sha1_32], have_srtp_lib=yes)
-       LDFLAGS=$LDFLAGS_save
-       LIBS=$LIBS_save
-@@ -1075,9 +1075,9 @@
-               LIBS_save=$LIBS
-               LDFLAGS="$LDFLAGS $SRTP_LIBS"
-               AC_CHECK_LIB(
--                      srtp,
-+                      srtp2,
-                       sha1_update,[
--                              AC_MSG_WARN([This libsrtp version exports symbols conflicting with polarssl, resulting in a bad execution path. libsrtp will be statically linked])
-+                              AC_MSG_WARN([This libsrtp2 version exports symbols conflicting with polarssl, resulting in a bad execution path. libsrtp2 will be statically linked])
-                               srtp_polarssl_conflict=yes
-                       ],
-                       srtp_polarssl_conflict=no
-@@ -1086,13 +1086,13 @@
-               LIBS=$LIBS_save
-               if test "$srtp_polarssl_conflict" = "yes"; then
--                      srtp_static_lib="${srtp_prefix}/lib/libsrtp.a"
-+                      srtp_static_lib="${srtp_prefix}/lib/libsrtp2.a"
-                       if test -f $srtp_static_lib -a -r $srtp_static_lib; then
--                              SRTP_LIBS="${srtp_prefix}/lib/libsrtp.a -Bsymbolic -Wl,--version-script=\$(top_srcdir)/src/libsrtp.map"
-+                              SRTP_LIBS="${srtp_prefix}/lib/libsrtp2.a -Bsymbolic -Wl,--version-script=\$(top_srcdir)/src/libsrtp2.map"
-                               AC_DEFINE(HAVE_SRTP, 1, [Defined when srtp support is compiled])
-                               have_srtp=true
-                       else
--                              AC_MSG_WARN([Could not access to $srtp_static_lib. Please use --with-srtp=PREFIX to specify the prefix where libsrtp.a has been installed])
-+                              AC_MSG_WARN([Could not access to $srtp_static_lib. Please use --with-srtp=PREFIX to specify the prefix where libsrtp2.a has been installed])
-                               SRTP_CFLAGS=
-                               SRTP_LIBS=
-                               have_srtp=true
-diff -u -r mediastreamer2-2.16.1/src/crypto/ms_srtp.c mediastreamer2-2.16.1-libsrtp2/src/crypto/ms_srtp.c
---- mediastreamer2-2.16.1/src/crypto/ms_srtp.c 2017-07-21 15:00:47.000000000 +0200
-+++ mediastreamer2-2.16.1-libsrtp2/src/crypto/ms_srtp.c        2018-01-13 00:14:48.575306030 +0100
-@@ -38,7 +38,7 @@
- // Windows phone doesn't use make install
- #include <srtp.h>
- #else
--#include <srtp/srtp.h>
-+#include <srtp2/srtp.h>
- #endif
-@@ -99,7 +99,7 @@
- /**** Sender functions ****/
- static int _process_on_send(RtpSession* session,MSSrtpStreamContext *ctx, mblk_t *m){
-       int slen;
--      err_status_t err;
-+      srtp_err_status_t err;
-       bool_t is_rtp=ctx->is_rtp;
-       rtp_header_t *rtp_header=is_rtp?(rtp_header_t*)m->b_rptr:NULL;
-       rtcp_common_header_t *rtcp_header=!is_rtp?(rtcp_common_header_t*)m->b_rptr:NULL;
-@@ -109,7 +109,7 @@
-               ms_mutex_lock(&ctx->mutex);
-               if (!ctx->secured) {
-                       /*does not make sense to protect, because we don't have any key*/
--                      err=err_status_ok;
-+                      err=srtp_err_status_ok;
-                       slen = 0; /*droping packets*/
-               } else {
-                       /* defragment incoming message and enlarge the buffer for srtp to write its data */
-@@ -120,7 +120,7 @@
-       } else if (rtcp_header && (slen>RTP_FIXED_HEADER_SIZE && rtcp_header->version==2)) {
-               ms_mutex_lock(&ctx->mutex);
-               if (!ctx->secured) {
--                      err=err_status_ok;
-+                      err=srtp_err_status_ok;
-                       /*does not make sense to protect, because we don't have any key*/
-                       slen = 0; /*droping packets*/
-               } else {
-@@ -135,7 +135,7 @@
-       }
-       /* check return code from srtp_protect */
--      if (err==err_status_ok){
-+      if (err==srtp_err_status_ok){
-               return slen;
-       }
-       ortp_error("srtp_protect%s() failed (%d) for stream ctx [%p]", is_rtp?"":"_rtcp", err,ctx);
-@@ -151,7 +151,7 @@
- }
- static int _process_on_receive(RtpSession* session,MSSrtpStreamContext *ctx, mblk_t *m, int err){
-       int slen;
--      err_status_t srtp_err;
-+      srtp_err_status_t srtp_err;
-       bool_t is_rtp=ctx->is_rtp;
-       /* keep NON-RTP data unencrypted */
-@@ -167,7 +167,7 @@
-       slen=err;
-       srtp_err = is_rtp?srtp_unprotect(ctx->srtp,m->b_rptr,&slen):srtp_unprotect_rtcp(ctx->srtp,m->b_rptr,&slen);
--      if (srtp_err==err_status_ok) {
-+      if (srtp_err==srtp_err_status_ok) {
-               return slen;
-       } else {
-               ms_error("srtp_unprotect%s() failed (%d) on stream ctx [%p]", is_rtp?"":"_rtcp", srtp_err,ctx);
-@@ -201,7 +201,7 @@
- static int ms_media_stream_session_fill_srtp_context(MSMediaStreamSessions *sessions, bool_t is_send, bool_t is_rtp) {
--      err_status_t err=0;
-+      srtp_err_status_t err=0;
-       RtpTransport *transport=NULL;
-       MSSrtpStreamContext* stream_ctx = get_stream_context(sessions,is_send,is_rtp);
-@@ -258,28 +258,28 @@
- }
--static int ms_set_srtp_crypto_policy(MSCryptoSuite suite, crypto_policy_t *policy) {
-+static int ms_set_srtp_srtp_crypto_policy(MSCryptoSuite suite, srtp_crypto_policy_t *policy) {
-       switch(suite){
-               case MS_AES_128_SHA1_32:
-                       // srtp doc says: not adapted to rtcp...
--                      crypto_policy_set_aes_cm_128_hmac_sha1_32(policy);
-+                      srtp_crypto_policy_set_aes_cm_128_hmac_sha1_32(policy);
-                       break;
-               case MS_AES_128_NO_AUTH:
-                       // srtp doc says: not adapted to rtcp...
--                      crypto_policy_set_aes_cm_128_null_auth(policy);
-+                      srtp_crypto_policy_set_aes_cm_128_null_auth(policy);
-                       break;
-               case MS_NO_CIPHER_SHA1_80:
--                      crypto_policy_set_null_cipher_hmac_sha1_80(policy);
-+                      srtp_crypto_policy_set_null_cipher_hmac_sha1_80(policy);
-                       break;
-               case MS_AES_128_SHA1_80: /*default mode*/
--                      crypto_policy_set_aes_cm_128_hmac_sha1_80(policy);
-+                      srtp_crypto_policy_set_aes_cm_128_hmac_sha1_80(policy);
-                       break;
-               case MS_AES_256_SHA1_80: // For backward compatibility
-               case MS_AES_CM_256_SHA1_80:
--                  crypto_policy_set_aes_cm_256_hmac_sha1_80(policy);
--            break;
-+                      srtp_crypto_policy_set_aes_cm_256_hmac_sha1_80(policy);
-+                      break;
-               case MS_AES_256_SHA1_32:
--                      crypto_policy_set_aes_cm_256_hmac_sha1_32(policy);
-+                      srtp_crypto_policy_set_aes_cm_256_hmac_sha1_32(policy);
-                       break;
-               case MS_CRYPTO_SUITE_INVALID:
-                       return -1;
-@@ -291,13 +291,13 @@
- static int ms_add_srtp_stream(srtp_t srtp, MSCryptoSuite suite, uint32_t ssrc, const char* key, size_t key_length, bool_t is_send, bool_t is_rtp)
- {
-       srtp_policy_t policy;
--      err_status_t err;
--      ssrc_t ssrc_conf;
-+      srtp_err_status_t err;
-+      srtp_ssrc_t ssrc_conf;
-       memset(&policy,0,sizeof(policy));
-       if (is_rtp) {
--              if (ms_set_srtp_crypto_policy(suite, &policy.rtp) != 0) {
-+              if (ms_set_srtp_srtp_crypto_policy(suite, &policy.rtp) != 0) {
-                       return -1;
-               }
-               /* check if key length match given policy */
-@@ -306,7 +306,7 @@
-                       return -1;
-               }
-       }else {
--              if (ms_set_srtp_crypto_policy(suite, &policy.rtcp) != 0) {
-+              if (ms_set_srtp_srtp_crypto_policy(suite, &policy.rtcp) != 0) {
-                       return -1;
-               }
-               if ((int)key_length != policy.rtcp.cipher_key_len) {
-@@ -326,7 +326,7 @@
-       policy.next = NULL;
-       err = srtp_add_stream(srtp, &policy);
--      if (err != err_status_ok) {
-+      if (err != srtp_err_status_ok) {
-               ms_error("Failed to add stream to srtp session (%d)", err);
-               return -1;
-       }
-@@ -344,7 +344,7 @@
- int ms_srtp_init(void)
- {
--      err_status_t st=0;
-+      srtp_err_status_t st=0;
-       ms_message("srtp init");
-       if (!srtp_init_done) {
-               st=srtp_init();
-@@ -352,7 +352,6 @@
-                       srtp_init_done++;
-               }else{
-                       ms_fatal("Couldn't initialize SRTP library: %d.", st);
--                      err_reporting_init("mediastreamer2");
-               }
-       }else srtp_init_done++;
-       return (int)st;
-@@ -508,7 +507,7 @@
- #else /* HAVE_SRTP */
- typedef void* srtp_t;
--typedef int err_status_t;
-+typedef int srtp_err_status_t;
- bool_t ms_srtp_supported(void){
-       return FALSE;
index e596ecfe7da5d46552d130fedb0da9a75a101fd0..a26091e5ed21eac72b0a0ea5e74bee30f0a9d949 100644 (file)
@@ -456,3 +456,23 @@ diff -ur mediastreamer-2.16.1/src/upnp/upnp_igd_utils.h mediastreamer-2.16.1-upn
  char *upnp_igd_get_first_document_item(upnp_igd_context *uIGD, IXML_Document *doc, const char *item);
  char *upnp_igd_get_element_value(upnp_igd_context *uIGD, IXML_Element *element);
  char *upnp_igd_get_first_element_item(upnp_igd_context *uIGD,IXML_Element *element, const char *item);
+--- mediastreamer2-4.4.2/configure.ac.orig     2021-07-05 06:50:46.295451589 +0200
++++ mediastreamer2-4.4.2/configure.ac  2021-07-05 17:16:33.665373367 +0200
+@@ -717,7 +717,7 @@ AC_ARG_ENABLE(upnp,
+ if test "$build_upnp" != "false" ; then
+       PKG_CHECK_MODULES([LIBUPNP], [libupnp],
+-              [if  pkg-config --atleast-version=1.6 "libupnp < 1.7"; then
++              [if  pkg-config --atleast-version=1.8 "libupnp"; then
+                       build_upnp=true
+                       old_CFLAGS="$CFLAGS"
+                       CFLAGS="$CFLAGS $LIBUPNP_CFLAGS -Werror -Wno-error=unused-variable"
+@@ -730,7 +730,7 @@ if test "$build_upnp" != "false" ; then
+                       AC_DEFINE(USE_PATCHED_UPNP, 1, [Define if upnp is patched]))
+                       CFLAGS="$old_CFLAGS"
+               else
+-                      AC_MSG_ERROR([libupnp >= 1.6 < 1.5 required.])
++                      AC_MSG_ERROR([libupnp >= 1.8 required.])
+               fi],
+               [if test "$build_upnp" == "true" ; then
+                       AC_MSG_ERROR([libupnp not found.])
index 70fde3973eebc7f196066fba8c7b52e30c2b24f9..cd600d135e844eee5430a25c9ec6e7a1ab8cc350 100644 (file)
 Summary:       Audio/Video real-time streaming
 Summary(pl.UTF-8):     PrzesyƂanie strumieni audio/video w czasie rzeczywistym 
 Name:          mediastreamer
-Version:       2.16.1
-Release:       10
-License:       GPL v2+
+Version:       4.4.2
+Release:       1
+License:       GPL v3+
 Group:         Libraries
-Source0:       https://linphone.org/releases/sources/mediastreamer/%{name}-%{version}.tar.gz
-# Source0-md5: 15b8b129a922180855d04d58cdd08d43
+#Source0Download: https://gitlab.linphone.org/BC/public/mediastreamer2/tags
+Source0:       https://gitlab.linphone.org/BC/public/mediastreamer2/-/archive/%{version}/mediastreamer2-%{version}.tar.bz2
+# Source0-md5: f2fe330ad7a65dcab407c311f98fc829
 Patch0:                build.patch
-Patch1:                libsrtp2.patch
 Patch2:                libupnp-1.14.patch
 URL:           http://www.linphone.org/technical-corner/mediastreamer2/overview
 %{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
@@ -32,7 +32,7 @@ BuildRequires:        SDL-devel >= 1.2.0
 %{?with_arts:BuildRequires:    artsc-devel}
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake >= 1:1.9
-%{?with_bcg729:BuildRequires:  bcg729-devel >= 1.0}
+%{?with_bcg729:BuildRequires:  bcg729-devel >= 1.0.1}
 BuildRequires: bctoolbox-devel >= 0.4.0
 %{?with_zrtp:BuildRequires:    bzrtp-devel >= 1.0.6}
 BuildRequires: doxygen
@@ -43,6 +43,7 @@ BuildRequires:        gettext-tools
 BuildRequires: intltool >= 0.40
 BuildRequires: libgsm-devel
 %{?with_pcap:BuildRequires:    libpcap-devel}
+BuildRequires: libstdc++-devel >= 6:5
 BuildRequires: libtheora-devel >= 1.0-0.alpha7
 BuildRequires: libtool >= 2:2
 BuildRequires: libupnp-devel
@@ -62,7 +63,8 @@ BuildRequires:        speexdsp-devel >= 1.2-beta3
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: xxd
-%{?with_bcg729:Requires:       bcg729 >= 1.0}
+BuildRequires: zxing-cpp-devel
+%{?with_bcg729:Requires:       bcg729 >= 1.0.1}
 Requires:      bctoolbox >= 0.4.0
 %{?with_zrtp:Requires: bzrtp >= 1.0.6}
 %{?with_opengl:Requires:       glew >= 1.5}
@@ -94,7 +96,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 %{?with_opengl:Requires:       OpenGL-devel}
 %{?with_alsa:Requires: alsa-lib-devel}
-%{?with_bcg729:Requires:       bcg729-devel >= 1.0}
+%{?with_bcg729:Requires:       bcg729-devel >= 1.0.1}
 Requires:      bctoolbox-devel >= 0.4.0
 %{?with_zrtp:Requires: bzrtp-devel >= 1.0.6}
 Requires:      ffmpeg-devel
@@ -135,9 +137,8 @@ Static mediastreamer libraries.
 Statyczne biblioteki mediastreamer.
 
 %prep
-%setup -q
+%setup -q -n mediastreamer2-%{version}
 %patch0 -p1
-%patch1 -p1
 %patch2 -p1
 
 [ ! -e gitversion.h ] && echo '#define MS2_GIT_VERSION "%{version}"' > src/gitversion.h
@@ -155,8 +156,8 @@ Statyczne biblioteki mediastreamer.
        --disable-tests \
        --enable-alsa%{!?with_alsa:=no} \
        %{?with_arts:--enable-artsc} \
-       %{?with_bcg729:--enable-bcg729} \
        --enable-external-ortp \
+       %{?with_bcg729:--enable-g729 --enable-g729bCN} \
        %{!?with_opengl:--disable-glx} \
        %{!?with_matroska:--disable-matroska} \
        %{!?with_pcap:--disable-pcap} \
@@ -164,6 +165,7 @@ Statyczne biblioteki mediastreamer.
        --enable-pulseaudio%{!?with_pulseaudio:=no} \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
+       --enable-upnp \
        %{!?with_zrtp:--disable-zrtp} \
        %{!?with_srtp:--with-srtp=none}
 
@@ -192,7 +194,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README.md
+%doc CHANGELOG.md README.md
 %attr(755,root,root) %{_bindir}/mediastream
 %attr(755,root,root) %{_bindir}/msaudiocmp
 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
@@ -202,7 +204,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_voip.so.10
 %dir %{_libdir}/mediastreamer
 %dir %{_libdir}/mediastreamer/plugins
-%{_pixmapsdir}/nowebcamCIF.jpg
+%{_datadir}/mediastreamer
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.306029 seconds and 4 git commands to generate.