]> git.pld-linux.org Git - packages/mediastreamer.git/commitdiff
- proper License tag (GPL v2+)
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 18 Jun 2013 19:47:58 +0000 (21:47 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 18 Jun 2013 19:47:58 +0000 (21:47 +0200)
- pl
- completed dependencies
- enable pulseaudio by default

mediastreamer.spec

index 62bc9d31d92c9c42e3207197f41ada1e30a4dea1..4dad720b8078b9c8e69cbe52e9b5e99f54cebbbb 100644 (file)
@@ -1,32 +1,59 @@
+#
+# Conditional build:
+%bcond_without opengl          # X11+OpenGL rendering support
+%bcond_with    pcap            # audio playing from PCAP files
+%bcond_without pulseaudio      # PulseAudio support
+#
 Summary:       Audio/Video real-time streaming
+Summary(pl.UTF-8):     Przesyłanie strumieni audio/video w czasie rzeczywistym 
 Name:          mediastreamer
 Version:       2.9.0
 Release:       1
-License:       LGPL
+License:       GPL v2+
 Group:         Libraries
-Source0:       http://mirror.lihnidos.org/GNU/savannah/linphone/mediastreamer/%{name}-%{version}.tar.gz
+Source0:       http://download-mirror.savannah.gnu.org/releases/linphone/mediastreamer/%{name}-%{version}.tar.gz
 # Source0-md5: f2ea0fe731a363749a81b6eaac22a62c
 Patch0:                %{name}-imagedir.patch
 URL:           http://www.linphone.org/eng/documentation/dev/mediastreamer2.html
-BuildRequires: SDL-devel
+%{?with_opengl:BuildRequires:  OpenGL-GLX-devel}
+BuildRequires: SDL-devel >= 1.2.0
 BuildRequires: alsa-lib-devel
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
 BuildRequires: doxygen
+# libavcodec >= 51.0.0, libswscale >= 0.7.0
 BuildRequires: ffmpeg-devel
+BuildRequires: gettext-devel
+%{?with_opengl:BuildRequires:  glew-devel >= 1.5}
 BuildRequires: jack-audio-connection-kit-devel
+BuildRequires: intltool >= 0.40
 BuildRequires: libgsm-devel
-BuildRequires: libsamplerate-devel
-BuildRequires: libtheora-devel
+%{?with_pcap:BuildRequires:    libpcap-devel}
+BuildRequires: libtheora-devel >= 1.0-0.alpha7
+BuildRequires: libtool >= 2:2
+BuildRequires: libupnp-devel >= 1.6
+BuildRequires: libupnp-devel < 1.7
 BuildRequires: libv4l-devel
+BuildRequires: libvpx-devel >= 0.9.6
+BuildRequires: opus-devel >= 0.9.0
 BuildRequires: ortp-devel >= 0.21.0
 BuildRequires: pkgconfig
+%{?with_pulseaudio:BuildRequires:      pulseaudio-devel >= 0.9.21}
 BuildRequires: sed >= 4.0
-BuildRequires: spandsp-devel
-BuildRequires: speex-devel
+BuildRequires: spandsp-devel >= 0.0.6
+BuildRequires: speex-devel >= 1.2-beta3
 BuildRequires: xorg-lib-libX11-devel
 BuildRequires: xorg-lib-libXv-devel
 BuildRequires: xxd
+%{?with_opengl:Requires:       glew >= 1.5}
+Requires:      libtheora >= 1.0-0.alpha7
+Requires:      libupnp >= 1.6
+Requires:      libvpx >= 0.9.6
+Requires:      opus >= 0.9.0
+Requires:      ortp >= 0.21.0
+%{?with_pulseaudio:Requires:   pulseaudio-libs >= 0.9.21}
+Requires:      spandsp-libs >= 0.0.6
+Requires:      speex >= 1.2-beta3
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -34,22 +61,51 @@ Mediastreamer2 is a GPL licensed library to make audio and video
 real-time streaming and processing. Written in pure C, it is based
 upon the oRTP library.
 
+%description -l pl.UTF-8
+Mediastreamer2 to udostępniona na licencji GPL biblioteka do
+przesyłania i przetwarzania strumieni audio/video w czasie
+rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
+
 %package devel
-Summary:       Header files and develpment documentation for mediastreamer
+Summary:       Header files and development documentation for mediastreamer library
+Summary(pl.UTF-8):     Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{version}-%{release}
+%{?with_opengl:Requires:       OpenGL-devel}
+Requires:      alsa-lib-devel
+Requires:      ffmpeg-devel
+%{?with_opengl:Requires:       glew-devel >= 1.5}
+Requires:      libtheora-devel >= 1.0-0.alpha7
+Requires:      libupnp-devel >= 1.6
+Requires:      libupnp-devel < 1.7
+Requires:      libv4l-devel
+Requires:      libvpx-devel >= 0.9.6
+Requires:      opus-devel >= 0.9.0
+Requires:      ortp-devel >= 0.21.0
+%{?with_pulseaudio:Requires:   pulseaudio-devel >= 0.9.21}
+Requires:      spandsp-devel >= 0.0.6
+Requires:      speex-devel >= 1.2-beta3
+Requires:      xorg-lib-libX11-devel
+Requires:      xorg-lib-libXv-devel
 
 %description devel
-Header files and develpment documentation for mediastreamer.
+Header files and development documentation for mediastreamer library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe i dokumentacja do biblioteki mediastreamer.
 
 %package static
 Summary:       Static mediastreamer library
+Summary(pl.UTF-8):     Statyczna biblioteka mediastreamer
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Static mediastreamer library.
 
+%description static -l pl.UTF-8
+Statyczna biblioteka mediastreamer.
+
 %prep
 %setup -q
 %patch0 -p1
@@ -58,10 +114,15 @@ Static mediastreamer library.
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure \
-       --enable-static \
-       --disable-tests
+       --enable-external-ortp \
+       %{!?with_opengl:--disable-glx} \
+       %{?with_pcap:--enable-pcap} \
+       %{?with_pulseaudio:--enable-pulseaudio} \
+       --disable-silent-rules \
+       --enable-static
 
 %{__make}
 
@@ -72,7 +133,7 @@ rm -rf $RPM_BUILD_ROOT
        DESTDIR=$RPM_BUILD_ROOT
 
 # Remove duplicated documentation
-rm -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html/
+%{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/%{name}-%{version}/html
 
 %find_lang %{name}
 
@@ -84,7 +145,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README help/doc/html
+%doc AUTHORS ChangeLog NEWS README
+%attr(755,root,root) %{_bindir}/mediastream
+%{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
 %attr(755,root,root) %{_libdir}/libmediastreamer_base.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libmediastreamer_base.so.3
 %attr(755,root,root) %{_libdir}/libmediastreamer_voip.so.*.*
This page took 0.034936 seconds and 4 git commands to generate.