]> git.pld-linux.org Git - packages/mediastreamer.git/blob - mediastreamer.spec
fe6fda3a1c678beff92f06bc6cae079a4f6820d4
[packages/mediastreamer.git] / mediastreamer.spec
1 #
2 # Conditional build:
3 %bcond_with     pcap            # audio playing from PCAP files
4 %bcond_without  static_libs     # static library
5 # transport
6 %bcond_without  srtp            # SRTP (secure RTP) support
7 %bcond_without  zrtp            # support for RFC 6189: Media Path Key Agreement for Unicast Secure RTP
8 # audio I/O
9 %bcond_without  alsa            # ALSA sound I/O support
10 %bcond_with     arts            # aRts sound I/O support
11 %bcond_with     oss             # OSS support (deprecated)
12 %bcond_with     portaudio       # PortAudio sound I/O support
13 %bcond_without  pulseaudio      # PulseAudio sound I/O support
14 # audio codecs
15 %bcond_without  bcg729          # support for G279AnnexB in RTC3389 implementation of Comfort Noise Payload
16 %bcond_without  bv16            # BV16 codec support
17 %bcond_without  spandsp         # G726 codec support via spandsp
18 # video I/O
19 %bcond_without  opengl          # X11+OpenGL rendering support
20 %bcond_without  sdl             # SDL support
21 # video codecs
22 %bcond_without  matroska        # Matroska support via bcmatroska2
23 %bcond_without  zxing           # QRcode support via zxing-cpp
24 #
25 Summary:        Audio/Video real-time streaming
26 Summary(pl.UTF-8):      Przesyłanie strumieni audio/video w czasie rzeczywistym 
27 Name:           mediastreamer
28 # note: 5.2.x is AGPL-licensed; see DEVEL-5.2 branch
29 Version:        5.1.72
30 Release:        2
31 License:        GPL v3+
32 Group:          Libraries
33 #Source0Download: https://gitlab.linphone.org/BC/public/mediastreamer2/tags
34 Source0:        https://gitlab.linphone.org/BC/public/mediastreamer2/-/archive/%{version}/mediastreamer2-%{version}.tar.bz2
35 # Source0-md5:  8b27b959e5872ac9625ab6740aab7376
36 Patch0:         build.patch
37 Patch1:         %{name}-cmake-link.patch
38 Patch2:         libupnp-1.14.patch
39 Patch3:         %{name}-cmake-datadir.patch
40 Patch4:         %{name}-cmake-install-pkgconfig.patch
41 Patch5:         %{name}-cmake-SDL.patch
42 Patch6:         %{name}-types.patch
43 Patch7:         %{name}-gsm.patch
44 Patch8:         %{name}-cmake-upnp.patch
45 Patch9:         %{name}-bzrtp.patch
46 Patch10:        %{name}-gcc.patch
47 URL:            http://www.linphone.org/technical-corner/mediastreamer2/overview
48 %{?with_opengl:BuildRequires:   OpenGL-GLX-devel}
49 %{?with_sdl:BuildRequires:      SDL-devel >= 1.2.0}
50 %{?with_alsa:BuildRequires:     alsa-lib-devel}
51 %{?with_arts:BuildRequires:     artsc-devel}
52 %{?with_bcg729:BuildRequires:   bcg729-devel >= 1.1.1-1}
53 %{?with_matroska:BuildRequires: bcmatroska2-devel >= 5.1}
54 BuildRequires:  bctoolbox-devel >= 0.4.0
55 %{?with_bv16:BuildRequires:     bv16-floatingpoint-devel}
56 %{?with_zrtp:BuildRequires:     bzrtp-devel >= 5.2.51}
57 BuildRequires:  cmake >= 3.1
58 BuildRequires:  doxygen
59 # libavcodec >= 51.0.0, libswscale >= 0.7.0
60 BuildRequires:  ffmpeg-devel
61 BuildRequires:  gettext-tools
62 %{?with_opengl:BuildRequires:   glew-devel >= 1.5}
63 BuildRequires:  intltool >= 0.40
64 BuildRequires:  libgsm-devel
65 BuildRequires:  libjpeg-turbo-devel
66 %{?with_pcap:BuildRequires:     libpcap-devel}
67 BuildRequires:  libstdc++-devel >= 6:5
68 BuildRequires:  libtheora-devel >= 1.0-0.alpha7
69 BuildRequires:  libupnp-devel >= 1.8
70 BuildRequires:  libv4l-devel
71 BuildRequires:  libvpx-devel >= 0.9.6
72 BuildRequires:  libyuv-devel
73 BuildRequires:  opus-devel >= 0.9.0
74 BuildRequires:  ortp-devel >= 5.1
75 BuildRequires:  pkgconfig
76 %{?with_portaudio:BuildRequires:        portaudio-devel}
77 %{?with_pulseaudio:BuildRequires:       pulseaudio-devel >= 0.9.21}
78 BuildRequires:  python3 >= 1:3
79 BuildRequires:  sed >= 4.0
80 %{?with_spandsp:BuildRequires:  spandsp-devel >= 0.0.6}
81 BuildRequires:  speex-devel >= 1:1.2-beta3
82 BuildRequires:  speexdsp-devel >= 1.2-beta3
83 %{?with_srtp:BuildRequires:     libsrtp2-devel}
84 BuildRequires:  xorg-lib-libX11-devel
85 BuildRequires:  xorg-lib-libXv-devel
86 %{?with_zxing:BuildRequires:    zxing-cpp-devel}
87 %{?with_bcg729:Requires:        bcg729 >= 1.1.1-1}
88 %{?with_matroska:Requires:      bcmatroska2 >= 5.1}
89 Requires:       bctoolbox >= 0.4.0
90 %{?with_zrtp:Requires:  bzrtp >= 5.2.51}
91 %{?with_opengl:Requires:        glew >= 1.5}
92 Requires:       libtheora >= 1.0-0.alpha7
93 Requires:       libvpx >= 0.9.6
94 Requires:       opus >= 0.9.0
95 Requires:       ortp >= 5.1
96 %{?with_pulseaudio:Requires:    pulseaudio-libs >= 0.9.21}
97 Requires:       spandsp >= 0.0.6
98 Requires:       speex >= 1:1.2-beta3
99 Requires:       speexdsp >= 1.2-beta3
100 Obsoletes:      mediastreamer-plugin-msbcg729 < 1.1
101 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
102
103 %description
104 Mediastreamer2 is a GPL licensed library to make audio and video
105 real-time streaming and processing. Written in pure C, it is based
106 upon the oRTP library.
107
108 %description -l pl.UTF-8
109 Mediastreamer2 to udostępniona na licencji GPL biblioteka do
110 przesyłania i przetwarzania strumieni audio/video w czasie
111 rzeczywistym. Jest napisana w czystym C, oparta na bibliotece oRTP.
112
113 %package devel
114 Summary:        Header files and development documentation for mediastreamer libraries
115 Summary(pl.UTF-8):      Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer
116 Group:          Development/Libraries
117 Requires:       %{name} = %{version}-%{release}
118 %{?with_opengl:Requires:        OpenGL-devel}
119 %{?with_alsa:Requires:  alsa-lib-devel}
120 %{?with_bcg729:Requires:        bcg729-devel >= 1.1.1-1}
121 %{?with_matroska:Requires:      bcmatroska2-devel >= 5.1}
122 Requires:       bctoolbox-devel >= 0.4.0
123 %{?with_bv16:Requires:  bv16-floatingpoint-devel}
124 %{?with_zrtp:Requires:  bzrtp-devel >= 5.2.51}
125 Requires:       ffmpeg-devel
126 %{?with_opengl:Requires:        glew-devel >= 1.5}
127 Requires:       libtheora-devel >= 1.0-0.alpha7
128 Requires:       libupnp-devel >= 1.8
129 Requires:       libv4l-devel
130 Requires:       libvpx-devel >= 0.9.6
131 Requires:       opus-devel >= 0.9.0
132 Requires:       ortp-devel >= 5.1
133 %{?with_portaudio:Requires:     portaudio-devel}
134 %{?with_pulseaudio:Requires:    pulseaudio-devel >= 0.9.21}
135 Requires:       spandsp-devel >= 0.0.6
136 Requires:       speex-devel >= 1:1.2-beta3
137 Requires:       speexdsp-devel >= 1.2-beta3
138 %{?with_srtp:Requires:  libsrtp2-devel}
139 Requires:       xorg-lib-libX11-devel
140 Requires:       xorg-lib-libXv-devel
141
142 %description devel
143 Header files and development documentation for mediastreamer
144 libraries.
145
146 %description devel -l pl.UTF-8
147 Pliki nagłówkowe i dokumentacja do bibliotek mediastreamer.
148
149 %package static
150 Summary:        Static mediastreamer libraries
151 Summary(pl.UTF-8):      Statyczne biblioteki mediastreamer
152 Group:          Development/Libraries
153 Requires:       %{name}-devel = %{version}-%{release}
154
155 %description static
156 Static mediastreamer libraries.
157
158 %description static -l pl.UTF-8
159 Statyczne biblioteki mediastreamer.
160
161 %prep
162 %setup -q -n mediastreamer2-%{version}
163 %patch0 -p1
164 %patch1 -p1
165 %patch2 -p1
166 %patch3 -p1
167 %patch4 -p1
168 %patch5 -p1
169 %patch6 -p1
170 %patch7 -p1
171 %patch8 -p1
172 %patch9 -p1
173 %patch10 -p1
174
175 # cmake checks for python3, so don't require python 2 as well
176 %{__sed} -i -e '1s,/usr/bin/python$,%{__python3},' tools/xxd.py
177
178 %{__sed} -i -e 's/"-Werror" /"-Werror" "-Wno-error=address"/' CMakeLists.txt
179
180 %build
181 install -d builddir
182 cd builddir
183 # NLS missing in cmake
184 CPPFLAGS="%{rpmcppflags} -DENABLE_NLS=1 -DGETTEXT_PACKAGE=\"mediastreamer\" -DLOCALEDIR=\"%{_localedir}\""
185 # note: NON_FREE_CODECS refer to H263, H264, MPEG4 via libavcodec
186 %cmake .. \
187         -DCMAKE_INSTALL_INCLUDEDIR=include \
188         -DCMAKE_INSTALL_LIBDIR=%{_lib} \
189         -DDISABLE_BC_PACKAGE_SEARCH:BOOL=OFF \
190         %{!?with_alsa:-DENABLE_ALSA=OFF} \
191         %{?with_arts:-DENABLE_ARTSC=ON} \
192         %{!?with_bv16:-DENABLE_BV16=OFF} \
193         %{?with_spandsp:-DENABLE_G726=ON} \
194         %{!?with_bcg729:-DENABLE_G729=OFF} \
195         %{?with_bcg729:-DENABLE_G729B_CNG=ON} \
196         %{!?with_opengl:-DENABLE_GL=OFF} \
197         %{!?with_opengl:-DENABLE_GLX=OFF} \
198         %{!?with_matroska:-DENABLE_MKV=OFF} \
199         -DENABLE_NON_FREE_CODECS=ON \
200         %{?with_oss:-DENABLE_OSS=ON} \
201         %{?with_pcap:-DENABLE_PCAP=ON} \
202         %{?with_portaudio:-DENABLE_PORTAUDIO=ON} \
203         %{?with_pulseaudio:-DENABLE_PULSEAUDIO=ON} \
204         %{!?with_zxing:-DENABLE_QRCODE=OFF} \
205         %{?with_sdl:-DENABLE_SDL=ON} \
206         %{!?with_srtp:-DENABLE_SRTP=OFF} \
207         %{!?with_static_libs:-DENABLE_STATIC=OFF} \
208         -DENABLE_UNIT_TESTS=OFF \
209         %{!?with_zrtp:-DENABLE_ZRTP=OFF}
210
211 %{__make}
212
213 %install
214 rm -rf $RPM_BUILD_ROOT
215
216 %{__make} -C builddir install \
217         DESTDIR=$RPM_BUILD_ROOT
218
219 # disable completeness check incompatible with split packaging
220 %{__sed} -i -e '/^foreach(target .*IMPORT_CHECK_TARGETS/,/^endforeach/d; /^unset(_IMPORT_CHECK_TARGETS)/d' $RPM_BUILD_ROOT%{_datadir}/Mediastreamer2/cmake/Mediastreamer2Targets.cmake
221
222 # missing from install in cmake
223 install builddir/tools/msaudiocmp $RPM_BUILD_ROOT%{_bindir}
224 %if %{with pcap}
225 install builddir/tools/pcap_playback $RPM_BUILD_ROOT%{_bindir}
226 %endif
227 for f in po/*.po ; do
228         lang=$(basename "$f" .po)
229         install -d $RPM_BUILD_ROOT%{_localedir}/${lang}/LC_MESSAGES
230         msgfmt -v -o $RPM_BUILD_ROOT%{_localedir}/${lang}/LC_MESSAGES/%{name}.mo "$f"
231 done
232
233 # for external plugins
234 install -d $RPM_BUILD_ROOT%{_libdir}/mediastreamer/plugins
235
236 # we don't need another copy
237 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/OpenGL
238 # Remove duplicated documentation
239 %{__rm} -r $RPM_BUILD_ROOT/usr/share/doc/mediastreamer2-5.1.0/html
240
241 %find_lang %{name}
242
243 %clean
244 rm -rf $RPM_BUILD_ROOT
245
246 %post   -p /sbin/ldconfig
247 %postun -p /sbin/ldconfig
248
249 %files -f %{name}.lang
250 %defattr(644,root,root,755)
251 %doc CHANGELOG.md README.md
252 %attr(755,root,root) %{_bindir}/mediastream
253 %attr(755,root,root) %{_bindir}/mkvstream
254 %attr(755,root,root) %{_bindir}/msaudiocmp
255 %{?with_pcap:%attr(755,root,root) %{_bindir}/pcap_playback}
256 %attr(755,root,root) %{_libdir}/libmediastreamer.so.11
257 %dir %{_libdir}/mediastreamer
258 %dir %{_libdir}/mediastreamer/plugins
259 %{_datadir}/mediastreamer
260
261 %files devel
262 %defattr(644,root,root,755)
263 %doc builddir/help/doc/html/*.{css,html,js,png}
264 %attr(755,root,root) %{_libdir}/libmediastreamer.so
265 %{_includedir}/mediastreamer2
266 %{_pkgconfigdir}/mediastreamer.pc
267 %dir %{_datadir}/Mediastreamer2
268 %{_datadir}/Mediastreamer2/cmake
269
270 %if %{with static_libs}
271 %files static
272 %defattr(644,root,root,755)
273 %{_libdir}/libmediastreamer.a
274 %endif
This page took 0.121202 seconds and 2 git commands to generate.