]> git.pld-linux.org Git - packages/mediastreamer-plugin-msopenh264.git/commitdiff
- updated to 1.2.1 auto/th/mediastreamer-plugin-msopenh264-1.2.1-6
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Jun 2019 11:43:38 +0000 (13:43 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 1 Jun 2019 11:43:38 +0000 (13:43 +0200)
- removed obsolete openh264-1.6 patch

mediastreamer-plugin-msopenh264.spec
openh264-1.6.patch [deleted file]

index 1173da9a44bdcf8ce22130ba95864460a7e4de53..1f831628fba1a6befa036be90c6c5ea401ede19a 100644 (file)
@@ -1,23 +1,22 @@
 Summary:       H.264 video codec for mediastreamer based on the openh264 library
 Summary(pl.UTF-8):     Kodek obrazu H.264 dla mediastreamera oparty na bibliotece openh264
 Name:          mediastreamer-plugin-msopenh264
-Version:       1.1.1
+Version:       1.2.1
 Release:       6
 License:       GPL v2+
 Group:         Libraries
-Source0:       http://linphone.org/releases/sources/plugins/msopenh264/msopenh264-%{version}.tar.gz
-# Source0-md5: 7500abc43b1f3c935c97ea6a5c0d75ee
-Patch0:                openh264-1.6.patch
+Source0:       https://linphone.org/releases/sources/plugins/msopenh264/msopenh264-%{version}.tar.gz
+# Source0-md5: 8e4dfaed03dbe10d1b32d70eea23ce9c
 URL:           http://www.linphone.org/technical-corner/mediastreamer2/overview
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-BuildRequires: mediastreamer-devel >= 2.7.0
+BuildRequires: mediastreamer-devel >= 2.14.0
 BuildRequires: openh264-devel >= 1.4.0
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: pkgconfig
 Requires:      openh264 >= 1.4.0
-Requires:      mediastreamer >= 2.7.0
+Requires:      mediastreamer >= 2.14.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -30,12 +29,12 @@ opartÄ… na bibliotece openh264.
 
 %prep
 %setup -q -n msopenh264-%{version}
-%patch0 -p1
 
 %build
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
+%{__autoheader}
 %{__automake}
 %configure
 
@@ -54,5 +53,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS NEWS README
+%doc AUTHORS NEWS README.md
 %attr(755,root,root) %{_libdir}/mediastreamer/plugins/libmsopenh264.so*
diff --git a/openh264-1.6.patch b/openh264-1.6.patch
deleted file mode 100644 (file)
index 7bff4c6..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-diff -ur msopenh264-1.1.1/src/msopenh264dec.cpp msopenh264-1.2.1/src/msopenh264dec.cpp
---- msopenh264-1.1.1/src/msopenh264dec.cpp     2015-09-23 15:14:22.000000000 +0200
-+++ msopenh264-1.2.1/src/msopenh264dec.cpp     2016-10-19 17:32:52.000000000 +0200
-@@ -14,6 +14,8 @@
- #include "msopenh264dec.h"
- #include "mediastreamer2/msticker.h"
- #include "ortp/b64.h"
-+#include "wels/codec_ver.h"
-+
- MSOpenH264Decoder::MSOpenH264Decoder(MSFilter *f)
-       : mFilter(f), mDecoder(0), mUnpacker(0), mSPS(0), mPPS(0), mYUVMsg(0),
-@@ -53,11 +62,14 @@
-               mUnpacker=rfc3984_new();
-               if (mDecoder != 0) {
-                       SDecodingParam params = { 0 };
-+#if (OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6)
-+#else
-                       params.eOutputColorFormat = videoFormatI420;
-+#endif
-                       params.uiTargetDqLayer = (unsigned char) -1;
-                       params.eEcActiveIdc = ERROR_CON_FRAME_COPY_CROSS_IDR;
-                       params.sVideoProperty.size = sizeof(params.sVideoProperty);
--                      params.sVideoProperty.eVideoBsType = VIDEO_BITSTREAM_DEFAULT;
-+                      params.sVideoProperty.eVideoBsType = VIDEO_BITSTREAM_AVC;
-                       long ret = mDecoder->Initialize(&params);
-                       if (ret != 0) {
-                               ms_error("OpenH264 decoder: Failed to initialize: %li", ret);
-diff -ur msopenh264-1.1.1/src/msopenh264enc.cpp msopenh264-1.2.1/src/msopenh264enc.cpp
---- msopenh264-1.1.1/src/msopenh264enc.cpp     2015-09-23 15:14:22.000000000 +0200
-+++ msopenh264-1.2.1/src/msopenh264enc.cpp     2017-07-20 15:56:32.000000000 +0200
-@@ -14,7 +14,7 @@
- #include "msopenh264enc.h"
- #include "mediastreamer2/msticker.h"
- #include "wels/codec_app_def.h"
--
-+#include "wels/codec_ver.h"
- //static const int RC_MARGIN = 10000; // bits per sec
- #if MSOPENH264_DEBUG
-@@ -114,9 +112,15 @@
-                       params.sSpatialLayers[0].fFrameRate = mVConf.fps;
-                       params.sSpatialLayers[0].iSpatialBitrate = targetBitrate;
-                       params.sSpatialLayers[0].iMaxSpatialBitrate = maxBitrate;
-+
-+#if (OPENH264_MAJOR == 1) && (OPENH264_MINOR >=6)
-+                      params.sSpatialLayers[0].sSliceArgument.uiSliceMode = SM_SIZELIMITED_SLICE;
-+                      params.sSpatialLayers[0].sSliceArgument.uiSliceSizeConstraint = ms_factory_get_payload_max_size(mFilter->factory);
-+#else
-                       params.sSpatialLayers[0].sSliceCfg.uiSliceMode = SM_DYN_SLICE;
-                       params.sSpatialLayers[0].sSliceCfg.sSliceArgument.uiSliceSizeConstraint = ms_factory_get_payload_max_size(mFilter->factory);
--
-+#endif
-+                      //params.sSpatialLayers[0].sSliceCfg.uiSliceMode = SM_AUTO_SLICE;
-                       ret = mEncoder->InitializeExt(&params);
-                       if (ret != 0) {
-                               ms_error("OpenH264 encoder: Failed to initialize: %d", ret);
---- msopenh264-1.1.1/src/msopenh264enc.h~      2015-09-23 15:14:22.000000000 +0200
-+++ msopenh264-1.1.1/src/msopenh264enc.h       2018-09-29 13:18:20.730187249 +0200
-@@ -21,7 +21,6 @@ Foundation, Inc., 59 Temple Place - Suit
- #include "mediastreamer2/msfilter.h"
- #include "mediastreamer2/msvideo.h"
- #include "mediastreamer2/rfc3984.h"
--#include "mediastreamer2/videostarter.h"
- #include "wels/codec_api.h"
- #include "msopenh264.h"
This page took 0.140926 seconds and 4 git commands to generate.