]> git.pld-linux.org Git - packages/mediainfo.git/blob - mediainfo.spec
bd4866bfe2ef4bc245a03198cd777e5d2a11fe1d
[packages/mediainfo.git] / mediainfo.spec
1 %define libmediainfo_ver        0.7.29
2 Summary:        Supplies technical and tag information about a video or audio file (CLI)
3 Name:           mediainfo
4 Version:        0.7.29
5 Release:        1
6 License:        GPL
7 Group:          Applications/Multimedia
8 URL:            http://mediainfo.sourceforge.net/
9 Source0:        http://downloads.sourceforge.net/project/mediainfo/source/mediainfo/%{version}/%{name}_%{version}.tar.bz2
10 # Source0-md5:  bedc73df1f513840754cd679c7578b48
11 BuildRequires:  autoconf
12 BuildRequires:  automake
13 BuildRequires:  dos2unix
14 BuildRequires:  libmediainfo-devel >= %{libmediainfo_ver}
15 BuildRequires:  libstdc++-devel
16 BuildRequires:  libtool
17 BuildRequires:  libzen-devel >= 0.4.9
18 BuildRequires:  pkgconfig
19 BuildRequires:  wxGTK2-unicode-devel
20 BuildRequires:  zlib-devel
21 Requires:       libmediainfo >= %{libmediainfo_ver}
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 MediaInfo CLI (Command Line Interface).
26
27 What information can I get from MediaInfo?
28 - General: title, author, director, album, track number, date,
29   duration...
30 - Video: codec, aspect, fps, bitrate...
31 - Audio: codec, sample rate, channels, language, bitrate...
32 - Text: language of subtitle
33 - Chapters: number of chapters, list of chapters
34
35 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
36 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
37 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
38 VMW, ASF, 3GP, 3GPP, 3GP2
39
40 What format (container) does MediaInfo support?
41 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
42   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
43 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
44 - Subtitles: SRT, SSA, ASS, SAMI
45
46 %package gui
47 Summary:        Supplies technical and tag information about a video or audio file (GUI)
48 Group:          X11/Applications/Multimedia
49 Requires:       libmediainfo >= %{version}
50 Requires:       libzen >= 0.4.9
51
52 %description gui
53 MediaInfo (Graphical User Interface).
54
55 What information can I get from MediaInfo?
56 - General: title, author, director, album, track number, date,
57   duration...
58 - Video: codec, aspect, fps, bitrate...
59 - Audio: codec, sample rate, channels, language, bitrate...
60 - Text: language of subtitle
61 - Chapters: number of chapters, list of chapters
62
63 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
64 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
65 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
66 VMW, ASF, 3GP, 3GPP, 3GP2
67
68 What format (container) does MediaInfo support?
69 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
70   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
71 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
72 - Subtitles: SRT, SSA, ASS, SAMI
73
74 %prep
75 %setup -q -n MediaInfo
76 dos2unix *.html *.txt Release/*.txt
77 chmod 644 *.html *.txt Release/*.txt
78
79 %build
80 export CFLAGS="%{rpmcflags}"
81 export CPPFLAGS="%{rpmcppflags}"
82 export CXXFLAGS="%{rpmcxxflags}"
83
84 # build CLI
85 cd Project/GNU/CLI
86         %{__libtoolize}
87         %{__aclocal}
88         %{__autoconf}
89         %{__automake}
90         %configure
91         %{__make}
92 cd -
93
94 # now build GUI
95 cd Project/GNU/GUI
96         %{__libtoolize}
97         %{__aclocal}
98         %{__autoconf}
99         %{__automake}
100         %configure \
101                 --with-wx-config=%{_bindir}/wx-gtk2-unicode-config
102         %{__make}
103 cd -
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107 %{__make} -C Project/GNU/CLI \
108         install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %{__make} -C Project/GNU/GUI \
112         install \
113         DESTDIR=$RPM_BUILD_ROOT
114
115 # icon
116 install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
117 install Source/Ressource/Image/MediaInfo.png \
118         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/%{name}.png
119 install -dm 755 $RPM_BUILD_ROOT%{_pixmapsdir}
120 install Source/Ressource/Image/MediaInfo.png \
121         $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
122
123 # menu-entry
124 install -dm 755 $RPM_BUILD_ROOT/%{_desktopdir}
125 install Project/GNU/GUI/mediainfo-gui.desktop \
126         $RPM_BUILD_ROOT/%{_desktopdir}
127 install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus
128 install Project/GNU/GUI/mediainfo-gui.kde3.desktop \
129         $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus/mediainfo-gui.desktop
130 install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/
131 install Project/GNU/GUI/mediainfo-gui.kde4.desktop \
132         $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/mediainfo-gui.desktop
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc Release/ReadMe_CLI_Linux.txt
140 %doc License.html History_CLI.txt
141 %attr(755,root,root) %{_bindir}/mediainfo
142
143 %files gui
144 %defattr(644,root,root,755)
145 %doc Release/ReadMe_GUI_Linux.txt
146 %doc License.html History_GUI.txt
147 %attr(755,root,root) %{_bindir}/mediainfo-gui
148 %{_desktopdir}/*.desktop
149 %{_pixmapsdir}/*.png
150 %{_iconsdir}/hicolor/128x128/apps/*.png
151 %dir %{_datadir}/apps/konqueror
152 %dir %{_datadir}/apps/konqueror/servicemenus
153 %{_datadir}/apps/konqueror/servicemenus/*.desktop
154 %dir %{_datadir}/kde4
155 %dir %{_datadir}/kde4/services
156 %dir %{_datadir}/kde4/services/ServiceMenus
157 %{_datadir}/kde4/services/ServiceMenus/*.desktop
This page took 0.056042 seconds and 2 git commands to generate.