]> git.pld-linux.org Git - packages/mediainfo.git/blob - mediainfo.spec
- up to 0.7.60
[packages/mediainfo.git] / mediainfo.spec
1 Summary:        Supplies technical and tag information about a video or audio file (CLI)
2 Name:           mediainfo
3 Version:        0.7.60
4 Release:        1
5 License:        GPL
6 Group:          Applications/Multimedia
7 Source0:        http://downloads.sourceforge.net/project/mediainfo/source/mediainfo/%{version}/%{name}_%{version}.tar.bz2
8 # Source0-md5:  ed1e1baf50ac101ef5c41b6b32ada36e
9 URL:            http://mediainfo.sourceforge.net/
10 BuildRequires:  autoconf
11 BuildRequires:  automake
12 BuildRequires:  dos2unix
13 BuildRequires:  libmediainfo-devel >= %{version}
14 BuildRequires:  libstdc++-devel
15 BuildRequires:  libtool
16 BuildRequires:  pkgconfig
17 BuildRequires:  wxGTK2-unicode-devel
18 BuildRequires:  zlib-devel
19 Requires:       libmediainfo >= %{version}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 MediaInfo CLI (Command Line Interface).
24
25 What information can I get from MediaInfo?
26 - General: title, author, director, album, track number, date,
27   duration...
28 - Video: codec, aspect, fps, bitrate...
29 - Audio: codec, sample rate, channels, language, bitrate...
30 - Text: language of subtitle
31 - Chapters: number of chapters, list of chapters
32
33 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
34 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
35 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
36 VMW, ASF, 3GP, 3GPP, 3GP2
37
38 What format (container) does MediaInfo support?
39 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
40   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
41 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
42 - Subtitles: SRT, SSA, ASS, SAMI
43
44 %package gui
45 Summary:        Supplies technical and tag information about a video or audio file (GUI)
46 Group:          X11/Applications/Multimedia
47 Requires:       kde-common-dirs >= 0.5
48 Requires:       libmediainfo >= %{version}
49 Requires:       libzen >= 0.4.9
50
51 %description gui
52 MediaInfo (Graphical User Interface).
53
54 What information can I get from MediaInfo?
55 - General: title, author, director, album, track number, date,
56   duration...
57 - Video: codec, aspect, fps, bitrate...
58 - Audio: codec, sample rate, channels, language, bitrate...
59 - Text: language of subtitle
60 - Chapters: number of chapters, list of chapters
61
62 DivX, XviD, H263, H.263, H264, x264, ASP, AVC, iTunes, MPEG-1, MPEG1,
63 MPEG-2, MPEG2, MPEG-4, MPEG4, MP4, M4A, M4V, QuickTime, RealVideo,
64 RealAudio, RA, RM, MSMPEG4v1, MSMPEG4v2, MSMPEG4v3, VOB, DVD, WMA,
65 VMW, ASF, 3GP, 3GPP, 3GP2
66
67 What format (container) does MediaInfo support?
68 - Video: MKV, OGM, AVI, DivX, WMV, QuickTime, Real, MPEG-1, MPEG-2,
69   MPEG-4, DVD (VOB) (Codecs: DivX, XviD, MSMPEG4, ASP, H.264, AVC...)
70 - Audio: OGG, MP3, WAV, RA, AC3, DTS, AAC, M4A, AU, AIFF
71 - Subtitles: SRT, SSA, ASS, SAMI
72
73 %prep
74 %setup -q -n MediaInfo
75 dos2unix *.html *.txt Release/*.txt
76 chmod 644 *.html *.txt Release/*.txt
77
78 %build
79 export CFLAGS="%{rpmcflags}"
80 export CPPFLAGS="%{rpmcppflags}"
81 export CXXFLAGS="%{rpmcxxflags}"
82
83 # build CLI
84 cd Project/GNU/CLI
85         %{__libtoolize}
86         %{__aclocal}
87         %{__autoconf}
88         %{__automake}
89         %configure
90         %{__make}
91 cd -
92
93 # now build GUI
94 cd Project/GNU/GUI
95         %{__libtoolize}
96         %{__aclocal}
97         %{__autoconf}
98         %{__automake}
99         %configure \
100                 --with-wx-config=%{_bindir}/wx-gtk2-unicode-config
101         %{__make}
102 cd -
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106 %{__make} -C Project/GNU/CLI \
107         install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %{__make} -C Project/GNU/GUI \
111         install \
112         DESTDIR=$RPM_BUILD_ROOT
113
114 # icon
115 install -dm 755 $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps
116 install Source/Resource/Image/MediaInfo.png \
117         $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/128x128/apps/%{name}.png
118 install -dm 755 $RPM_BUILD_ROOT%{_pixmapsdir}
119 install Source/Resource/Image/MediaInfo.png \
120         $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
121
122 # menu-entry
123 install -dm 755 $RPM_BUILD_ROOT/%{_desktopdir}
124 install Project/GNU/GUI/mediainfo-gui.desktop \
125         $RPM_BUILD_ROOT/%{_desktopdir}
126 install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus
127 install Project/GNU/GUI/mediainfo-gui.kde3.desktop \
128         $RPM_BUILD_ROOT/%{_datadir}/apps/konqueror/servicemenus/mediainfo-gui.desktop
129 install -dm 755 $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/
130 install Project/GNU/GUI/mediainfo-gui.kde4.desktop \
131         $RPM_BUILD_ROOT/%{_datadir}/kde4/services/ServiceMenus/mediainfo-gui.desktop
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %files
137 %defattr(644,root,root,755)
138 %doc Release/ReadMe_CLI_Linux.txt
139 %doc License.html History_CLI.txt
140 %attr(755,root,root) %{_bindir}/mediainfo
141
142 %files gui
143 %defattr(644,root,root,755)
144 %doc Release/ReadMe_GUI_Linux.txt
145 %doc License.html History_GUI.txt
146 %attr(755,root,root) %{_bindir}/mediainfo-gui
147 %{_desktopdir}/*.desktop
148 %{_pixmapsdir}/*.png
149 %{_iconsdir}/hicolor/128x128/apps/*.png
150 %dir %{_datadir}/apps/konqueror/servicemenus
151 %{_datadir}/apps/konqueror/servicemenus/*.desktop
152 %{_datadir}/kde4/services/ServiceMenus/*.desktop
This page took 0.052187 seconds and 3 git commands to generate.