]> git.pld-linux.org Git - packages/mdds.git/blob - mdds.spec
- updated to 2.0.3 (for libreoffice 7.5.x)
[packages/mdds.git] / mdds.spec
1 #
2 # Conditional build:
3 %bcond_without  apidocs # doxygen/sphinx+breathe API documentation
4 #
5 Summary:        A collection of multi-dimensional data structures and indexing algorithms
6 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
7 Name:           mdds
8 # keep in sync with BuildRequires in libreoffice.spec, ixion.spec, liborcus.spec
9 Version:        2.0.3
10 Release:        1
11 License:        MIT
12 Group:          Development/Libraries
13 #Source0Download: https://gitlab.com/mdds/mdds/-/releases
14 Source0:        https://kohei.us/files/mdds/src/%{name}-%{version}.tar.xz
15 # Source0-md5:  6ff7a461e9fc408c508bbfbf1f53969a
16 Patch0:         %{name}-doc.patch
17 URL:            https://gitlab.com/mdds/mdds
18 BuildRequires:  boost-devel >= 1.39
19 BuildRequires:  libstdc++-devel >= 6:4.7
20 BuildRequires:  rpmbuild(macros) >= 1.446
21 BuildRequires:  tar >= 1:1.22
22 BuildRequires:  xz
23 %if %{with apidocs}
24 BuildRequires:  doxygen
25 BuildRequires:  python3-breathe
26 BuildRequires:  sphinx-pdg-3
27 %endif
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 A collection of multi-dimensional data structures and indexing
33 algorithms.
34
35 It implements the following data structures:
36 - segment tree
37 - flat segment tree
38 - rectangle set
39 - point quad tree
40 - mixed type matrix
41
42 %description -l pl.UTF-8
43 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
44 Zaimplementowane są następujące struktury danych:
45 - drzewo segmentowe
46 - płaskie drzewo segmentowe
47 - zbiór prostokątów
48 - drzewo czwórkowe (quadtree) dla punktów
49 - macierz mieszana
50
51 %package devel
52 Summary:        A collection of multi-dimensional data structures and indexing algorithms
53 Summary(pl.UTF-8):      Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących
54 Group:          Development/Libraries
55 Requires:       boost-devel >= 1.39
56 Requires:       libstdc++-devel >= 6:4.7
57
58 %description devel
59 A collection of multi-dimensional data structures and indexing
60 algorithms.
61
62 It implements the following data structures:
63 - segment tree
64 - flat segment tree
65 - rectangle set
66 - point quad tree
67 - mixed type matrix
68
69 %description devel -l pl.UTF-8
70 Zbiór struktur danych wielowymiarowych oraz algorytmów indeksujących.
71 Zaimplementowane są następujące struktury danych:
72 - drzewo segmentowe
73 - płaskie drzewo segmentowe
74 - zbiór prostokątów
75 - drzewo czwórkowe (quadtree) dla punktów
76 - macierz mieszana
77
78 %package apidocs
79 Summary:        API documentation for MDDS
80 Summary(pl.UTF-8):      Dokumentacja API biblioteki MDDS
81 Group:          Documentation
82
83 %description apidocs
84 API documentation for MDDS.
85
86 %description apidocs -l pl.UTF-8
87 Dokumentacja API biblioteki MDDS.
88
89 %prep
90 %setup -q
91
92 %build
93 %configure \
94         SPHINX=/usr/bin/sphinx-build-3 \
95         %{?with_apidocs:--enable-docs}
96
97 %{__make}
98
99 %if %{with apidocs}
100 %{__make} doc
101 %endif
102
103 %install
104 rm -rf $RPM_BUILD_ROOT
105
106 %{__make} install \
107         DESTDIR=$RPM_BUILD_ROOT
108
109 # packaged as %doc
110 %{__rm} -r $RPM_BUILD_ROOT%{_docdir}/mdds
111
112 %clean
113 rm -rf $RPM_BUILD_ROOT
114
115 %files devel
116 %defattr(644,root,root,755)
117 %doc AUTHORS CHANGELOG LICENSE README.md
118 %{_includedir}/mdds-2.0
119 %{_npkgconfigdir}/mdds-2.0.pc
120
121 %if %{with apidocs}
122 %files apidocs
123 %defattr(644,root,root,755)
124 %doc doc/_doxygen/html doc/_build/{_static,*.html,*.js}
125 %endif
This page took 0.134936 seconds and 3 git commands to generate.