]> git.pld-linux.org Git - packages/mate-panel.git/blob - mate-panel.spec
new, version 1.5.3
[packages/mate-panel.git] / mate-panel.spec
1 # TODO
2 # - docs broken, like mate-desktop
3 #   fix gtk-doc building (probably missing some dtd's)
4 #xsltproc -o mate-applet-clock-C.omf --stringparam db2omf.basename mate-applet-clock --stringparam db2omf.format 'docbook' --stringparam db2omf.dtd "-//OASIS//DTD DocBook XML V4.1.2//EN" --stringparam db2omf.lang C --stringparam db2omf.omf_dir "/usr/share/omf" --stringparam db2omf.help_dir "/usr/share/mate/help" --stringparam db2omf.omf_in "/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/mate-applet-clock.omf.in"  `/usr/bin/pkg-config --variable db2omf mate-doc-utils` C/mate-applet-clock.xml || { rm -f "mate-applet-clock-C.omf"; exit 1; }
5 #if ! test -d ar/; then mkdir ar/; fi
6 #if [ -f "C/mate-applet-clock.xml" ]; then d="../"; else d="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/"; fi; \
7 #mo="ar/ar.mo"; \
8 #if [ -f "${mo}" ]; then mo="../${mo}"; else mo="/home/users/glen/rpm/packages/BUILD.i686-linux/mate-panel-1.5.3/help/clock/${mo}"; fi; \
9 #(cd ar/ && \
10 #  `which xml2po` -m docbook -e -t "${mo}" \
11 #    "${d}C/mate-applet-clock.xml" > mate-applet-clock.xml.tmp && \
12 #    cp mate-applet-clock.xml.tmp mate-applet-clock.xml && rm -f mate-applet-clock.xml.tmp)
13 #runtime error
14 #xsltApplyStylesheet: saving to mate-applet-clock-C.omf may not be possible
15 #make[3]: *** [mate-applet-clock-C.omf] Error 1
16 #make[3]: *** Waiting for unfinished jobs....
17 #Making all in mate-panel-applet
18 #make[4]: Entering directory `/home/users/glen/rpm/BUILD/i686-linux/mate-panel-1.5.3/doc/reference/mate-panel-applet'
19 #  DOC   Scanning header files
20 #  DOC   Introspecting gobjects
21 #libtool: link: cannot find the library `../../../libmate-panel-applet/libmate-panel-applet-3.la' or unhandled argument `../../../libmate-panel-applet/libmate-panel-applet-3.la'
22 #Linking of scanner failed:
23 #make[4]: *** [scan-build.stamp] Error 1
24 #make[4]: Leaving directory `/home/users/
25 # - check direct deps:
26 #mate-panel-1.5.3-0.1.i686 marks mate-menus-libs-1.5.0-1.i686 (cap libmate-menu.so.2)
27 #mate-panel-1.5.3-0.1.i686 marks mate-panel-libs-1.5.3-0.1.i686 (cap libmate-panel-applet-4.so.1)
28 #mate-panel-1.5.3-0.1.i686 marks libmateweather-1.5.0-1.i686 (cap libmateweather.so.1)
29 #mate-panel-1.5.3-0.1.i686 marks libmatewnck-1.5.0-1.i686 (cap libmatewnck.so.0)
30 # - apidoc subpackage
31
32 # Conditional build:
33 %bcond_with     doc     # gtk doc. broken
34
35 Summary:        MATE Desktop panel applets
36 Name:           mate-panel
37 Version:        1.5.3
38 Release:        0.1
39 # libs are LGPLv2+ applications GPLv2+
40 License:        GPL v2+
41 Group:          X11/Applications
42 URL:            http://mate-desktop.org
43 Source0:        http://pub.mate-desktop.org/releases/1.5/%{name}-%{version}.tar.xz
44 # Source0-md5:  72029cbcd38bee447df92c8774452bf3
45 BuildRequires:  desktop-file-utils
46 BuildRequires:  icon-naming-utils
47 BuildRequires:  mate-common
48 BuildRequires:  pkgconfig(dbus-glib-1)
49 BuildRequires:  pkgconfig(dconf)
50 BuildRequires:  pkgconfig(gobject-introspection-1.0)
51 BuildRequires:  pkgconfig(gsettings-desktop-schemas)
52 BuildRequires:  pkgconfig(gtk+-2.0)
53 BuildRequires:  pkgconfig(libcanberra)
54 BuildRequires:  pkgconfig(libmate-menu)
55 BuildRequires:  pkgconfig(libmatewnck)
56 BuildRequires:  pkgconfig(libnm-gtk)
57 BuildRequires:  pkgconfig(librsvg-2.0)
58 BuildRequires:  pkgconfig(mate-desktop-2.0)
59 %{?with_apidoc:BuildRequires:   pkgconfig(mate-doc-utils)}
60 BuildRequires:  pkgconfig(mateweather)
61 BuildRequires:  pkgconfig(pango)
62 BuildRequires:  pkgconfig(sm)
63 BuildRequires:  pkgconfig(x11)
64 BuildRequires:  popt-devel
65 BuildRequires:  tar >= 1:1.22
66 BuildRequires:  xz
67 Requires:       %{name}-libs = %{version}-%{release}
68 Requires:       glib2 >= 1:2.26.0
69 Requires:       gsettings-desktop-schemas
70 # needed as nothing else requires it
71 Requires:       desktop-file-utils
72 Requires:       gtk-update-icon-cache
73 Requires:       mate-session-manager
74 # for fish
75 Requires:       fortune-mod
76 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
77
78 %description
79 MATE Desktop panel applets
80
81 %package libs
82 Summary:        Shared libraries for mate-panel
83 License:        LGPL v2+
84 Group:          Libraries
85 Requires:       %{name} = %{version}-%{release}
86
87 %description libs
88 Shared libraries for libmate-desktop
89
90 %package devel
91 Summary:        Development files for mate-panel
92 Group:          Development/Libraries
93 Requires:       %{name}-libs = %{version}-%{release}
94
95 %description devel
96 Development files for mate-panel
97
98 %prep
99 %setup -q
100
101 %build
102 NOCONFIGURE=1 ./autogen.sh
103 # libexecdir needed for gnome conflicts
104 %configure \
105         --disable-scrollkeeper \
106         --disable-static \
107         --disable-schemas-compile \
108         --with-x \
109         --enable-network-manager \
110         --libexecdir=%{_libexecdir}/mate-panel \
111         --with-html-dir=%{_gtkdocdir} \
112         %{?with_doc:--enable-gtk-doc} \
113         --enable-introspection
114
115 %{__make}  \
116         V=1
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 rm -fv $RPM_BUILD_ROOT%{_libdir}/lib*.la
124
125 desktop-file-install \
126         --remove-category="MATE" \
127         --add-category="X-Mate" \
128         --dir=$RPM_BUILD_ROOT%{_desktopdir} \
129 $RPM_BUILD_ROOT%{_desktopdir}/mate-panel.desktop
130
131 %find_lang %{name}
132
133 %clean
134 rm -rf $RPM_BUILD_ROOT
135
136 %post
137 %update_icon_cache hicolor
138 %update_desktop_database
139 %glib_compile_schemas
140
141 %postun
142 %update_icon_cache hicolor
143 %update_desktop_database
144 %glib_compile_schemas
145
146 %post   libs -p /sbin/ldconfig
147 %postun libs -p /sbin/ldconfig
148
149 %files -f %{name}.lang
150 %defattr(644,root,root,755)
151 %doc AUTHORS COPYING README
152 %attr(755,root,root) %{_bindir}/mate-desktop-item-edit
153 %attr(755,root,root) %{_bindir}/mate-panel
154 %attr(755,root,root) %{_bindir}/mate-panel-test-applets
155 %{_mandir}/man1/*
156 %{_libdir}/girepository-1.0/MatePanelApplet-4.0.typelib
157 %{_libexecdir}/mate-panel
158 %{_datadir}/glib-2.0/schemas/org.mate.panel.*.xml
159 %{_desktopdir}/mate-panel.desktop
160 %{_datadir}/dbus-1/services/org.mate.panel.*.service
161 %{_datadir}/omf/mate-applet-fish
162 %{_datadir}/omf/mate-applet-clock
163 %{_iconsdir}/hicolor/*/*/*
164 %{_datadir}/mate/help/mate-applet-clock
165 %{_datadir}/mate/help/mate-applet-fish
166 %{_datadir}/mate-panel
167 %{_datadir}/mate-panelrc
168
169 %files libs
170 %defattr(644,root,root,755)
171 %doc COPYING.LIB
172 %attr(755,root,root) %{_libdir}/libmate-panel-applet-4.so.*.*.*
173 %ghost %{_libdir}/libmate-panel-applet-4.so.1
174
175 %files devel
176 %defattr(644,root,root,755)
177 %{_libdir}/libmate-panel-applet-4.so
178 %{_includedir}/mate-panel-4.0
179 %{_pkgconfigdir}/libmatepanelapplet-4.0.pc
180 %{_datadir}/gir-1.0/MatePanelApplet-4.0.gir
181 # apidoc
182 %{_gtkdocdir}/mate-panel-applet
This page took 0.113287 seconds and 4 git commands to generate.