]> git.pld-linux.org Git - packages/lvm2.git/commitdiff
- added lvm2-lvmetad init script fix to pld_init patch
authorJakub Bogusz <qboosh@pld-linux.org>
Fri, 8 Apr 2016 13:50:32 +0000 (15:50 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Fri, 8 Apr 2016 13:50:32 +0000 (15:50 +0200)
lvm2-pld_init.patch
lvm2.spec

index 90b549c20909d2dc895a45a98793c5e136d63039..6d8febc7a4cc10100f414790bb752b9ffd65e06a 100644 (file)
@@ -171,3 +171,51 @@ diff -dur LVM2.2.02.98.orig/scripts/blk_availability_systemd_red_hat.service.in
  ExecStop=@sbindir@/blkdeactivate -u -l wholevg
  RemainAfterExit=yes
  
+--- LVM2.2.02.149/scripts/lvm2_lvmetad_init_red_hat.in.orig    2016-04-01 21:32:17.000000000 +0200
++++ LVM2.2.02.149/scripts/lvm2_lvmetad_init_red_hat.in 2016-04-08 15:34:29.481897884 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # Copyright (C) 2012 Red Hat, Inc. All rights reserved.
+ #
+@@ -52,7 +52,7 @@
+ start()
+ {
+       ret=0
+-      action "Starting LVM metadata daemon:" $DAEMON || ret=$?
++      run_cmd "Starting LVM metadata daemon:" $DAEMON || ret=$?
+       return $ret
+ }
+@@ -60,7 +60,8 @@
+ stop()
+ {
+       ret=0
+-      action "Signaling LVM metadata daemon to exit:" killproc -p $PID_FILE $DAEMON -TERM || ret=$?
++      msg_stopping "LVM metadata daemon"
++      killproc -p $PID_FILE $DAEMON -TERM || ret=$?
+       return $ret
+ }
+@@ -80,9 +81,10 @@
+       stop
+       rtrn=$?
+       [ $rtrn = 0 ] && rm -f $LOCK_FILE
++      exit 0
+       ;;
+-  restart)
++  restart|force-reload)
+       if stop
+       then
+               start
+@@ -105,7 +107,7 @@
+       ;;
+   *)
+-      echo $"Usage: $0 {start|stop|force-stop|restart|condrestart|try-restart|status}"
++      echo "Usage: $0 {start|stop|force-stop|restart|force-reload|condrestart|try-restart|status}"
+       ;;
+ esac
index dacfcd8baa107d70a6161028eea16e5f4c0c87ac..228cd45445f82d538317f2d9c60edd28735ba4cb 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
@@ -3,9 +3,6 @@
 # - spec default value for --with-replicators (=internal/shared/none, configure default is none)?
 #   (also internal vs shared for lvm1,pool,cluster,snapshots,mirrors,raid,replicators,thin,cache;
 #    note: dmeventd requires mirrors=internal)
-# - fix initscripts:
-#   # service lvm2-lvmetad start
-#   /etc/rc.d/init.d/lvm2-lvmetad: line 55: action: command not found
 #
 # Conditional build:
 # - initrd stuff
This page took 0.125016 seconds and 4 git commands to generate.