]> git.pld-linux.org Git - packages/lvm2.git/commitdiff
Version: 2.2.02.98
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 25 Oct 2012 11:20:28 +0000 (13:20 +0200)
committerJacek Konieczny <jajcus@jajcus.net>
Thu, 25 Oct 2012 11:20:28 +0000 (13:20 +0200)
- up to 2.2.02.98
- dropped cman/openais dependency (those projects are not maintained any
  more)
- lvm2-clvmd_init.patch and pldize_lvm2_monitor.patch merged into
  lvm2-pld_init.patch, blk-availability job added

device-mapper-dmsetup-export.patch
lvm2-clvmd_init.patch [deleted file]
lvm2-pld_init.patch [new file with mode: 0644]
lvm2.spec
pldize_lvm2_monitor.patch [deleted file]

index c7b0a4d273c1bfb8c89a6d9942449b6ee9a9deed..b6e92b87354e06b3ad8f9eb42590b4209b1f23bb 100644 (file)
@@ -1,8 +1,33 @@
-diff --git a/dmsetup/dmsetup.c b/dmsetup/dmsetup.c
-index 25f14a6..b693008 100644
---- a/tools/dmsetup.c
-+++ b/tools/dmsetup.c
-@@ -995,6 +995,94 @@ static int _status(int argc, char **argv
+diff -dur -x '*~' -x '*.orig' -x '*.rej' LVM2.2.02.98.orig/man/dmsetup.8.in LVM2.2.02.98/man/dmsetup.8.in
+--- LVM2.2.02.98.orig/man/dmsetup.8.in 2012-10-15 16:24:58.000000000 +0200
++++ LVM2.2.02.98/man/dmsetup.8.in      2012-10-25 10:24:13.000000000 +0200
+@@ -43,6 +43,9 @@
+ .RI [ device_name ]
+ .RE
+ .br
++.B dmsetup export
++.RI [ device_name ]
++.br
+ .B dmsetup load
+ .I device_name
+ .RB [ \-\-table
+@@ -287,6 +290,12 @@
+ See below for information on the table format.
+ .br
+ .TP
++.B export
++.RI [ device_name ]
++.br
++Outputs information in key/value format to be imported by other programs.
++.br
++.TP
+ .B deps
+ .RB [ \-o
+ .IR options ]
+diff -dur -x '*~' -x '*.orig' -x '*.rej' LVM2.2.02.98.orig/tools/dmsetup.c LVM2.2.02.98/tools/dmsetup.c
+--- LVM2.2.02.98.orig/tools/dmsetup.c  2012-10-25 10:23:32.000000000 +0200
++++ LVM2.2.02.98/tools/dmsetup.c       2012-10-25 10:24:35.000000000 +0200
+@@ -1725,6 +1725,94 @@
        return r;
  }
  
@@ -95,40 +120,13 @@ index 25f14a6..b693008 100644
 +}
 +
  /* Show target names and their version numbers */
- static int _targets(int argc __attribute((unused)), char **argv __attribute((unused)), void *data __attribute((unused)))
+ static int _targets(CMD_ARGS)
  {
-@@ -1699,6 +1787,7 @@ static struct command _commands[] = {
+@@ -3075,6 +3163,7 @@
        {"info", "[<device>]", 0, -1, 1, _info},
-       {"deps", "[<device>]", 0, -1, 1, _deps},
-       {"status", "[<device>] [--target <target_type>]", 0, -1, 1, _status},
+       {"deps", "[-o options] [<device>]", 0, -1, 1, _deps},
+       {"status", "[<device>] [--noflush] [--target <target_type>]", 0, -1, 1, _status},
 +      {"export", "[<device>]", 0, -1, 1, _export},
        {"table", "[<device>] [--target <target_type>] [--showkeys]", 0, -1, 1, _status},
-       {"wait", "<device> [<event_nr>]", 0, 2, 0, _wait},
+       {"wait", "<device> [<event_nr>] [--noflush]", 0, 2, 0, _wait},
        {"mknodes", "[<device>]", 0, -1, 1, _mknodes},
-diff --git a/man/dmsetup.8 b/man/dmsetup.8
-index 5b2ed9f..c4524aa 100644
---- a/man/dmsetup.8.in
-+++ b/man/dmsetup.8.in
-@@ -39,6 +39,9 @@ dmsetup \- low level logical volume mana
- .RI [ device_name ]
- .RE
- .br
-+.B dmsetup export
-+.RI [ device_name ]
-+.br
- .B dmsetup load
- .I device_name
- .RB [ \-\-table
-@@ -138,6 +141,12 @@ device_name in subsequent dmsetup comman
- /dev/mapper/<device-name>.
- See below for information on the table format.
- .br
-+.TP
-+.B export
-+.RI [ device_name ]
-+.br
-+Outputs information in key/value format to be imported by other programs.
-+.br
- .TP
- .B deps
- .RB [ \-o
diff --git a/lvm2-clvmd_init.patch b/lvm2-clvmd_init.patch
deleted file mode 100644 (file)
index 545b9c0..0000000
+++ /dev/null
@@ -1,73 +0,0 @@
---- LVM2.2.02.67/scripts/clvmd_init_red_hat.in 2010-07-17 18:33:02.185014713 +0200
-+++ LVM2.2.02.67/scripts/clvmd_init_red_hat.in 2010-07-17 18:59:14.831553676 +0200
-@@ -64,9 +64,8 @@ rh_status_q() {
- start()
- {
-       if ! rh_status_q; then
--              echo -n "Starting $DAEMON: "
-+              msg_starting "$DAEMON"
-               $DAEMON $CLVMDOPTS || return $?
--              echo
-       fi
-       # Refresh local cache.
-@@ -86,7 +85,7 @@ start()
-       ${lvm_vgscan} > /dev/null 2>&1
--      action "Activating VG(s):" ${lvm_vgchange} -ayl $LVM_VGS || return $?
-+      run_cmd "Activating VG(s):" ${lvm_vgchange} -ayl $LVM_VGS || return $?
-       touch $LOCK_FILE
-@@ -111,27 +110,23 @@ stop()
-       [ -z "$LVM_VGS" ] && LVM_VGS="$(clustered_vgs)"
-       if [ -n "$LVM_VGS" ]; then
--              action "Deactivating clustered VG(s):" ${lvm_vgchange} -anl $LVM_VGS || return $?
-+              run_cmd "Deactivating clustered VG(s):" ${lvm_vgchange} -anl $LVM_VGS || return $?
-       fi
--      action "Signaling $DAEMON to exit" kill -TERM $(pidofproc $DAEMON) || return $?
-+      run_cmd "Signaling $DAEMON to exit" kill -TERM $(pidofproc $DAEMON) || return $?
-       # wait half second before we start the waiting loop or we will show
-       # the loop more time than really necessary
-       usleep 500000
-       # clvmd could take some time to stop
--      rh_status_q && action "Waiting for $DAEMON to exit:" wait_for_finish
-+      rh_status_q && run_cmd "Waiting for $DAEMON to exit:" wait_for_finish
-       if rh_status_q; then
--              echo -n "$DAEMON failed to exit"
--              failure
--              echo
-+              fail
-               return 1
-       else
--              echo -n "$DAEMON terminated"
--              success
--              echo
-+              ok
-       fi
-       rm -f $LOCK_FILE
-@@ -141,7 +136,7 @@ stop()
- reload() {
-       rh_status_q || exit 7
--      action "Reloading $DAEMON configuration: " $DAEMON -R || return $?
-+      run_cmd "Reloading $DAEMON configuration: " $DAEMON -R || return $?
- }
- restart() {
-@@ -152,7 +147,7 @@ restart() {
-       # Try to get clvmd to restart itself. This will preserve 
-       # exclusive LV locks
--      action "Restarting $DAEMON: " $DAEMON -S
-+      run_cmd "Restarting $DAEMON: " $DAEMON -S
-       # If that fails then do a normal stop & restart
-       if  [ $? != 0 ]; then
diff --git a/lvm2-pld_init.patch b/lvm2-pld_init.patch
new file mode 100644 (file)
index 0000000..a27d30c
--- /dev/null
@@ -0,0 +1,174 @@
+diff -dur LVM2.2.02.98.orig/scripts/blk_availability_init_red_hat.in LVM2.2.02.98/scripts/blk_availability_init_red_hat.in
+--- LVM2.2.02.98.orig/scripts/blk_availability_init_red_hat.in 2012-10-15 16:24:58.000000000 +0200
++++ LVM2.2.02.98/scripts/blk_availability_init_red_hat.in      2012-10-25 12:01:33.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # Copyright (C) 2012 Red Hat, Inc. All rights reserved.
+ #
+@@ -43,16 +43,20 @@
+ case "$1" in
+   start)
+       touch $LOCK_FILE
++      exit 0
+       ;;
+   stop)
+-      action "Stopping block device availability:" $sbindir/$script $options
++      run_cmd "Stopping block device availability:" $sbindir/$script $options
+       rm -f $LOCK_FILE
++      exit 0
+       ;;
+   status)
++      exit 0
+       ;;
+   *)
+-      echo $"Usage: $0 {start|stop|status}"
++      msg_usage "$0 {start|stop|status}"
++      exit 3
+       ;;
+ esac
+diff -dur LVM2.2.02.98.orig/scripts/clvmd_init_red_hat.in LVM2.2.02.98/scripts/clvmd_init_red_hat.in
+--- LVM2.2.02.98.orig/scripts/clvmd_init_red_hat.in    2012-10-15 16:24:58.000000000 +0200
++++ LVM2.2.02.98/scripts/clvmd_init_red_hat.in 2012-10-25 11:57:52.000000000 +0200
+@@ -65,9 +65,8 @@
+ start()
+ {
+       if ! rh_status_q; then
+-              echo -n "Starting $DAEMON: "
++              msg_starting "$DAEMON"
+               $DAEMON $CLVMDOPTS || return $?
+-              echo
+       fi
+       # Refresh local cache.
+@@ -87,7 +86,7 @@
+       ${lvm_vgscan} > /dev/null 2>&1
+-      action "Activating VG(s):" ${lvm_vgchange} -aay $LVM_VGS || return $?
++      run_cmd "Activating VG(s):" ${lvm_vgchange} -aay $LVM_VGS || return $?
+       touch $LOCK_FILE
+@@ -112,27 +111,23 @@
+       [ -z "$LVM_VGS" ] && LVM_VGS="$(clustered_vgs)"
+       if [ -n "$LVM_VGS" ]; then
+-              action "Deactivating clustered VG(s):" ${lvm_vgchange} -anl $LVM_VGS || return $?
++              run_cmd "Deactivating clustered VG(s):" ${lvm_vgchange} -anl $LVM_VGS || return $?
+       fi
+-      action "Signaling $DAEMON to exit" kill -TERM $(pidofproc $DAEMON) || return $?
++      run_cmd "Signaling $DAEMON to exit" kill -TERM $(pidofproc $DAEMON) || return $?
+       # wait half second before we start the waiting loop or we will show
+       # the loop more time than really necessary
+       usleep 500000
+       # clvmd could take some time to stop
+-      rh_status_q && action "Waiting for $DAEMON to exit:" wait_for_finish
++      rh_status_q && run_cmd "Waiting for $DAEMON to exit:" wait_for_finish
+       if rh_status_q; then
+-              echo -n "$DAEMON failed to exit"
+-              failure
+-              echo
++              fail
+               return 1
+       else
+-              echo -n "$DAEMON terminated"
+-              success
+-              echo
++              ok
+       fi
+       rm -f $LOCK_FILE
+@@ -142,7 +137,7 @@
+ reload() {
+       rh_status_q || exit 7
+-      action "Reloading $DAEMON configuration: " $DAEMON -R || return $?
++      run_cmd "Reloading $DAEMON configuration: " $DAEMON -R || return $?
+ }
+ restart() {
+@@ -153,7 +148,7 @@
+       # Try to get clvmd to restart itself. This will preserve 
+       # exclusive LV locks
+-      action "Restarting $DAEMON: " $DAEMON -S
++      run_cmd "Restarting $DAEMON: " $DAEMON -S
+       # If that fails then do a normal stop & restart
+       if  [ $? != 0 ]; then
+diff -dur LVM2.2.02.98.orig/scripts/lvm2_monitoring_init_red_hat.in LVM2.2.02.98/scripts/lvm2_monitoring_init_red_hat.in
+--- LVM2.2.02.98.orig/scripts/lvm2_monitoring_init_red_hat.in  2012-10-15 16:24:58.000000000 +0200
++++ LVM2.2.02.98/scripts/lvm2_monitoring_init_red_hat.in       2012-10-25 11:57:52.000000000 +0200
+@@ -1,4 +1,4 @@
+-#!/bin/bash
++#!/bin/sh
+ #
+ # Copyright (C) 2007-2009 Red Hat, Inc. All rights reserved.
+ #
+@@ -46,12 +46,19 @@
+ start()
+ {
+-      ret=0
++      local ret=0
+       # TODO do we want to separate out already active groups only?
+       VGSLIST=`$VGS --noheadings -o name --config 'log{command_names=0 prefix="  "}' 2> /dev/null`
+       for vg in $VGSLIST
+       do
+-          action "Starting monitoring for VG $vg:" $VGCHANGE --monitor y --poll y --config 'log{command_names=0 prefix="  "}' $vg || ret=$?
++          msg_starting "Starting monitoring for VG $vg:"; busy
++              $VGCHANGE --monitor y --poll y --config 'log{command_names=0 prefix="  "}' $vg
++              ret=$?
++              if [ $ret -ne 0 ]; then
++                      fail
++                      return $ret
++              fi
++              ok
+       done
+       return $ret
+@@ -60,7 +67,7 @@
+ stop()
+ {
+-      ret=0
++      local ret=0
+       # TODO do we want to separate out already active groups only?
+       if test "$WARN" = "1"; then
+          echo "Not stopping monitoring, this is a dangerous operation. Please use force-stop to override."
+@@ -69,7 +76,14 @@
+       VGSLIST=`$VGS --noheadings -o name --config 'log{command_names=0 prefix="  "}' 2> /dev/null`
+       for vg in $VGSLIST
+       do
+-          action "Stopping monitoring for VG $vg:" $VGCHANGE --monitor n --config 'log{command_names=0 prefix="  "}' $vg || ret=$?
++          msg_stopping "Stopping monitoring for VG $vg:"; busy
++              $VGCHANGE --monitor n --config 'log{command_names=0 prefix="  "}' $vg
++              ret=$?
++              if [ $ret -ne 0 ]; then
++                      fail
++                      return $ret
++              fi
++              ok
+       done
+       return $ret
+ }
+diff -dur LVM2.2.02.98.orig/scripts/lvm2_monitoring_systemd_red_hat.service.in LVM2.2.02.98/scripts/lvm2_monitoring_systemd_red_hat.service.in
+--- LVM2.2.02.98.orig/scripts/lvm2_monitoring_systemd_red_hat.service.in       2012-10-15 16:24:58.000000000 +0200
++++ LVM2.2.02.98/scripts/lvm2_monitoring_systemd_red_hat.service.in    2012-10-25 11:57:52.000000000 +0200
+@@ -2,7 +2,7 @@
+ Description=Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
+ Documentation=man:dmeventd(8) man:lvcreate(8) man:lvchange(8) man:vgchange(8)
+ Requires=dm-event.socket
+-After=dm-event.socket fedora-storage-init.service fedora-storage-init-late.service lvm2-activation.service lvm2-lvmetad.service
++After=dm-event.socket pld-storage-init.service pld-storage-init-late.service lvm2-activation.service lvm2-lvmetad.service
+ Before=local-fs.target
+ DefaultDependencies=no
+ Conflicts=shutdown.target
index 04c3d133764674b462cc0eb52c32257a45471128..58af0ed516d0d063ad342bc5347357f7cb615c7e 100644 (file)
--- a/lvm2.spec
+++ b/lvm2.spec
@@ -9,9 +9,6 @@
 %bcond_with    dietlibc        # link initrd version with dietlibc
 %bcond_with    glibc           # link initrd version with static GLIBC
 %bcond_without  cluster                # disable all cluster support (clvmd&cmirrord)
-%bcond_without  cman           # disable cman cluster support (clvmd)
-%bcond_without corosync        # disable corosync cluster support (clvmd&cmirrord)
-%bcond_without openais         # disable openais cluster support (clvmd)
 %bcond_with    lvmetad         # enable lvmetad
 %bcond_without selinux         # disable SELinux
 
 %define                with_glibc      1
 %endif
 
-%if %{without cman} && %{without corosync} && %{without openais}
-%undefine      with_cluster
-%endif
-
 Summary:       The new version of Logical Volume Manager for Linux
 Summary(pl.UTF-8):     Nowa wersja Logical Volume Managera dla Linuksa
 Name:          lvm2
-Version:       2.02.95
-Release:       11
+Version:       2.02.98
+Release:       1
 License:       GPL v2
 Group:         Applications/System
 Source0:       ftp://sources.redhat.com/pub/lvm2/LVM2.%{version}.tgz
-# Source0-md5: bd470a802046c807603618a443732ea7
+# Source0-md5: 1ce5b7f9981e1d02dfd1d3857c8d9fbe
 Source1:       %{name}-tmpfiles.conf
 Patch0:                %{name}-selinux.patch
 Patch1:                %{name}-diet.patch
 Patch2:                device-mapper-dmsetup-export.patch
-Patch3:                %{name}-clvmd_init.patch
+Patch3:                %{name}-pld_init.patch
 Patch4:                dl-dlsym.patch
-Patch5:                pldize_lvm2_monitor.patch
-Patch6:                %{name}-wrapper.patch
-Patch7:                udev-deprecated.patch
-Patch8:                %{name}-lvm_path.patch
+Patch5:                %{name}-wrapper.patch
+Patch6:                %{name}-lvm_path.patch
 URL:           http://sources.redhat.com/lvm2/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake
@@ -80,12 +71,8 @@ BuildConflicts:      device-mapper-dietlibc
 %{?with_uClibc:BuildRequires:  uClibc-static >= 2:0.9.29}
 %endif
 %if %{with cluster}
-%{?with_cman:BuildRequires:    cluster-cman-devel}
-BuildRequires: cluster-dlm-devel
-%if %{with corosync} || %{with openais}
 BuildRequires: corosync-devel
-%endif
-%{?with_openais:BuildRequires: openais-devel >= 1.0}
+BuildRequires: dlm-devel >= 3.99.5
 %endif
 Requires(post,preun,postun):   systemd-units >= 38
 Requires:      device-mapper >= %{version}-%{release}
@@ -106,6 +93,9 @@ BuildRoot:   %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # borken on AC
 %define                filterout_ld    -Wl,--as-needed
 
+# causes: undefined reference to `__stack_chk_fail_local'
+%define                filterout_c     -fstack-protector
+
 # for some reason known only to rpm there must be "\\|" not "\|" here
 %define                dietarch        %(echo %{_target_cpu} | sed -e 's/i.86\\|pentium.\\|athlon/i386/;s/amd64/x86_64/;s/armv.*/arm/')
 %define                dietlibdir      %{_prefix}/lib/dietlibc/lib-%{dietarch}
@@ -142,30 +132,30 @@ Group:            Applications/System
 Requires:      %{name} = %{version}-%{release}
 
 %description clvmd
-clvmd is the daemon that distributes  LVM  metadata  updates  around
-a cluster.   It must be running on all nodes in the cluster and will
-give an error if a node in the cluster does not have this daemon
-running.
+clvmd is the daemon that distributes LVM metadata updates around a
+cluster. It must be running on all nodes in the cluster and will give
+an error if a node in the cluster does not have this daemon running.
 
 %description clvmd -l pl.UTF-8
 clvmd to demon który rozprowadza zmiany meta-danych LVM po klastrze.
-Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy
-jakiś węzeł w klastrze nie ma tego demona uruchomionego.
+Mysi działać na wszystkich węzłach klastra i zgłosi błąd gdy jakiś
+węzeł w klastrze nie ma tego demona uruchomionego.
 
 %package cmirrord
 Summary:       Cluster mirror log daemon
 Group:         Applications/System
-Requires:      cluster-cman
 Requires:      %{name} = %{version}-%{release}
+Requires:      cluster-cman
 
 %description cmirrord
-cmirrord is the daemon that tracks mirror log information in a cluster.
-It is specific to device-mapper based mirrors (and by extension, LVM cluster
-mirrors). Cluster mirrors are not possible without this daemon running.
+cmirrord is the daemon that tracks mirror log information in a
+cluster. It is specific to device-mapper based mirrors (and by
+extension, LVM cluster mirrors). Cluster mirrors are not possible
+without this daemon running.
 
-This daemon relies on the cluster infrastructure provided by the Cluster
-MANager (CMAN), which must be set up and running in order for cmirrord to
-function.
+This daemon relies on the cluster infrastructure provided by the
+Cluster MANager (CMAN), which must be set up and running in order for
+cmirrord to function.
 
 %package -n device-mapper
 Summary:       Userspace support for the device-mapper
@@ -268,8 +258,6 @@ potrzeby initrd.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p1
-%patch7 -p1
-%patch8 -p1
 
 # do not force --export-symbol linker option for e.g. statically linked executables
 # -rdynamic compiler option drives linker in the right way.
@@ -308,6 +296,7 @@ cp -f /usr/share/automake/config.sub autoconf
 %{__make} -j1 -C include
 %{__make} -j1 -C lib LIB_SHARED= VERSIONED_SHLIB=
 %{__make} -j1 -C libdm LIB_SHARED= VERSIONED_SHLIB=
+%{__make} -j1 -C libdaemon/client LIB_SHARED= VERSIONED_SHLIB=
 %{__make} -j1 -C tools dmsetup.static lvm.static %{?with_dietlibc:DIETLIBC_LIBS="-lcompat"}
 mv -f tools/lvm.static initrd-lvm
 mv -f tools/dmsetup.static initrd-dmsetup
@@ -343,8 +332,8 @@ unset CC
        --enable-udev_sync \
        --enable-udev_rules \
 %if %{with cluster}
-       %{?with_corosync:--enable-cmirrord} \
-       --with-clvmd=%{?with_cman:cman,}%{?with_openais:openais,}%{?with_corosync:corosync} \
+       --with-clvmd=corosync \
+       --enable-cmirrord \
 %endif
        --with-lvm1=internal \
        --with-pool=internal \
@@ -352,6 +341,7 @@ unset CC
        --with-snapshots=internal \
        --with-mirrors=internal \
        --with-thin=internal \
+       --with-thin-check="" \
        --with-interface=ioctl \
        --with-udev-prefix=/ \
        --with-systemd_dir=%{systemdunitdir} \
@@ -370,8 +360,8 @@ install -d $RPM_BUILD_ROOT{/%{_lib},%{_sysconfdir}/lvm}
        OWNER="" \
        GROUP=""
 
-mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
-install -m 0644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
+install -d $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d
+install %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/tmpfiles.d/%{name}.conf
 
 mv $RPM_BUILD_ROOT%{_libdir}/lib*.so.* $RPM_BUILD_ROOT/%{_lib}
 for lib in $RPM_BUILD_ROOT/%{_lib}/lib*.so.*; do
@@ -399,14 +389,20 @@ rm -rf $RPM_BUILD_ROOT
 /sbin/chkconfig --add lvm2-monitor
 %service lvm2-monitor restart
 %systemd_post lvm2-monitor.service
+/sbin/chkconfig --add blk-availability
+# no service blk-availability restart
+%systemd_post blk-availability.service
 
 %preun
 %systemd_preun lvm2-monitor.service
+%systemd_preun blk-availability.service
 
 %postun
 if [ "$1" = "0" ]; then
        %service lvm2-monitor stop
        /sbin/chkconfig --del lvm2-monitor
+       #no service blk-availability stop
+       /sbin/chkconfig --del blk-availability
 fi
 %systemd_reload
 
@@ -430,11 +426,13 @@ fi
 %files
 %defattr(644,root,root,755)
 %doc README WHATS_NEW doc/*
+%attr(755,root,root) %{_sbindir}/blkdeactivate
 %attr(755,root,root) %{_sbindir}/fsadm
 %attr(755,root,root) %{_sbindir}/lv*
 %attr(755,root,root) %{_sbindir}/pv*
 %attr(755,root,root) %{_sbindir}/vg*
 %{_mandir}/man5/lvm.conf.5*
+%{_mandir}/man8/blkdeactivate.8*
 %{_mandir}/man8/fsadm.8*
 %{_mandir}/man8/lv*.8*
 %{_mandir}/man8/pv*.8*
@@ -443,8 +441,10 @@ fi
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lvm/lvm.conf
 %{_sysconfdir}/tmpfiles.d/lvm2.conf
 %{systemdunitdir}/lvm2-monitor.service
+%{systemdunitdir}/blk-availability.service
 %dir %{_sysconfdir}/lvm/cache
 %ghost %{_sysconfdir}/lvm/cache/.cache
+%attr(754,root,root) /etc/rc.d/init.d/blk-availability
 %attr(754,root,root) /etc/rc.d/init.d/lvm2-monitor
 
 %if %{with cluster}
@@ -454,14 +454,12 @@ fi
 %attr(754,root,root) /etc/rc.d/init.d/clvmd
 %{_mandir}/man8/clvmd.8*
 
-%if %{with corosync}
 %files cmirrord
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_usrsbindir}/cmirrord
 %{_mandir}/man8/cmirrord.8*
 %attr(754,root,root) /etc/rc.d/init.d/cmirrord
 %endif
-%endif
 
 %files -n device-mapper
 %defattr(644,root,root,755)
diff --git a/pldize_lvm2_monitor.patch b/pldize_lvm2_monitor.patch
deleted file mode 100644 (file)
index d6c96ae..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
---- LVM2.2.02.85/scripts/lvm2_monitoring_init_red_hat.in       2011-10-05 21:36:47.152774996 +0200
-+++ LVM2.2.02.95/scripts/lvm2_monitoring_init_red_hat.in       2012-04-18 18:11:44.000000000 +0300
-@@ -1,3 +1,3 @@
--#!/bin/bash
-+#!/bin/sh
- #
- # Copyright (C) 2007-2009 Red Hat, Inc. All rights reserved.
-@@ -46,12 +46,19 @@
- start()
- {
--      ret=0
-+      local ret=0
-       # TODO do we want to separate out already active groups only?
-       VGSLIST=`$VGS --noheadings -o name --config 'log{command_names=0 prefix="  "}' 2> /dev/null`
-       for vg in $VGSLIST
-       do
--          action "Starting monitoring for VG $vg:" $VGCHANGE --monitor y --poll y --config 'log{command_names=0 prefix="  "}' $vg || ret=$?
-+          msg_starting "Starting monitoring for VG $vg:"; busy
-+              $VGCHANGE --monitor y --poll y --config 'log{command_names=0 prefix="  "}' $vg
-+              ret=$?
-+              if [ $ret -ne 0 ]; then
-+                      fail
-+                      return $ret
-+              fi
-+              ok
-       done
-       return $ret
-@@ -60,7 +67,7 @@
- stop()
- {
--      ret=0
-+      local ret=0
-       # TODO do we want to separate out already active groups only?
-       if test "$WARN" = "1"; then
-          echo "Not stopping monitoring, this is a dangerous operation. Please use force-stop to override."
-@@ -69,7 +76,14 @@
-       VGSLIST=`$VGS --noheadings -o name --config 'log{command_names=0 prefix="  "}' 2> /dev/null`
-       for vg in $VGSLIST
-       do
--          action "Stopping monitoring for VG $vg:" $VGCHANGE --monitor n --config 'log{command_names=0 prefix="  "}' $vg || ret=$?
-+          msg_stopping "Stopping monitoring for VG $vg:"; busy
-+              $VGCHANGE --monitor n --config 'log{command_names=0 prefix="  "}' $vg
-+              ret=$?
-+              if [ $ret -ne 0 ]; then
-+                      fail
-+                      return $ret
-+              fi
-+              ok
-       done
-       return $ret
- }
---- LVM2.2.02.94/scripts/lvm2_monitoring_systemd_red_hat.service.in~   2012-02-01 15:08:39.000000000 +0200
-+++ LVM2.2.02.94/scripts/lvm2_monitoring_systemd_red_hat.service.in    2012-03-29 00:12:31.886921407 +0300
-@@ -1,7 +1,7 @@
- [Unit]
- Description=Monitoring of LVM2 mirrors, snapshots etc. using dmeventd or progress polling
- Requires=dm-event.socket
--After=dm-event.socket fedora-storage-init.service fedora-storage-init-late.service
-+After=dm-event.socket pld-storage-init.service pld-storage-init-late.service
- Before=local-fs.target
- DefaultDependencies=no
- Conflicts=shutdown.target
This page took 0.056837 seconds and 4 git commands to generate.