]> git.pld-linux.org Git - packages/lms.git/blob - lms.spec
cf6c27061fcbcfcc0b9a7d9ddb259f51fcab9f01
[packages/lms.git] / lms.spec
1 %define         _add pre5
2 Summary:        LAN Managment System
3 Summary(pl):    System Zarz±dzania Siec± Lokaln±
4 Name:           lms
5 Version:        1.0
6 Release:        0.2.%{_add}
7 License:        GPL
8 Group:          Networking/Utilities
9 Source0:        http://lms.rulez.pl/download/%{name}-%{version}%{_add}.tar.gz
10 Vendor:         Rulez.PL
11 Requires:       php
12 Requires:       php-posix
13 Requires:       webserver
14 Requires:       mysql
15 #Requires:      perl-Getopt-Long
16 # for now i'm not sure is it required ...
17 Requires:       perl-Net-SMTP-Server
18 Requires:       perl-Config-IniFiles
19 Requires:       perl-DBI
20 Requires:       perl-DBD-mysql
21 Requires:       perl-DBD-Pg
22 Requires:       Smarty
23 Requires:       ADOdb
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %define         _lmsdir /home/services/httpd/html/%{name}
28
29 %description
30 This is a package of applications in PHP and Perl to managing LANs.
31 It's using MySQL (for now) but PostgreSQL will be supported in near
32 future. Main foundation is get the best service of users at
33 providiers level.
34 The main sign in LMS are:
35 - database of users (name, surname, address, telefon number, 
36   commentary);
37 - database of computers (IP, MAC);
38 - easy-ridden financial system and funds of network;
39 - different subscriptions;
40 - sending warnings to users;
41 - autogenerating dhcpd.conf;
42 - autogenerating firewall rules (ipchains/iptables);
43 - autogenerating idents for ident daemon;
44 - many levels of access for LMS administrators;
45 - integration with LinuxStat package;
46 - autogenerating ARP rules (ether auth);
47 - autogenerating DNS files;
48
49 %description -l pl
50 "LMS" jest skrótem od "LAN Management System". Jest to zestaw
51 aplikacji w PHP i Perlu, u³atwiaj±cych zarz±dzanie sieciami
52 osiedlowymi (popularnie zwanymi Amatorskimi Sieciami Komputerowymi),
53 opartych o bazê danych MySQL (docelowo, do wyboru, MySQL lub
54 PostgreSQL). G³ówne za³o¿enia to uzyskanie jako¶ci us³ug oraz obs³ugi
55 u¿ytkowników na poziomie providera z prawdziwego zdarzenia.
56 Najbardziej podstawowe cechy LMS to:
57 - baza danych u¿ytkowników (imiê, nazwisko, adres, numer telefonu,
58   uwagi);
59 - baza danych komputerów (adres IP, adres MAC);
60 - prowadzenie prostego rachunku operacji finansowych oraz stanu
61   funduszów sieci;
62 - ró¿ne taryfy abonamentowe;
63 - wysy³anie poczt± elektroniczn± upomnieñ do u¿ytkowników;
64 - automatyczne naliczanie op³at miesiêcznych;
65 - generowanie dhcpd.conf;
66 - generowanie regu³ firewalla (ipchains/iptables);
67 - generowanie identów dla demona oidentd;
68 - ró¿ne poziomy dostêpu do funkcji LMS dla administratorów;
69 - integracja z pakietem LinuxStat;
70 - generowanie wpisów ARP (blokada adresów IP po ARP);
71 - generowanie wpisów do DNS;
72
73 %prep
74 %setup -q -n lms
75
76 %install
77 rm -rf $RPM_BUILD_ROOT
78 install -d $RPM_BUILD_ROOT%{_lmsdir}/{img,lib,modules,templates,templates_c}
79 install -d $RPM_BUILD_ROOT%{_datadir}/%{name}
80 install -d $RPM_BUILD_ROOT%{_bindir}/
81
82 install *.php $RPM_BUILD_ROOT%{_lmsdir}
83 install -d {img,lib,modules,templates,templates_c} $RPM_BUILD_ROOT%{_lmsdir}
84 install -d backup $RPM_BUILD_ROOT%{_localstatedir}/%{name}/
85 install bin/* $RPM_BUILD_ROOT%{_bindir}/
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc doc
93 %dir %{_lmsdir}
94 %attr(770,root,http) %{_lmsdir}/templates_c
95 %{_lmsdir}/*.php
96 %{_lmsdir}/img
97 %{_lmsdir}/lib
98 %{_lmsdir}/modules
99 %{_lmsdir}/templates
100 %{_localstatedir}/%{name}
101 %{_bindir}/lms-*
This page took 0.141902 seconds and 2 git commands to generate.