]> git.pld-linux.org Git - packages/llvm.git/commitdiff
up to 11.0.0
authorJan Palus <atler@pld-linux.org>
Tue, 13 Oct 2020 08:24:56 +0000 (10:24 +0200)
committerJan Palus <atler@pld-linux.org>
Tue, 13 Oct 2020 08:24:56 +0000 (10:24 +0200)
- flang not packaged (requires MLIR not included in release)
- continue using old approach to finding python interpreter (prefers
  python2 which seems still required by lldb bindings)

lld-sphinx2.patch [deleted file]
llvm-python-modules.patch
llvm.spec

diff --git a/lld-sphinx2.patch b/lld-sphinx2.patch
deleted file mode 100644 (file)
index 24de5af..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- llvm-10.0.0.src/tools/lld/docs/conf.py.orig        2020-04-11 21:02:50.200235591 +0200
-+++ llvm-10.0.0.src/tools/lld/docs/conf.py     2020-04-11 21:02:56.470201624 +0200
-@@ -134,7 +134,7 @@
- #html_use_smartypants = True
- # Custom sidebar templates, maps document names to template names.
--html_sidebars = {'index': 'indexsidebar.html'}
-+html_sidebars = {'index': ['indexsidebar.html']}
- # Additional templates that should be rendered to pages, maps page names to
- # template names.
index 5a013239b62b248ee1a7bb0a7ccbe61bcfa7f91c..fa8d826ddc21f6e8c3e1abc0dd5ba2424ab6126c 100644 (file)
@@ -1,6 +1,6 @@
---- llvm-9.0.0.src/CMakeLists.txt.orig 2019-08-26 14:31:37.000000000 +0200
-+++ llvm-9.0.0.src/CMakeLists.txt      2019-12-04 00:12:17.536142461 +0100
-@@ -612,6 +612,18 @@
+--- llvm-11.0.0.src/CMakeLists.txt.orig        2020-10-07 12:10:48.000000000 +0200
++++ llvm-11.0.0.src/CMakeLists.txt     2020-10-13 01:18:33.807817497 +0200
+@@ -646,6 +646,23 @@
  set(LLVM_ENABLE_PER_TARGET_RUNTIME_DIR OFF CACHE BOOL
    "Enable per-target runtimes directory")
  
 +  message(FATAL_ERROR "Python 2.7 or newer is required")
 +endif()
 +
- # All options referred to from HandleLLVMOptions have to be specified
- # BEFORE this include, otherwise options will not be correctly set on
- # first cmake run
-@@ -642,18 +654,6 @@
++add_executable(Python3::Interpreter IMPORTED)
++set_target_properties(Python3::Interpreter PROPERTIES
++  IMPORTED_LOCATION ${PYTHON_EXECUTABLE})
++set(Python3_EXECUTABLE ${PYTHON_EXECUTABLE})
++
+ set(LLVM_PROFDATA_FILE "" CACHE FILEPATH
+   "Profiling data file to use when compiling in order to improve runtime performance.")
+@@ -679,40 +691,6 @@
  
  include(HandleLLVMOptions)
  
--include(FindPythonInterp)
--if( NOT PYTHONINTERP_FOUND )
--  message(FATAL_ERROR
--"Unable to find Python interpreter, required for builds and testing.
+-if(CMAKE_VERSION VERSION_LESS 3.12)
+-  include(FindPythonInterp)
+-  if( NOT PYTHONINTERP_FOUND )
+-    message(FATAL_ERROR
+-  "Unable to find Python interpreter, required for builds and testing.
 -
--Please install Python or specify the PYTHON_EXECUTABLE CMake variable.")
--endif()
+-  Please install Python or specify the PYTHON_EXECUTABLE CMake variable.")
+-  endif()
+-
+-  if( ${PYTHON_VERSION_STRING} VERSION_LESS 2.7 )
+-    message(FATAL_ERROR "Python 2.7 or newer is required")
+-  endif()
+-
+-  add_executable(Python3::Interpreter IMPORTED)
+-  set_target_properties(Python3::Interpreter PROPERTIES
+-    IMPORTED_LOCATION ${PYTHON_EXECUTABLE})
+-  set(Python3_EXECUTABLE ${PYTHON_EXECUTABLE})
+-else()
+-  find_package(Python3 COMPONENTS Interpreter)
+-  if(NOT Python3_Interpreter_FOUND)
+-    message(WARNING "Python3 not found, using python2 as a fallback")
+-    find_package(Python2 COMPONENTS Interpreter REQUIRED)
+-    if(Python2_VERSION VERSION_LESS 2.7)
+-      message(SEND_ERROR "Python 2.7 or newer is required")
+-    endif()
 -
--if( ${PYTHON_VERSION_STRING} VERSION_LESS 2.7 )
--  message(FATAL_ERROR "Python 2.7 or newer is required")
+-    # Treat python2 as python3
+-    add_executable(Python3::Interpreter IMPORTED)
+-    set_target_properties(Python3::Interpreter PROPERTIES
+-      IMPORTED_LOCATION ${Python2_EXECUTABLE})
+-    set(Python3_EXECUTABLE ${Python2_EXECUTABLE})
+-  endif()
 -endif()
 -
  ######
index 56d1b2d18933aee14a8cd13511c60660897eab8f..801f3ffe74863569c96d41185e6e259b09339fc5 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       10.0.1
+Version:       11.0.0
 Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: https://github.com/llvm/llvm-project/releases/
 Source0:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 71c68c526cbbf1674b5aafc5542b336c
+# Source0-md5: 85844102335b2e01b3c64b6734fb56f2
 Source1:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-%{version}.src.tar.xz
-# Source1-md5: 6c8b56f531876fd24e06257a2d8ce422
+# Source1-md5: d8fbc5b1d27f44922cfbbf199d0bab78
 Source2:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: 970835d14e9c08a68c4b2ff3931bada7
+# Source2-md5: 182511f9ba2c83b9d3c934501d48bee9
 Source3:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 0dddd62dd96ba97ccf075fc3ca086024
+# Source3-md5: f36e38d039721555cd41e8687d577094
 Source4:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 263ad3980c19012719b14333b69c108e
+# Source4-md5: 314d2db9d05ff6bf006ce3496de47b53
 Source5:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 251388aa2f5fbd472acc9735b3386e59
+# Source5-md5: 8f7c4942b26c91de2b90dc85e38590d1
 Source6:       https://github.com/llvm/llvm-project/releases/download/llvmorg-%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: c8f364fbb129e47ef2793c317561449a
+# Source6-md5: b2f9f55fd275a384f0dfbbc41242d52e
 Patch1:                %{name}-pld.patch
 Patch2:                %{name}-python-modules.patch
 Patch3:                x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
-Patch6:                lld-sphinx2.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
@@ -140,7 +139,7 @@ Requires:   %{name}-libs = %{version}-%{release}
 ExcludeArch:   ppc64
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                abi     10
+%define                abi     11
 %define                _sysconfdir     /etc/%{name}
 
 %define                specflags_ppc   -fno-var-tracking-assignments
@@ -553,7 +552,6 @@ Integracja narzędzi Clang do formatowania i zmiany nazw z Vimem.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%patch6 -p1
 
 grep -rl /usr/bin/env projects tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
@@ -723,6 +721,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-elfabi
 %attr(755,root,root) %{_bindir}/llvm-exegesis
 %attr(755,root,root) %{_bindir}/llvm-extract
+%attr(755,root,root) %{_bindir}/llvm-gsymutil
 %attr(755,root,root) %{_bindir}/llvm-ifs
 %attr(755,root,root) %{_bindir}/llvm-install-name-tool
 %attr(755,root,root) %{_bindir}/llvm-jitlink
@@ -733,6 +732,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvm-lto2
 %attr(755,root,root) %{_bindir}/llvm-mc
 %attr(755,root,root) %{_bindir}/llvm-mca
+%attr(755,root,root) %{_bindir}/llvm-ml
 %attr(755,root,root) %{_bindir}/llvm-modextract
 %attr(755,root,root) %{_bindir}/llvm-mt
 %attr(755,root,root) %{_bindir}/llvm-nm
@@ -807,10 +807,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libLLVM-%{abi}.so
 # non-soname symlink
 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
-%attr(755,root,root) %ghost %{_libdir}/libLTO.so.10
+%attr(755,root,root) %ghost %{_libdir}/libLTO.so.11
 %attr(755,root,root) %{_libdir}/LLVMgold.so
-%attr(755,root,root) %{_libdir}/libRemarks.so.10
-%attr(755,root,root) %{_libdir}/libclang-cpp.so.10
+%attr(755,root,root) %{_libdir}/libRemarks.so.11
+%attr(755,root,root) %{_libdir}/libclang-cpp.so.11
 
 %files devel
 %defattr(644,root,root,755)
@@ -862,7 +862,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang-cpp
 %attr(755,root,root) %{_bindir}/clang-doc
 %attr(755,root,root) %{_bindir}/clang-format
-%attr(755,root,root) %{_bindir}/clang-import-test
 %attr(755,root,root) %{_bindir}/clang-offload-bundler
 %attr(755,root,root) %{_bindir}/clang-offload-wrapper
 %attr(755,root,root) %{_bindir}/git-clang-format
@@ -966,6 +965,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_libdir}/libclang*.a
 %{_includedir}/clang
 %{_includedir}/clang-c
+%{_includedir}/clang-tidy
 %{_libdir}/cmake/clang
 
 %files -n clang-doc
@@ -1016,6 +1016,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %{_libdir}/liblld[ACDEHMRWXY]*.a
 %{_includedir}/lld
+%{_libdir}/cmake/lld
 
 %if %{with lldb}
 %files -n lldb
@@ -1026,8 +1027,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/lldb-server
 %attr(755,root,root) %{_bindir}/lldb-vscode
 %attr(755,root,root) %{_libdir}/liblldb.so.%{version}
-%attr(755,root,root) %ghost %{_libdir}/liblldb.so.10
-%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.10
+%attr(755,root,root) %ghost %{_libdir}/liblldb.so.11
+%attr(755,root,root) %ghost %{_libdir}/liblldbIntelFeatures.so.11
 %dir %{py_sitedir}/lldb
 %attr(755,root,root) %{py_sitedir}/lldb/lldb-argdumper
 %{py_sitedir}/lldb/formatters
This page took 0.215721 seconds and 4 git commands to generate.