]> git.pld-linux.org Git - packages/llvm.git/commitdiff
Detect PLD GCC triplet. Probably needs to be fixed for arch != x86.
authorwolf <wolf@pld-linux.org>
Sun, 17 Apr 2011 15:37:01 +0000 (15:37 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    llvm-pld.patch -> 1.1
    llvm.spec -> 1.22

llvm-pld.patch [new file with mode: 0644]
llvm.spec

diff --git a/llvm-pld.patch b/llvm-pld.patch
new file mode 100644 (file)
index 0000000..01f94e1
--- /dev/null
@@ -0,0 +1,13 @@
+diff -ruN llvm-2.9./tools/clang/lib/Driver/ToolChains.cpp llvm-2.9/tools/clang/lib/Driver/ToolChains.cpp
+--- llvm-2.9./tools/clang/lib/Driver/ToolChains.cpp    2011-03-21 22:29:27.000000000 +0100
++++ llvm-2.9/tools/clang/lib/Driver/ToolChains.cpp     2011-04-17 16:57:06.471923892 +0200
+@@ -1447,6 +1447,9 @@
+     else if (!llvm::sys::fs::exists("/usr/lib/gcc/i586-suse-linux", Exists) &&
+              Exists)
+       GccTriple = "i586-suse-linux";
++    else if (!llvm::sys::fs::exists("/usr/lib/gcc/triplet-plox-here", Exists) &&
++             Exists)
++      GccTriple = "triplet-plox-here";
+   }
+   const char* GccVersions[] = {"4.5.2", "4.5.1", "4.5", "4.4.5", "4.4.4",
index 39a65a09fc18a0b34d2c2ec5b7d347d364310134..c7bf90f3dcdef8fc3300c80027e9597d53842c9a 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -25,6 +25,7 @@ Source1:      http://llvm.org/releases/%{version}/clang-%{version}.tgz
 # Source1-md5: 634de18d04b7a4ded19ec4c17d23cfca
 # Data files should be installed with timestamps preserved
 Patch3:                %{name}-2.6-timestamp.patch
+Patch4:                %{name}-pld.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
@@ -190,6 +191,9 @@ HTML documentation for LLVM's OCaml binding.
 %setup -q -a1
 mv clang-*.* tools/clang
 %patch3 -p1
+%patch4 -p1
+
+sed -i 's|triplet-plox-here|%{_host}|' tools/clang/lib/Driver/ToolChains.cpp
 
 # configure does not properly specify libdir
 sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
This page took 0.042281 seconds and 4 git commands to generate.