]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- ups, was using older tarball; update to final one now
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 15 Jun 2013 19:13:21 +0000 (21:13 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Sat, 15 Jun 2013 19:13:21 +0000 (21:13 +0200)
llvm-config.patch
llvm-pld.patch
llvm.spec

index abdbdb9734f721666d19d793065971ac5378324d..38dc3ad6cb528c164962dffbef7ad04d3a57bc4c 100644 (file)
                      "/../../" + Multilib, Paths);
  
    // Add the non-multilib suffixed paths (if potentially different).
-@@ -2189,7 +2189,7 @@ Linux::Linux(const Driver &D, const llvm
+@@ -2342,7 +2342,7 @@ Linux::Linux(const Driver &D, const llvm
      }
    }
    addPathIfExists(SysRoot + "/lib", Paths);
 -  addPathIfExists(SysRoot + "/usr/lib", Paths);
 +  addPathIfExists(SysRoot + LLVM_LIBDIR, Paths);
- }
  
- bool Linux::HasNativeLLVMSupport() const {
+   IsPIEDefault = SanitizerArgs(*this, Args).hasZeroBaseShadow();
+ }
 --- llvm-3.2.src/tools/clang/lib/Driver/Tools.cpp.orig 2012-11-21 08:56:23.000000000 +0100
 +++ llvm-3.2.src/tools/clang/lib/Driver/Tools.cpp      2013-01-26 18:43:56.952167604 +0100
 @@ -218,7 +218,7 @@ static void addProfileRT(const ToolChain
index 96d8bda7c66f89d634ddc5b36cdc0ec17ecb7c1b..c9c88047afbb365a5ba5db688683de8c693ec6fd 100644 (file)
@@ -59,7 +59,7 @@
 @@ -2088,7 +2100,7 @@
    // ABI requires a mapping between the GOT and the symbol table.
    // Android loader does not support .gnu.hash.
-   if (!isMipsArch(Arch) && !IsAndroid) {
+   if (!IsMips && !IsAndroid) {
 -    if (IsRedhat(Distro) || IsOpenSuse(Distro) ||
 +    if (IsRedhat(Distro) || IsOpenSuse(Distro) || IsPLD(Distro) ||
          (IsUbuntu(Distro) && Distro >= UbuntuMaverick))
index 0df8c07711aa2d6743b7640d5720f4100c44802d..87aa0d5f7aff661b2a5be2ca02a3147bcc0674ec 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -24,6 +24,8 @@ Group:                Development/Languages
 #Source0Download: http://llvm.org/releases/download.html
 Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.gz
 # Source0-md5: 40564e1dc390f9844f1711c08b08e391
+Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.gz
+# Source1-md5: xyz
 Patch0:                %{name}-config.patch
 # Data files should be installed with timestamps preserved
 Patch1:                %{name}-2.6-timestamp.patch
@@ -262,7 +264,8 @@ HTML documentation for LLVM's OCaml binding.
 Dokumentacja HTML wiązania OCamla do LLVM-a.
 
 %prep
-%setup -q -n %{name}-%{version}.src
+%setup -q -a1 -n %{name}-%{version}.src
+mv cfe-%{version}.src tools/clang
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
@@ -311,10 +314,6 @@ bash ../%configure \
        --enable-shared \
        --with-pic
 
-# hack so it will find own headers
-install -d Release
-ln -s lib Release/lib64
-
 %{__make} \
        VERBOSE=1 \
        REQUIRES_RTTI=1 \
@@ -436,6 +435,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvm-nm.1*
 %{_mandir}/man1/llvm-prof.1*
 %{_mandir}/man1/llvm-ranlib.1*
+%{_mandir}/man1/llvm-readobj.1*
 %{_mandir}/man1/llvm-stress.1*
 %{_mandir}/man1/llvm-symbolizer.1*
 %{_mandir}/man1/opt.1*
@@ -443,7 +443,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files libs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libLLVM-%{version}svn.so
+%attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.041853 seconds and 4 git commands to generate.