]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- fix ocaml binding build, release 1. auto/th/llvm-3_0-1
authorPaweł Sikora <pluto@pld-linux.org>
Thu, 9 Feb 2012 19:09:21 +0000 (19:09 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    llvm-bug11177.patch -> 1.1
    llvm.spec -> 1.30

llvm-bug11177.patch [new file with mode: 0644]
llvm.spec

diff --git a/llvm-bug11177.patch b/llvm-bug11177.patch
new file mode 100644 (file)
index 0000000..7eff486
--- /dev/null
@@ -0,0 +1,45 @@
+make *** No rule to make target (...)/rpm/BUILD/llvm-3.0.src/obj/bindings/ocaml/llvm/Release/META.llvm, needed by install-meta.
+
+Index: bindings/ocaml/Makefile.ocaml
+===================================================================
+--- bindings/ocaml/Makefile.ocaml      (revision 144182)
++++ bindings/ocaml/Makefile.ocaml      (revision 144183)
+@@ -238,14 +238,14 @@
+ # Also install the .mli's (headers) as documentation.
+ install-cmis: $(OutputsCMI) $(OcamlHeaders)
+       $(Verb) $(MKDIR) $(PROJ_libocamldir)
++      $(Verb) for i in $(OcamlHeaders:$(ObjDir)/%=%); do \
++        $(EchoCmd) "Installing $(BuildMode) $(PROJ_libocamldir)/$$i"; \
++        $(DataInstall) $(ObjDir)/$$i "$(PROJ_libocamldir)/$$i"; \
++      done
+       $(Verb) for i in $(OutputsCMI:$(OcamlDir)/%=%); do \
+         $(EchoCmd) "Installing $(BuildMode) $(PROJ_libocamldir)/$$i"; \
+         $(DataInstall) $(OcamlDir)/$$i "$(PROJ_libocamldir)/$$i"; \
+       done
+-      $(Verb) for i in $(OcamlHeaders:$(ObjDir)/%=%); do \
+-        $(EchoCmd) "Installing $(BuildMode) $(PROJ_libocamldir)/$$i"; \
+-        $(DataInstall) $(ObjDir)/$$i "$(PROJ_libocamldir)/$$i"; \
+-      done
+ uninstall-cmis::
+       $(Verb) for i in $(OutputsCMI:$(OcamlDir)/%=%); do \
+Index: bindings/ocaml/llvm/Makefile
+===================================================================
+--- bindings/ocaml/llvm/Makefile       (revision 144182)
++++ bindings/ocaml/llvm/Makefile       (revision 144183)
+@@ -30,11 +30,13 @@
+ $(OcamlDir)/META.llvm: META.llvm
+       $(Verb) $(CP) -f $< $@
+-install-meta:: $(ObjDir)/META.llvm
++install-meta:: $(OcamlDir)/META.llvm
+       $(Echo) "Install $(BuildMode) $(DestMETA)"
+       $(Verb) $(MKDIR) $(PROJ_libocamldir)
+-      $(Verb) $(DataInstall) META.llvm "$(DestMETA)"
++      $(Verb) $(DataInstall) $< "$(DestMETA)"
+ uninstall-meta::
+       $(Echo) "Uninstalling $(DestMETA)"
+       -$(Verb) $(RM) -f "$(DestMETA)"
++
++.PHONY: copy-meta install-meta uninstall-meta
index 96226df60bb14f05b10a1a1c26600672ad700150..dbf2bd3aad6464c853f9673ca090f24063af4635 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -1,7 +1,4 @@
 #
-# TODO:
-# make *** No rule to make target (...)/rpm/BUILD/llvm-3.0.src/obj/bindings/ocaml/llvm/Release/META.llvm, needed by install-meta.
-#
 # Conditional build:
 %bcond_without ocaml   # ocaml binding
 %bcond_with    apidocs # The doxygen docs are HUGE, so they are not built by default.
@@ -16,7 +13,7 @@ Summary:      The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
 Version:       3.0
-Release:       0.1
+Release:       1
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.tar.gz
@@ -26,6 +23,7 @@ Source1:      http://llvm.org/releases/%{version}/clang-%{version}.tar.gz
 # Data files should be installed with timestamps preserved
 Patch3:                %{name}-2.6-timestamp.patch
 Patch4:                %{name}-pld.patch
+Patch5:                %{name}-bug11177.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
@@ -245,6 +243,7 @@ Dokumentacja HTML wiązania OCamla do LLVM-a.
 mv clang-*.* tools/clang
 %patch3 -p1
 %patch4 -p1
+%patch5 -p0
 
 # configure does not properly specify libdir
 sed -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
@@ -464,11 +463,13 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ocaml}
 %files ocaml
 %defattr(644,root,root,755)
+%{_libdir}/ocaml/META.llvm
 %{_libdir}/ocaml/llvm*.cma
 %{_libdir}/ocaml/llvm*.cmi
 
 %files ocaml-devel
 %defattr(644,root,root,755)
+%{_libdir}/libllvm*.a
 %{_libdir}/ocaml/libLLVM*.a
 %{_libdir}/ocaml/libllvm*.a
 %{_libdir}/ocaml/llvm*.a
This page took 0.141 seconds and 4 git commands to generate.