]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- move tblgen.1 manpage to proper package.
authorPaweł Sikora <pluto@pld-linux.org>
Wed, 10 Nov 2010 11:54:59 +0000 (11:54 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- move shared runtime libs to proper core packages.

Changed files:
    llvm.spec -> 1.16

llvm.spec

index 8b9c2c61233404a8cbb850a29483c4e97432d76d..b87a643224fa45a3d2fa533c5f1a72d7a4f0d0b1 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -279,6 +279,9 @@ rm -rf moredocs/examples
 cp -a examples moredocs/examples
 find moredocs/examples -name Makefile | xargs -0r rm -f
 
+# Move shared runtime to standard libdir.
+mv $RPM_BUILD_ROOT%{_libdir}/%{name}/lib{LLVM-*.*,clang}.so $RPM_BUILD_ROOT%{_libdir}
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -296,6 +299,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/llvmc
 %attr(755,root,root) %{_bindir}/llvm-*
 %exclude %attr(755,root,root) %{_bindir}/llvm-config
+%attr(755,root,root) %{_libdir}/libLLVM-*.*.so
 %{_mandir}/man1/bugpoint.1*
 %{_mandir}/man1/llc.1*
 %{_mandir}/man1/lli.1*
@@ -305,7 +309,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/llvmgxx.1*
 %{_mandir}/man1/opt.1*
 #%{_mandir}/man1/stkrc.1*
-%{_mandir}/man1/tblgen.1*
 
 %files devel
 %defattr(644,root,root,755)
@@ -313,6 +316,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_includedir}/llvm
 %{_includedir}/llvm-c
 %{_libdir}/%{name}
+%exclude %attr(755,root,root) %{_libdir}/libLLVM-*.*.so
+%exclude %attr(755,root,root) %{_libdir}/libclang.so
 
 %files doc
 %defattr(644,root,root,755)
@@ -331,8 +336,10 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/clang*
 %attr(755,root,root) %{_bindir}/tblgen
 %attr(755,root,root) %{_bindir}/c-index-test
+%attr(755,root,root) %{_libdir}/libclang.so
 %{_prefix}/lib/clang
 %{_mandir}/man1/clang.1.*
+%{_mandir}/man1/tblgen.1*
 
 %files -n clang-analyzer
 %defattr(644,root,root,755)
This page took 0.071129 seconds and 4 git commands to generate.