]> git.pld-linux.org Git - packages/llvm.git/commitdiff
disable format-security due swig generated code
authorElan Ruusamäe <glen@delfi.ee>
Sun, 2 Oct 2016 14:11:45 +0000 (17:11 +0300)
committerElan Ruusamäe <glen@delfi.ee>
Sun, 2 Oct 2016 14:12:35 +0000 (17:12 +0300)
llvm-3.8.0.src/build/tools/lldb/scripts/LLDBWrapPython.cpp: In function ‘PyObject* _wrap_SBError_SetErrorStringWithFormat__SWIG_3(PyObject*, PyObject*)’:
llvm-3.8.0.src/build/tools/lldb/scripts/LLDBWrapPython.cpp:21362:70: error: format not a string literal and no format arguments [-Werror=format-security]
     result = (int)(arg1)->SetErrorStringWithFormat((char const *)arg2);

llvm.spec

index 290d98cf1244efef0883956c1e9a0bcefeb9712a..aedec3c7fd868d3dba97cc8c94e2a132ab43730d 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -124,9 +124,11 @@ BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
 %define                _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
 
-# clang doesn't know it, and leaving it here would pollute llvm-config
+# clang doesn't know -fvar-tracking-assignments, and leaving it here would pollute llvm-config
+# -Werror=format-security is for swig
+# TODO: add - -Werror=format-security to tools/lldb/scripts/LLDBWrapPython.cpp
 %define                filterout_c     -fvar-tracking-assignments
-%define                filterout_cxx   -fvar-tracking-assignments
+%define                filterout_cxx   -fvar-tracking-assignments -Werror=format-security
 %define                filterout_ccpp  -fvar-tracking-assignments
 
 # std::__once_call, std::__once_callable non-function symbols
This page took 0.029212 seconds and 4 git commands to generate.