]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- added lldb-atomic patch (try to fix lldb build on i[34]86) auto/th/llvm-3.5.0-1
authorJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 20:21:20 +0000 (22:21 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Sun, 19 Oct 2014 20:21:20 +0000 (22:21 +0200)
llvm-lldb-atomic.patch [new file with mode: 0644]
llvm.spec

diff --git a/llvm-lldb-atomic.patch b/llvm-lldb-atomic.patch
new file mode 100644 (file)
index 0000000..510864b
--- /dev/null
@@ -0,0 +1,11 @@
+--- llvm-3.5.0.src/tools/lldb/lib/Makefile.orig        2014-07-21 19:24:05.000000000 +0200
++++ llvm-3.5.0.src/tools/lldb/lib/Makefile     2014-10-19 22:11:21.104592254 +0200
+@@ -173,7 +173,7 @@
+     # Don't allow unresolved symbols.
+     LLVMLibsOptions += -Wl,--no-undefined
+     # Link in python
+-    LLVMLibsOptions += $(PYTHON_BUILD_FLAGS) -lrt -ledit -lncurses -lpanel
++    LLVMLibsOptions += $(PYTHON_BUILD_FLAGS) -lrt -ledit -lncurses -lpanel -latomic
+     LLVMLibsOptions += -Wl,--soname,lib$(LIBRARYNAME)$(SHLIBEXT)
+ endif
index 32968a7c69b0c7436d8afe6de5ac9a389cfe77ee..699fc487153e4aedb7876123ad27bc8e96539a52 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -41,7 +41,8 @@ Patch1:               %{name}-2.6-timestamp.patch
 Patch2:                %{name}-pld.patch
 Patch3:                %{name}-polly-update.patch
 Patch4:                %{name}-lldb.patch
-Patch5:                %{name}-lld-link.patch
+Patch5:                %{name}-lldb-atomic.patch
+Patch6:                %{name}-lld-link.patch
 URL:           http://llvm.org/
 BuildRequires: autoconf >= 2.60
 BuildRequires: automake >= 1:1.9.6
@@ -74,6 +75,9 @@ BuildRequires:        python
 BuildRequires: tcl-devel
 %endif
 %if %{with lldb}
+%ifarch i386 i486
+BuildRequires: libatomic-devel
+%endif
 BuildRequires: libedit-devel
 BuildRequires: libxml2-devel >= 2
 BuildRequires: ncurses-ext-devel
@@ -413,8 +417,13 @@ mv lld-%{version}.src tools/lld
 %patch1 -p1
 %patch2 -p1
 %{?with_polly:%patch3 -p1}
-%{?with_lldb:%patch4 -p1}
+%if %{with lldb}
+%patch4 -p1
+%ifarch i386 i486
 %patch5 -p1
+%endif
+%endif
+%patch6 -p1
 
 # configure does not properly specify libdir
 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
This page took 0.081269 seconds and 4 git commands to generate.