]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- updated patches
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Mar 2016 19:25:50 +0000 (20:25 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 12 Mar 2016 19:25:50 +0000 (20:25 +0100)
debuginfo-fix.patch [deleted file]
llvm-lld-link.patch
llvm-pld.patch
llvm.spec

diff --git a/debuginfo-fix.patch b/debuginfo-fix.patch
deleted file mode 100644 (file)
index 72ad371..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- llvm-3.7.0.src/include/llvm/CodeGen/CommandFlags.h~        2015-07-06 19:44:26.000000000 +0200
-+++ llvm-3.7.0.src/include/llvm/CodeGen/CommandFlags.h 2015-10-11 11:59:10.130862977 +0200
-@@ -21,7 +21,7 @@
- #include "llvm/IR/Intrinsics.h"
- #include "llvm/IR/Module.h"
- #include "llvm/MC/MCTargetOptionsCommandFlags.h"
--#include "llvm//MC/SubtargetFeature.h"
-+#include "llvm/MC/SubtargetFeature.h"
- #include "llvm/Support/CodeGen.h"
- #include "llvm/Support/CommandLine.h"
- #include "llvm/Support/Host.h"
index 631898d1dbaf7206df2dd11bc2247701287a7eac..ef90e1e8410b7abff15c35889a8725a65767be88 100644 (file)
    )
  
  include_directories(.)
---- llvm-3.7.0.src/tools/lld/lib/ReaderWriter/PECOFF/CMakeLists.txt.orig       2015-02-20 23:10:28.000000000 +0100
-+++ llvm-3.7.0.src/tools/lld/lib/ReaderWriter/PECOFF/CMakeLists.txt    2015-10-01 21:51:35.921762208 +0200
-@@ -13,4 +13,5 @@
-     lldCore
-     LLVMObject
-     LLVMSupport
-+    pthread
-   )
 --- llvm-3.7.0.src/tools/lld/lib/ReaderWriter/ELF/CMakeLists.txt.orig  2015-05-22 18:01:12.000000000 +0200
 +++ llvm-3.7.0.src/tools/lld/lib/ReaderWriter/ELF/CMakeLists.txt       2015-10-02 15:51:47.415199842 +0200
 @@ -17,6 +17,7 @@
index b93a34887413344621fb84913aed5cac0a2d5cb2..17406c10b0a20f01fd2bdf55de4fdf206a1bd6e3 100644 (file)
    DebianSqueeze,
    DebianWheezy,
 @@ -2820,6 +2824,10 @@
-   return Distro >= UbuntuHardy && Distro <= UbuntuTrusty;
+   return Distro >= UbuntuHardy && Distro <= UbuntuXenial;
  }
  
 +static bool IsPLD(enum Distro Distro) {
 +  return Distro == PLDLinux;
 +}
 +
- static Distro DetectDistro(llvm::Triple::ArchType Arch) {
+ static Distro DetectDistro(const Driver &D, llvm::Triple::ArchType Arch) {
    llvm::ErrorOr<std::unique_ptr<llvm::MemoryBuffer>> File =
        llvm::MemoryBuffer::getFile("/etc/lsb-release");
 @@ -2888,6 +2896,9 @@
index 5ad15ee6591165e61e3f6ac3a4b5a8da8f4010bd..66dc10cafe1f09af46265b916dfee3913b5ef1e3 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -46,7 +46,6 @@ Patch0:               %{name}-lld-link.patch
 Patch1:                %{name}-pld.patch
 Patch2:                libdir.patch
 Patch3:                x32-gcc-toolchain.patch
-Patch5:                debuginfo-fix.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
@@ -486,7 +485,6 @@ mv lld-%{version}.src tools/lld
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
-%patch5 -p1
 
 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
This page took 0.038821 seconds and 4 git commands to generate.