]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- added BRs (and bcond) for multilib clang rt
authorJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Nov 2015 11:32:19 +0000 (12:32 +0100)
committerJakub Bogusz <qboosh@pld-linux.org>
Sat, 28 Nov 2015 11:32:19 +0000 (12:32 +0100)
llvm.spec

index 9618fe38cba20a1de6815de7bdfca0ac4620147d..f4df28b809fa6563a4a647d3f5d9c8f56b4834be 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -6,13 +6,14 @@
 # - no content in doc package (it used to contain parts of clang apidocs and some examples)
 #
 # Conditional build:
-%bcond_without lldb    # LLDB debugger
-%bcond_without polly   # Polly cache-locality optimization, auto-parallelism and vectorization
-%bcond_without rt      # compiler-rt libraries
-%bcond_without ocaml   # OCaml binding
-%bcond_without doc     # HTML docs and man pages
-%bcond_with    apidocs # doxygen docs (HUGE, so they are not built by default)
-%bcond_with    tests   # run tests
+%bcond_without lldb            # LLDB debugger
+%bcond_without polly           # Polly cache-locality optimization, auto-parallelism and vectorization
+%bcond_without rt              # compiler-rt libraries
+%bcond_without multilib        # compiler-rt multilib libraries
+%bcond_without ocaml           # OCaml binding
+%bcond_without doc             # HTML docs and man pages
+%bcond_with    apidocs         # doxygen docs (HUGE, so they are not built by default)
+%bcond_with    tests           # run tests
 
 # No ocaml on other arches or no native ocaml (required for ocaml-ctypes)
 %ifnarch %{ix86} %{x8664} arm aarch64 ppc sparc sparcv9 
@@ -83,6 +84,12 @@ BuildRequires:       dejagnu
 BuildRequires: python
 BuildRequires: tcl-devel
 %endif
+%if %{with rt} && %{with multilib}
+%ifarch %{x8664}
+BuildRequires: gcc-c++-multilib-32
+BuildRequires: libstdc++-multilib-32-devel
+%endif
+%endif
 %if %{with lldb}
 BuildRequires: epydoc
 %ifarch i386 i486
@@ -758,7 +765,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libclang[A-Z]*.so.%{version}
 %attr(755,root,root) %ghost %{_libdir}/libclang[A-Z]*.so.3.7
 
-%if %{with rt}
+%if %{with rt} && %{with multilib}
 %ifarch %{x8664}
 %files -n clang-multilib
 %defattr(644,root,root,755)
This page took 0.032749 seconds and 4 git commands to generate.