]> git.pld-linux.org Git - packages/llvm.git/commitdiff
- fix building with g++ 7
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 19 Feb 2018 14:50:10 +0000 (15:50 +0100)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 19 Feb 2018 14:50:10 +0000 (15:50 +0100)
gcc7.patch [new file with mode: 0644]
llvm.spec

diff --git a/gcc7.patch b/gcc7.patch
new file mode 100644 (file)
index 0000000..f300225
--- /dev/null
@@ -0,0 +1,10 @@
+--- llvm-3.9.1.src/tools/lldb/include/lldb/Utility/TaskPool.h~ 2015-11-03 23:29:20.000000000 +0100
++++ llvm-3.9.1.src/tools/lldb/include/lldb/Utility/TaskPool.h  2018-02-19 15:48:34.116275467 +0100
+@@ -33,6 +33,7 @@
+ #include <queue>
+ #include <thread>
+ #include <vector>
++#include <functional>
+ // Global TaskPool class for running tasks in parallel on a set of worker thread created the first
+ // time the task pool is used. The TaskPool provide no gurantee about the order the task will be run
index 2e5359a25be636a7126b945f784e41031f0ebd02..a6ca9a3bf21c7fbd1e820d755fc558a9aad172de 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -50,6 +50,7 @@ Patch3:               x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
 Patch6:                D35246.diff
+Patch7:                gcc7.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
@@ -508,6 +509,7 @@ Dokumentacja HTML wiązania OCamla do LLVM-a.
 %patch4 -p1
 %patch5 -p1
 %patch6 -p0
+%patch7 -p1
 
 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
This page took 0.436757 seconds and 4 git commands to generate.