]> git.pld-linux.org Git - packages/llvm.git/commitdiff
keep asserts disabled with lowmem
authorJan Palus <atler@pld-linux.org>
Tue, 21 Mar 2023 13:22:39 +0000 (14:22 +0100)
committerJan Palus <atler@pld-linux.org>
Tue, 21 Mar 2023 13:22:39 +0000 (14:22 +0100)
llvm.spec

index f6c315a4991214a8827afbdc1d7117bd9354633f..8a92c6a0c1bca53d40f6f56d0b0472a6b90b1a56 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -742,8 +742,8 @@ cd build
 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
 
 %if %{with lowmem}
-export CFLAGS="%{rpmcflags} -g0"
-export CXXFLAGS="%{rpmcxxflags} -g0"
+export CFLAGS="%{rpmcflags} -NDEBUG -g0"
+export CXXFLAGS="%{rpmcxxflags} -NDEBUG -g0"
 if echo 'int main(){}' | %{__cc} -x c %{rpmldflags} -Wl,--reduce-memory-overheads -o /dev/null - > /dev/null 2>&1; then
 export LDFLAGS="%{rpmldflags} -Wl,--reduce-memory-overheads"
 fi
This page took 0.166295 seconds and 4 git commands to generate.