]> git.pld-linux.org Git - packages/llvm.git/commitdiff
Version: 3.9.0
authorJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 3 Nov 2016 11:29:10 +0000 (12:29 +0100)
committerJacek Konieczny <j.konieczny@eggsoft.pl>
Thu, 3 Nov 2016 11:29:10 +0000 (12:29 +0100)
libdir-polly.patch [deleted file]
llvm-lld-link.patch
llvm-pld.patch
llvm.spec

diff --git a/libdir-polly.patch b/libdir-polly.patch
deleted file mode 100644 (file)
index 56be78e..0000000
+++ /dev/null
@@ -1,12 +0,0 @@
---- llvm-3.7.0.src/tools/polly/cmake/polly_macros.cmake~       2015-06-29 21:57:59.000000000 +0200
-+++ llvm-3.7.0.src/tools/polly/cmake/polly_macros.cmake        2015-09-09 21:36:43.080128117 +0200
-@@ -46,7 +46,7 @@
-   endif(MSVC)
-   install(TARGETS ${name}
-     EXPORT LLVMExports
--    LIBRARY DESTINATION lib
-+    LIBRARY DESTINATION lib${LLVM_LIBDIR_SUFFIX}
-     ARCHIVE DESTINATION lib${LLVM_LIBDIR_SUFFIX})
-   set_property(GLOBAL APPEND PROPERTY LLVM_EXPORTS ${name})
- endmacro(add_polly_library)
-
index 71f62c0e2bdbcab8ba5cedec8c892e04137f731c..7449a54e85c15f1da0dd26846351c80104888148 100644 (file)
@@ -1,15 +1,30 @@
---- llvm-3.7.0.src/tools/lld/lib/Core/CMakeLists.txt.orig      2015-01-21 23:54:56.000000000 +0100
-+++ llvm-3.7.0.src/tools/lld/lib/Core/CMakeLists.txt   2015-10-01 20:22:26.497622590 +0200
-@@ -8,5 +8,5 @@ add_llvm_library(lldCore
-   SymbolTable.cpp
+diff -dur -x '*~' -x '*.orig' -x '*.rej' llvm-3.9.0.src.orig/tools/lld/COFF/CMakeLists.txt llvm-3.9.0.src/tools/lld/COFF/CMakeLists.txt
+--- llvm-3.9.0.src.orig/tools/lld/COFF/CMakeLists.txt  2016-07-13 05:19:27.000000000 +0200
++++ llvm-3.9.0.src/tools/lld/COFF/CMakeLists.txt       2016-11-03 12:20:24.000000000 +0100
+@@ -18,6 +18,9 @@
+   Symbols.cpp
    Writer.cpp
++  LINK_LIBS
++    pthread
++
+   LINK_COMPONENTS
+   ${LLVM_TARGETS_TO_BUILD}
+   Core
+diff -dur -x '*~' -x '*.orig' -x '*.rej' llvm-3.9.0.src.orig/tools/lld/lib/Core/CMakeLists.txt llvm-3.9.0.src/tools/lld/lib/Core/CMakeLists.txt
+--- llvm-3.9.0.src.orig/tools/lld/lib/Core/CMakeLists.txt      2016-01-07 01:14:09.000000000 +0100
++++ llvm-3.9.0.src/tools/lld/lib/Core/CMakeLists.txt   2016-11-03 12:20:10.000000000 +0100
+@@ -12,5 +12,5 @@
+   ${LLD_INCLUDE_DIR}/lld/Core
    LINK_LIBS
 -    LLVMSupport
 +    LLVMSupport pthread
    )
---- llvm-3.7.0.src/tools/lld/lib/Driver/CMakeLists.txt.orig    2015-06-23 21:54:57.000000000 +0200
-+++ llvm-3.7.0.src/tools/lld/lib/Driver/CMakeLists.txt 2015-10-01 20:22:45.881962494 +0200
-@@ -37,6 +37,7 @@ add_llvm_library(lldDriver
+diff -dur -x '*~' -x '*.orig' -x '*.rej' llvm-3.9.0.src.orig/tools/lld/lib/Driver/CMakeLists.txt llvm-3.9.0.src/tools/lld/lib/Driver/CMakeLists.txt
+--- llvm-3.9.0.src.orig/tools/lld/lib/Driver/CMakeLists.txt    2016-03-02 20:08:05.000000000 +0100
++++ llvm-3.9.0.src/tools/lld/lib/Driver/CMakeLists.txt 2016-11-03 12:20:10.000000000 +0100
+@@ -17,6 +17,7 @@
      LLVMObject
      LLVMOption
      LLVMSupport
    )
  
  add_dependencies(lldDriver DriverOptionsTableGen)
---- llvm-3.7.0.src/tools/lld/lib/ReaderWriter/CMakeLists.txt.orig      2015-04-10 23:23:51.000000000 +0200
-+++ llvm-3.7.0.src/tools/lld/lib/ReaderWriter/CMakeLists.txt   2015-10-01 20:22:59.195987185 +0200
-@@ -16,4 +16,5 @@ add_llvm_library(lldReaderWriter
-     lldYAML
-     LLVMObject
-     LLVMSupport
-+    pthread
-   )
---- llvm-3.7.0.src/tools/lld/lib/ReaderWriter/MachO/CMakeLists.txt.orig        2015-06-23 22:35:31.000000000 +0200
-+++ llvm-3.7.0.src/tools/lld/lib/ReaderWriter/MachO/CMakeLists.txt     2015-10-01 21:51:16.757434595 +0200
-@@ -22,6 +22,7 @@
-     lldYAML
-     LLVMObject
-     LLVMSupport
-+    pthread
-   )
- include_directories(.)
---- llvm-3.7.0.src/tools/lld/lib/ReaderWriter/ELF/CMakeLists.txt.orig  2015-05-22 18:01:12.000000000 +0200
-+++ llvm-3.7.0.src/tools/lld/lib/ReaderWriter/ELF/CMakeLists.txt       2015-10-02 15:51:47.415199842 +0200
-@@ -17,6 +17,7 @@
+diff -dur -x '*~' -x '*.orig' -x '*.rej' llvm-3.9.0.src.orig/tools/lld/lib/ReaderWriter/CMakeLists.txt llvm-3.9.0.src/tools/lld/lib/ReaderWriter/CMakeLists.txt
+--- llvm-3.9.0.src.orig/tools/lld/lib/ReaderWriter/CMakeLists.txt      2016-03-02 01:37:50.000000000 +0100
++++ llvm-3.9.0.src/tools/lld/lib/ReaderWriter/CMakeLists.txt   2016-11-03 12:20:10.000000000 +0100
+@@ -16,4 +16,5 @@
      lldYAML
      LLVMObject
      LLVMSupport
 +    pthread
    )
- include_directories(.)
---- llvm-3.8.0.src/tools/lld/COFF/CMakeLists.txt~      2016-10-01 20:57:37.000000000 +0300
-+++ llvm-3.8.0.src/tools/lld/COFF/CMakeLists.txt       2016-10-01 20:57:44.393387882 +0300
-@@ -17,6 +17,9 @@
-   Symbols.cpp
-   Writer.cpp
-+  LINK_LIBS
-+    pthread
-+
-   LINK_COMPONENTS
-   ${LLVM_TARGETS_TO_BUILD}
-   Core
index 17406c10b0a20f01fd2bdf55de4fdf206a1bd6e3..758b70993abefd2fd95c082c46f4d9f13ad0e1a6 100644 (file)
@@ -1,6 +1,7 @@
---- llvm-3.5.0.src/tools/clang/lib/Driver/ToolChains.cpp.orig  2014-10-01 21:07:02.242822402 +0200
-+++ llvm-3.5.0.src/tools/clang/lib/Driver/ToolChains.cpp       2014-10-01 21:29:07.449433463 +0200
-@@ -1333,6 +1333,7 @@
+diff -dur -x '*~' -x '*.orig' -x '*.rej' llvm-3.9.0.src.orig/tools/clang/lib/Driver/ToolChains.cpp llvm-3.9.0.src/tools/clang/lib/Driver/ToolChains.cpp
+--- llvm-3.9.0.src.orig/tools/clang/lib/Driver/ToolChains.cpp  2016-08-18 19:56:48.000000000 +0200
++++ llvm-3.9.0.src/tools/clang/lib/Driver/ToolChains.cpp       2016-11-03 12:18:35.000000000 +0100
+@@ -1498,6 +1498,7 @@
  
    static const char *const X86_64LibDirs[] = {"/lib64", "/lib"};
    static const char *const X86_64Triples[] = {
@@ -8,7 +9,7 @@
        "x86_64-linux-gnu",       "x86_64-unknown-linux-gnu",
        "x86_64-pc-linux-gnu",    "x86_64-redhat-linux6E",
        "x86_64-redhat-linux",    "x86_64-suse-linux",
-@@ -1341,6 +1342,7 @@
+@@ -1507,6 +1508,7 @@
    static const char *const X32LibDirs[] = {"/libx32"};
    static const char *const X86LibDirs[] = {"/lib32", "/lib"};
    static const char *const X86Triples[] = {
@@ -16,7 +17,7 @@
        "i686-linux-gnu",       "i686-pc-linux-gnu",     "i486-linux-gnu",
        "i386-linux-gnu",       "i386-redhat-linux6E",   "i686-redhat-linux",
        "i586-redhat-linux",    "i386-redhat-linux",     "i586-suse-linux",
-@@ -1370,6 +1372,7 @@
+@@ -1532,6 +1534,7 @@
  
    static const char *const PPCLibDirs[] = {"/lib32", "/lib"};
    static const char *const PPCTriples[] = {
@@ -24,8 +25,8 @@
        "powerpc-linux-gnu", "powerpc-unknown-linux-gnu", "powerpc-linux-gnuspe",
        "powerpc-suse-linux", "powerpc-montavista-linuxspe"};
    static const char *const PPC64LibDirs[] = {"/lib64", "/lib"};
-@@ -1385,14 +1388,14 @@
-                                                 "ppc64le-redhat-linux" };
+@@ -1544,14 +1547,14 @@
+       "powerpc64le-suse-linux", "ppc64le-redhat-linux"};
  
    static const char *const SPARCv8LibDirs[] = {"/lib32", "/lib"};
 -  static const char *const SPARCv8Triples[] = {"sparc-linux-gnu",
 -  static const char *const SystemZTriples[] = {
 +  static const char *const SystemZTriples[] = {"s390x-pld-linux",
        "s390x-linux-gnu", "s390x-unknown-linux-gnu", "s390x-ibm-linux-gnu",
-       "s390x-suse-linux", "s390x-redhat-linux"
-   };
-@@ -2778,6 +2781,7 @@
+       "s390x-suse-linux", "s390x-redhat-linux"};
  
- enum Distro {
+@@ -3716,6 +3719,7 @@
+   // in this enum, because some tests are done by integer comparison against
+   // the first and last known member in the family, e.g. IsRedHat().
    ArchLinux,
 +  PLDLinux,
    DebianLenny,
    DebianSqueeze,
    DebianWheezy,
-@@ -2820,6 +2824,10 @@
+@@ -3761,6 +3765,10 @@
    return Distro >= UbuntuHardy && Distro <= UbuntuXenial;
  }
  
@@ -61,8 +62,8 @@
  static Distro DetectDistro(const Driver &D, llvm::Triple::ArchType Arch) {
    llvm::ErrorOr<std::unique_ptr<llvm::MemoryBuffer>> File =
        llvm::MemoryBuffer::getFile("/etc/lsb-release");
-@@ -2888,6 +2896,9 @@
-   if (llvm::sys::fs::exists("/etc/arch-release"))
+@@ -3837,6 +3845,9 @@
+   if (D.getVFS().exists("/etc/arch-release"))
      return ArchLinux;
  
 +  if (!llvm::sys::fs::exists("/etc/pld-release"))
    return UnknownDistro;
  }
  
-@@ -3029,7 +3040,7 @@
+@@ -4012,7 +4023,7 @@
  
-   Distro Distro = DetectDistro(Arch);
+   Distro Distro = DetectDistro(D, Arch);
  
 -  if (IsOpenSUSE(Distro) || IsUbuntu(Distro)) {
 +  if (IsOpenSUSE(Distro) || IsUbuntu(Distro) || IsPLD(Distro)) {
      ExtraOpts.push_back("-z");
      ExtraOpts.push_back("relro");
    }
-@@ -3049,7 +3060,7 @@
+@@ -4032,7 +4043,7 @@
    // ABI requires a mapping between the GOT and the symbol table.
    // Android loader does not support .gnu.hash.
    if (!IsMips && !IsAndroid) {
          (IsUbuntu(Distro) && Distro >= UbuntuMaverick))
        ExtraOpts.push_back("--hash-style=gnu");
  
-@@ -3058,10 +3069,10 @@
+@@ -4041,7 +4052,7 @@
        ExtraOpts.push_back("--hash-style=both");
    }
  
--  if (IsRedhat(Distro))
-+  if (IsRedhat(Distro) || IsPLD(Distro))
+-  if (IsRedhat(Distro) && Distro != RHEL5 && Distro != RHEL6)
++  if ((IsRedhat(Distro) && Distro != RHEL5 && Distro != RHEL6) || IsPLD(Distro))
      ExtraOpts.push_back("--no-add-needed");
  
--  if ((IsDebian(Distro) && Distro >= DebianSqueeze) || IsOpenSUSE(Distro) ||
-+  if ((IsDebian(Distro) && Distro >= DebianSqueeze) || IsOpenSUSE(Distro) || IsPLD(Distro) ||
-       (IsRedhat(Distro) && Distro != RHEL4 && Distro != RHEL5) ||
-       (IsUbuntu(Distro) && Distro >= UbuntuKarmic))
-     ExtraOpts.push_back("--build-id");
+ #ifdef ENABLE_LINKER_BUILD_ID
index 773d90d2b4f72afa48ef58f2fdb00bff2715a3f7..d60d2fb95fad16d6dc75b9ca3049e762a7c49a57 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
 Summary:       The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
 Summary(pl.UTF-8):     Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
 Name:          llvm
-Version:       3.8.1
+Version:       3.9.0
 Release:       0.1
 License:       University of Illinois/NCSA Open Source License
 Group:         Development/Languages
 #Source0Download: http://llvm.org/releases/download.html
 Source0:       http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
-# Source0-md5: 538467e6028bbc9259b1e6e015d25845
+# Source0-md5: f2093e98060532449eb7d2fcfd0bc6c6
 Source1:       http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
-# Source1-md5: 4ff2f8844a786edb0220f490f7896080
+# Source1-md5: 29e1d86bee422ab5345f5e9fb808d2dc
 Source2:       http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
-# Source2-md5: f140db073d2453f854fbe01cc46f3110
+# Source2-md5: b7ea34c9d744da16ffc0217b6990d095
 Source3:       http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
-# Source3-md5: 9e4787b71be8e432fffd31e13ac87623
+# Source3-md5: 968d053c3c3d7297983589164c6999e9
 Source4:       http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
-# Source4-md5: 8a40e697a4ba1c8b640b85d074bd6e25
+# Source4-md5: 1cf328cbae25267749b68cfa6f113674
 Source5:       http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
-# Source5-md5: 6e49f285d0b366cc3cab782d8c92d382
+# Source5-md5: f4f663068c77fc742113211841e94d5e
 Source6:       http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
-# Source6-md5: 68cd069bf99c71ebcfbe01d557c0e14d
+# Source6-md5: c23c895c0d855a0dc426af686538a95e
 Patch0:                %{name}-lld-link.patch
 Patch1:                %{name}-pld.patch
 Patch2:                libdir.patch
 Patch3:                x32-gcc-toolchain.patch
 Patch4:                cmake-buildtype.patch
 Patch5:                %{name}-ocaml-shared.patch
-Patch6:                libdir-polly.patch
 URL:           http://llvm.org/
 BuildRequires: bash
 BuildRequires: bison
-BuildRequires: cmake >= 2.8.12.2
+BuildRequires: cmake >= 3.4.3
 BuildRequires: flex
 BuildRequires: gcc >= 5:3.4
 # gcc4 might be installed, but not current __cc
@@ -504,9 +503,6 @@ Dokumentacja HTML wiązania OCamla do LLVM-a.
 %patch3 -p1
 %patch4 -p1
 %patch5 -p1
-%if %{with polly}
-%patch6 -p1
-%endif
 
 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
        s,^#!.*bin/env python,#!%{__python},
@@ -542,6 +538,7 @@ CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64"
        -DLLVM_BUILD_LLVM_DYLIB:BOOL=ON \
        -DLLVM_LINK_LLVM_DYLIB:BOOL=ON \
        -DBUILD_SHARED_LIBS:BOOL=OFF \
+       -DENABLE_LINKER_BUILD_ID:BOOL=ON \
        ../
 
 %{__make} \
This page took 0.042778 seconds and 4 git commands to generate.