]> git.pld-linux.org Git - packages/llvm.git/commitdiff
force enable LLVM_ENABLE_PER_TARGET_RUNTIME_DIR on %{arm}
authorJan Palus <atler@pld-linux.org>
Wed, 22 Mar 2023 08:47:12 +0000 (09:47 +0100)
committerJan Palus <atler@pld-linux.org>
Wed, 22 Mar 2023 08:47:12 +0000 (09:47 +0100)
now that CMAKE_SYSTEM_PROCESSOR is defined correctly:

https://github.com/llvm/llvm-project/commit/716e27bc9ad4699bbc82318834e938bcc9682cf8

started to apply. keep the setting enabled since it will be enabled by
default in llvm 17:

https://github.com/llvm/llvm-project/commit/cd173cbd7cca69c29df42cd4b42e60433435c29b

llvm.spec

index f42e5f8337b1d2553736b5fc98441bda23ca76c6..008d03fc5c85e229a4104ab8ebedb8b389902083 100644 (file)
--- a/llvm.spec
+++ b/llvm.spec
@@ -755,6 +755,9 @@ fi
        -DLLVM_ENABLE_ASSERTIONS:BOOL=OFF \
        -DLLVM_INSTALL_PACKAGE_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_libdir}/cmake/llvm") \
        -DLLVM_TOOLS_INSTALL_DIR=%(realpath -m "--relative-to=%{_prefix}" "%{_bindir}") \
+%ifarch %{arm}
+       -DLLVM_ENABLE_PER_TARGET_RUNTIME_DIR:BOOL=ON \
+%endif
 %if %{with apidocs}
        -DLLVM_ENABLE_DOXYGEN:BOOL=ON \
 %endif
This page took 0.111305 seconds and 4 git commands to generate.