]> git.pld-linux.org Git - packages/llvm.git/blob - llvm.spec
- updated to 3.6.0
[packages/llvm.git] / llvm.spec
1 #
2 # Conditional build:
3 %bcond_without  lldb    # LLDB debugger
4 %bcond_without  polly   # Polly cache-locality optimization, auto-parallelism and vectorization
5 %bcond_without  rt      # compiler-rt libraries
6 %bcond_without  ocaml   # OCaml binding
7 %bcond_without  doc     # HTML docs and man pages
8 %bcond_with     apidocs # doxygen docs (HUGE, so they are not built by default)
9 %bcond_with     tests   # run tests
10
11 %ifarch s390 s390x sparc64
12 # No ocaml on these arches
13 %undefine       with_ocaml
14 %endif
15
16 Summary:        The Low Level Virtual Machine (An Optimizing Compiler Infrastructure)
17 Summary(pl.UTF-8):      Niskopoziomowa maszyna wirtualna (infrastruktura kompilatora optymalizującego)
18 Name:           llvm
19 Version:        3.6.0
20 Release:        0.1
21 License:        University of Illinois/NCSA Open Source License
22 Group:          Development/Languages
23 #Source0Download: http://llvm.org/releases/download.html
24 Source0:        http://llvm.org/releases/%{version}/%{name}-%{version}.src.tar.xz
25 # Source0-md5:  f1e14e949f8df3047c59816c55278cec
26 Source1:        http://llvm.org/releases/%{version}/cfe-%{version}.src.tar.xz
27 # Source1-md5:  e3012065543dc6ab8a9842b09616b78d
28 Source2:        http://llvm.org/releases/%{version}/compiler-rt-%{version}.src.tar.xz
29 # Source2-md5:  cc36dbcafe43406083e98bc9e74f8054
30 Source3:        http://llvm.org/releases/%{version}/lldb-%{version}.src.tar.xz
31 # Source3-md5:  a1ea02b3126152f3dd9aeee8ebb5afa5
32 Source4:        http://llvm.org/releases/%{version}/polly-%{version}.src.tar.xz
33 # Source4-md5:  73d3d3b024da1e542ed5ecd8c936bd08
34 Source5:        http://llvm.org/releases/%{version}/clang-tools-extra-%{version}.src.tar.xz
35 # Source5-md5:  85a170713a0b15a728b0cfd7b63c546c
36 Source6:        http://llvm.org/releases/%{version}/lld-%{version}.src.tar.xz
37 # Source6-md5:  482dc6f72f6e9ff80bc520987c5b4f7e
38 # Data files should be installed with timestamps preserved
39 Patch1:         %{name}-2.6-timestamp.patch
40 Patch2:         %{name}-pld.patch
41 Patch4:         %{name}-lldb.patch
42 Patch5:         %{name}-lldb-atomic.patch
43 Patch6:         %{name}-lld-link.patch
44 URL:            http://llvm.org/
45 BuildRequires:  autoconf >= 2.60
46 BuildRequires:  automake >= 1:1.9.6
47 BuildRequires:  bash
48 BuildRequires:  bison
49 BuildRequires:  flex
50 BuildRequires:  gcc >= 5:3.4
51 # gcc4 might be installed, but not current __cc
52 %if "%(echo %{cc_version} | cut -d. -f1,2)" < "3.4"
53 BuildRequires:  __cc >= 3.4
54 %endif
55 %ifarch x32
56 BuildRequires:  glibc-devel(x86_64)
57 %endif
58 BuildRequires:  groff
59 BuildRequires:  libltdl-devel
60 BuildRequires:  libtool >= 2:1.5.22
61 BuildRequires:  libstdc++-devel >= 5:3.4
62 %if %{with ocaml}
63 BuildRequires:  ocaml-ocamldoc
64 BuildRequires:  ocaml-findlib
65 BuildRequires:  ocaml-ounit
66 %endif
67 BuildRequires:  perl-base >= 1:5.6
68 BuildRequires:  perl-tools-pod
69 BuildRequires:  rpm-pythonprov
70 %{?with_doc:BuildRequires:      sphinx-pdg}
71 BuildRequires:  tar >= 1:1.22
72 BuildRequires:  xz
73 %if %{with apidocs}
74 BuildRequires:  doxygen
75 BuildRequires:  graphviz
76 %endif
77 %if %{with tests}
78 BuildRequires:  dejagnu
79 BuildRequires:  python
80 BuildRequires:  tcl-devel
81 %endif
82 %if %{with lldb}
83 %ifarch i386 i486
84 BuildRequires:  libatomic-devel
85 %endif
86 BuildRequires:  libedit-devel
87 BuildRequires:  libxml2-devel >= 2
88 BuildRequires:  ncurses-ext-devel
89 BuildRequires:  python-devel >= 2
90 %endif
91 %if %{with polly}
92 BuildRequires:  cloog-isl-devel
93 # >= 0.18.2-2
94 BuildRequires:  gmp-devel
95 BuildRequires:  isl-devel >= 0.14
96 # optional
97 BuildRequires:  pluto-devel
98 BuildRequires:  scoplib-devel >= 0.2.1-2
99 #cuda-devel
100 %endif
101 Requires:       %{name}-libs = %{version}-%{release}
102 # LLVM is not supported on PPC64
103 # http://llvm.org/bugs/show_bug.cgi?id=3729
104 ExcludeArch:    ppc64
105 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
106
107 %define         _sysconfdir     /etc/%{name}
108
109 %define         specflags_ppc   -fno-var-tracking-assignments
110
111 # strip corrupts: $RPM_BUILD_ROOT/usr/lib64/llvm-gcc/bin/llvm-c++ ...
112 %define         _noautostrip    .*/\\(libmud.*\\.a\\|bin/llvm-.*\\|lib.*++\\.a\\)
113
114 %description
115 LLVM is a compiler infrastructure designed for compile-time,
116 link-time, runtime, and idle-time optimization of programs from
117 arbitrary programming languages. LLVM is written in C++ and has been
118 developed since 2000 at the University of Illinois and Apple. It
119 currently supports compilation of C and C++ programs using clang
120 frontend.
121
122 %description -l pl.UTF-8
123 LLVM to infrastruktura kompilatora zaprojektowana do optymalizacji
124 czasu kompilowania, linkowania, działania i bezczynności programów w
125 dowolnych językach programowania. Jest napisana w C++, rozwijana od
126 roku 2000 przez Uniwersytet w Illinois i Apple. Aktualnie obsługuje
127 kompilację programów w C i C++ przy użyciu frontendu clang.
128
129 %package libs
130 Summary:        LLVM shared library
131 Summary(pl.UTF-8):      Biblioteka współdzielona LLVM-a
132 Group:          Libraries
133 Conflicts:      llvm < 3.2
134
135 %description libs
136 LLVM shared library.
137
138 %description libs -l pl.UTF-8
139 Biblioteka współdzielona LLVM-a.
140
141 %package devel
142 Summary:        Static libraries and header files for LLVM
143 Summary(pl.UTF-8):      Biblioteki statyczne i pliki nagłówkowe dla LLVM-a
144 Group:          Development/Languages
145 Requires:       %{name}-libs = %{version}-%{release}
146 Requires:       libstdc++-devel >= 6:3.4
147
148 %description devel
149 This package contains static libraries and header files needed to
150 develop new native programs that use the LLVM infrastructure.
151
152 %description devel -l pl.UTF-8
153 Ten pakiet zawiera biblioteki statyczne oraz pliki nagłówkowe
154 potrzebne do tworzenia nowych programów natywnych wykorzystujących
155 infrastrukturę LLVM.
156
157 %package doc
158 Summary:        Documentation for LLVM
159 Summary(pl.UTF-8):      Dokumentacja do LLVM-a
160 Group:          Documentation
161 # does not require base
162
163 %description doc
164 Documentation for the LLVM compiler infrastructure.
165
166 %description doc -l pl.UTF-8
167 Dokumentacja do infrastruktury kompilatorów LLVM.
168
169 %package apidocs
170 Summary:        API documentation for LLVM
171 Summary(pl.UTF-8):      Dokumentacja API LLVM-a
172 Group:          Development/Languages
173 Requires:       %{name}-doc = %{version}-%{release}
174
175 %description apidocs
176 API documentation for the LLVM compiler infrastructure.
177
178 %description apidocs -l pl.UTF-8
179 Dokumentacja API infrastruktury kompilatorów LLVM.
180
181 %package polly
182 Summary:        Polyhedral optimizations for LLVM
183 Summary(pl.UTF-8):      Optymalizacje wielościanowe dla LLVM-a
184 Group:          Development/Tools
185 URL:            http://polly.llvm.org/
186 Requires:       %{name} = %{version}-%{release}
187
188 %description polly
189 Polly is a high-level loop and data-locality optimizer and
190 optimization infrastructure for LLVM. It uses an abstract mathematical
191 representation based on integer polyhedra to analyze and optimize the
192 memory access pattern of a program.
193
194 %description polly -l pl.UTF-8
195 Polly to wysokopoziomowy optymalizator i infrastruktura LLVM-a do
196 optymalizacji pętli i położenia danych. Wykorzystuje abstrakcyjną
197 reprezentację matematyczną opartą na wielościanach całkowitoliczbowych
198 do analizy i optymalizacji wzorców dostępu do pamięci przez program.
199
200 %package polly-devel
201 Summary:        Header files for LLVM Polly optimization infrastructure
202 Summary(pl.UTF-8):      Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly
203 Group:          Development/Libraries
204 URL:            http://polly.llvm.org/
205 Requires:       %{name}-devel = %{version}-%{release}
206 Requires:       %{name}-polly = %{version}-%{release}
207
208 %description polly-devel
209 Header files for LLVM Polly optimization infrastructure.
210
211 %description polly-devel -l pl.UTF-8
212 Pliki nagłówkowe infrastruktury optymalizacji LLVM-a Polly.
213
214 %package -n clang
215 Summary:        A C language family frontend for LLVM
216 Summary(pl.UTF-8):      Frontend LLVM-a do języków z rodziny C
217 License:        NCSA
218 Group:          Development/Languages
219 Requires:       %{name} = %{version}-%{release}
220
221 %description -n clang
222 clang: noun 1. A loud, resonant, metallic sound. 2. The strident call
223 of a crane or goose. 3. C-language family front-end toolkit.
224
225 The goal of the Clang project is to create a new C, C++, Objective C
226 and Objective C++ front-end for the LLVM compiler. Its tools are built
227 as libraries and designed to be loosely-coupled and extendable.
228
229 %description -n clang -l pl.UTF-8
230 clang (z angielskiego): 1. głośny, rezonujący, metaliczny dźwięk; 2.
231 piskliwy odgłos żurawia lub gęsi; 3. narzędzia frontendowe dla języków
232 z rodziny C.
233
234 Celem projektu Clang jest utworzenie nowego frontendu dla kompilatora
235 LLVM do języków C, C++, Objective C i Objective C++. Narzędzia są
236 budowane jako biblioteki i zaprojektowane z myślą o swobodnym łączeniu
237 i rozszerzaniu.
238
239 %package -n clang-analyzer
240 Summary:        A source code analysis framework
241 Summary(pl.UTF-8):      Szkielet do analizy kodu źródłowego
242 License:        NCSA
243 Group:          Development/Languages
244 Requires:       clang = %{version}-%{release}
245 # not picked up automatically since files are currently not instaled
246 # in standard Python hierarchies yet
247 Requires:       python
248
249 %description -n clang-analyzer
250 The Clang Static Analyzer consists of both a source code analysis
251 framework and a standalone tool that finds bugs in C and Objective-C
252 programs. The standalone tool is invoked from the command-line, and is
253 intended to run in tandem with a build of a project or code base.
254
255 %description -n clang-analyzer -l pl.UTF-8
256 Clang Static Analyzer składa się ze szkieletu do analizy kodu
257 źródłowego oraz samodzielnego narzędzia znajdującego błędy w
258 programach w C i C++. Narzędzie jest wywoływane z linii poleceń, z
259 myślą o uruchamianiu wraz z kompilacją projektu lub kodu.
260
261 %package -n clang-devel
262 Summary:        Header files for Clang
263 Summary(pl.UTF-8):      Pliki nagłówkowe Clanga
264 Group:          Development/Languages
265 Requires:       %{name}-devel = %{version}-%{release}
266 Requires:       clang = %{version}-%{release}
267
268 %description -n clang-devel
269 This package contains header files for the Clang compiler.
270
271 %description -n clang-devel -l pl.UTF-8
272 Ten pakiet zawiera pliki nagłówkowe kompilatora Clang.
273
274 %package -n clang-doc
275 Summary:        Documentation for Clang
276 Summary(pl.UTF-8):      Dokumentacja do Clanga
277 Group:          Documentation
278 Requires:       %{name} = %{version}-%{release}
279
280 %description -n clang-doc
281 Documentation for the Clang compiler front-end.
282
283 %description -n clang-doc -l pl.UTF-8
284 Dokumentacja do frontendu kompilatora Clang.
285
286 %package -n clang-apidocs
287 Summary:        API documentation for Clang
288 Summary(pl.UTF-8):      Dokumentacja API Clanga
289 Group:          Development/Languages
290 Requires:       clang-doc = %{version}-%{release}
291
292 %description -n clang-apidocs
293 API documentation for the Clang compiler.
294
295 %description -n clang-apidocs -l pl.UTF-8
296 Dokumentacja API kompilatora Clang.
297
298 %package -n clang-tools-extra
299 Summary:        Extra tools for Clang
300 Summary(pl.UTF-8):      Dodatkowe narzędzia do kompilatora Clang
301 Group:          Development/Tools
302 URL:            http://clang.llvm.org/docs/ClangTools.html
303 Requires:       clang = %{version}-%{release}
304
305 %description -n clang-tools-extra
306 Extra tools for Clang.
307
308 %description -n clang-tools-extra -l pl.UTF-8
309 Dodatkowe narzędzia do kompilatora Clang.
310
311 %package -n lld
312 Summary:        The LLVM linker
313 Summary(pl.UTF-8):      Konsolidator z projektu LLVM
314 Group:          Development/Libraries
315 URL:            http://lld.llvm.org/
316 Requires:       %{name} = %{version}-%{release}
317
318 %description -n lld
319 lld is a new set of modular code for creating linker tools.
320
321 %description -n lld -l pl.UTF-8
322 lld to nowy zbiór modularnego kodu do tworzenia narzędzi
323 konsolidujących.
324
325 %package -n lld-devel
326 Summary:        Development files for LLD linker tools
327 Summary(pl.UTF-8):      Pliki programistyczne narzędzi konsolidujących LLD
328 Group:          Development/Tools
329 URL:            http://lld.llvm.org/
330 Requires:       %{name}-devel = %{version}-%{release}
331
332 %description -n lld-devel
333 Development files for LLD linker tools.
334
335 %description -n lld-devel -l pl.UTF-8
336 Pliki programistyczne narzędzi konsolidujących LLD.
337
338 %package -n lldb
339 Summary:        Next generation high-performance debugger
340 Summary(pl.UTF-8):      Wydajny debugger nowej generacji
341 Group:          Development/Debuggers
342 URL:            http://lldb.llvm.org/
343 Requires:       %{name} = %{version}-%{release}
344
345 %description -n lldb
346 LLDB is a next generation, high-performance debugger. It is built as a
347 set of reusable components which highly leverage existing libraries in
348 the larger LLVM Project, such as the Clang expression parser and LLVM
349 disassembler.
350
351 %description -n lldb -l pl.UTF-8
352 LLDB to wydajny debugger nowej generacji. Jest zbudowany w oparciu o
353 komponenty wielokrotnego użytku, wykorzystujące istniejące biblioteki
354 w projekcie LLVM, takie jak analizator wyrażeń kompilatora Clang oraz
355 disasembler LLVM.
356
357 %package -n lldb-devel
358 Summary:        Development files for LLDB debugger
359 Summary(pl.UTF-8):      Pliki programistyczne debuggera LLDB
360 Group:          Development/Libraries
361 URL:            http://lldb.llvm.org/
362 Requires:       %{name}-devel = %{version}-%{release}
363 Requires:       clang-devel = %{version}-%{release}
364 Requires:       lldb = %{version}-%{release}
365
366 %description -n lldb-devel
367 Development files for LLDB debugger.
368
369 %description -n lldb-devel -l pl.UTF-8
370 Pliki programistyczne debuggera LLDB.
371
372 %package ocaml
373 Summary:        OCaml binding for LLVM
374 Summary(pl.UTF-8):      Wiązanie OCamla do LLVM-a
375 Group:          Libraries
376 Requires:       %{name} = %{version}-%{release}
377 %requires_eq    ocaml-runtime
378
379 %description ocaml
380 OCaml binding for LLVM.
381
382 %description ocaml -l pl.UTF-8
383 Wiązanie OCamla do LLVM-a.
384
385 %package ocaml-devel
386 Summary:        Development files for LLVM OCaml binding
387 Summary(pl.UTF-8):      Pliki programistyczne wiązania OCamla do LLVM-a
388 Group:          Development/Libraries
389 Requires:       %{name}-devel = %{version}-%{release}
390 Requires:       %{name}-ocaml = %{version}-%{release}
391
392 %description ocaml-devel
393 The llvm-ocaml-devel package contains libraries and signature files
394 for developing applications that use llvm-ocaml binding.
395
396 %description ocaml-devel -l pl.UTF-8
397 Ten pakiet zawiera biblioteki i pliki sygnatur do tworzenia aplikacji
398 wykorzystujących wiązanie llvm-ocaml.
399
400 %package ocaml-doc
401 Summary:        Documentation for LLVM's OCaml binding
402 Summary(pl.UTF-8):      Dokumentacja wiązania OCamla do LLVM-a
403 Group:          Documentation
404 Requires:       %{name}-ocaml = %{version}-%{release}
405
406 %description ocaml-doc
407 HTML documentation for LLVM's OCaml binding.
408
409 %description ocaml-doc -l pl.UTF-8
410 Dokumentacja HTML wiązania OCamla do LLVM-a.
411
412 %prep
413 %setup -q -n %{name}-%{version}.src -a1 %{?with_rt:-a2} %{?with_lldb:-a3} %{?with_polly:-a4} -a5 -a6
414 mv cfe-%{version}.src tools/clang
415 %{?with_rt:mv compiler-rt-%{version}.src projects/compiler-rt}
416 %{?with_lldb:mv lldb-%{version}.src tools/lldb}
417 %{?with_polly:mv polly-%{version}.src tools/polly}
418 mv clang-tools-extra-%{version}.src tools/clang/tools/extra
419 mv lld-%{version}.src tools/lld
420
421 %patch1 -p1
422 %patch2 -p1
423 %if %{with lldb}
424 %patch4 -p1
425 %ifarch i386 i486
426 %patch5 -p1
427 %endif
428 %endif
429 %patch6 -p1
430
431 # configure does not properly specify libdir
432 %{__sed} -i 's|(PROJ_prefix)/lib|(PROJ_prefix)/%{_lib}|g' Makefile.config.in
433 # clang resources
434 %{__sed} -i 's|(PROJ_prefix)/lib/|(PROJ_prefix)/%{_lib}/|g' tools/clang/lib/Headers/Makefile
435 %{__sed} -i 's|"lib"|"%{_lib}"|' tools/clang/lib/Driver/Driver.cpp
436
437 grep -rl /usr/bin/env tools utils | xargs sed -i -e '1{
438         s,^#!.*bin/env python,#!%{__python},
439         s,^#!.*bin/env perl,#!%{__perl},
440 }'
441
442 %build
443 install -d obj
444 %if "%{_lib}" != "lib"
445 # workaround for clang relative search paths building
446 install -d obj/Release
447 ln -snf lib obj/Release/%{_lib}
448 %endif
449
450 cd autoconf
451 %{__aclocal} -I m4
452 %{__autoconf} -o ../configure configure.ac
453 cd ..
454 %{__autoheader} -I autoconf -I autoconf/m4 autoconf/configure.ac
455 %if %{with polly}
456 cd tools/polly/autoconf
457 %{__aclocal} -I m4 -I ../../../autoconf/m4
458 %{__autoconf} -o ../configure configure.ac
459 cd ..
460 %{__autoheader} -I autoconf -I autoconf/m4 -I ../../../autoconf/m4 autoconf/configure.ac
461 cd ../..
462 %endif
463
464 # Disabling assertions now, rec. by pure and needed for OpenGTL
465 # TESTFIX no PIC on ix86: http://llvm.org/bugs/show_bug.cgi?id=3801
466 #
467 # bash specific 'test a < b'
468 cd obj
469 CPPFLAGS="%{rpmcppflags} -D_FILE_OFFSET_BITS=64 \
470 %ifarch %{x8664}
471 -DLLVM_LIBDIR_SUFFIX=64"
472 %endif
473 %ifarch x32
474 -DLLVM_LIBDIR_SUFFIX=x32"
475 %endif
476
477 bash ../%configure \
478         --datadir=%{_datadir}/%{name}-%{version} \
479         --disable-assertions \
480         --enable-cxx11 \
481 %ifarch %{ix86}
482         --disable-pic \
483 %endif
484         --disable-static \
485         --enable-bindings=%{?with_ocaml:ocaml}%{!?with_ocaml:none} \
486         --enable-debug-runtime \
487 %if %{with apidocs}
488         --enable-doxygen \
489 %endif
490         --enable-experimental-targets=R600 \
491         --enable-jit \
492         --enable-optimized \
493         --enable-shared \
494         --with-pic
495
496 %{__make} \
497         VERBOSE=1 \
498         REQUIRES_RTTI=1 \
499         OPTIMIZE_OPTION="%{rpmcflags} %{rpmcppflags}"
500
501 %if %{with tests}
502 %{__make} check 2>&1 | tee llvm-testlog.txt
503 %{__make} -C tools/clang test 2>&1 | tee clang-testlog.txt
504 %endif
505
506 cd ..
507
508 %if %{with doc}
509 %{__make} -C docs -f Makefile.sphinx man
510 %{__make} -C tools/clang/tools/extra/docs html
511 %endif
512
513 %install
514 rm -rf $RPM_BUILD_ROOT
515 %{__make} -C obj -j1 install \
516         PROJ_docsdir=/moredocs \
517         DESTDIR=$RPM_BUILD_ROOT
518
519 # Static analyzer not installed by default:
520 # http://clang-analyzer.llvm.org/installation#OtherPlatforms
521 install -d $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
522 # create launchers
523 for f in scan-{build,view}; do
524         ln -s %{_libdir}/clang-analyzer/$f/$f $RPM_BUILD_ROOT%{_bindir}/$f
525         cp -pr tools/clang/tools/$f $RPM_BUILD_ROOT%{_libdir}/clang-analyzer
526 done
527 %{__mv} $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-build/scan-build.1 $RPM_BUILD_ROOT%{_mandir}/man1
528 %py_comp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
529 %py_ocomp $RPM_BUILD_ROOT%{_libdir}/clang-analyzer/scan-view
530 %py_postclean %{_libdir}/clang-analyzer/scan-view
531
532 %if %{with doc}
533 install -d $RPM_BUILD_ROOT%{_mandir}/man1
534 cp -p docs/_build/man/*.1 $RPM_BUILD_ROOT%{_mandir}/man1
535 # these tools are not installed
536 %{__rm} $RPM_BUILD_ROOT%{_mandir}/man1/{FileCheck,llvm-build}.1
537 # make links
538 echo '.so llvm-ar.1' > $RPM_BUILD_ROOT%{_mandir}/man1/llvm-ranlib.1
539 %endif
540
541 # Move documentation back to build directory
542 rm -rf moredocs
543 mv $RPM_BUILD_ROOT/moredocs .
544 %{__rm} -v moredocs/*.tar.gz
545 %if %{with ocaml}
546 %{__rm} -v moredocs/ocamldoc/html/*.tar.gz
547 %endif
548
549 # and separate the apidoc
550 %if %{with apidocs}
551 rm -rf apidoc clang-apidoc
552 mv moredocs/html/doxygen apidoc
553 cp -a tools/clang/docs/doxygen/html clang-apidoc
554 %endif
555
556 # And prepare Clang documentation
557 rm -rf clang-docs
558 install -d clang-docs
559 for f in LICENSE.TXT NOTES.txt README.txt; do
560         ln tools/clang/$f clang-docs
561 done
562
563 # Get rid of erroneously installed example files.
564 %{__rm} -v $RPM_BUILD_ROOT%{_libdir}/*LLVMHello.*
565 # parts of test suite
566 %{__rm} $RPM_BUILD_ROOT%{_bindir}/{FileCheck,count,not}
567 %{__rm} $RPM_BUILD_ROOT%{_bindir}/linker-script-test
568
569 # remove documentation makefiles:
570 # they require the build directory to work
571 rm -rf moredocs/examples
572 cp -a examples moredocs/examples
573 find moredocs/examples -name Makefile | xargs -0r rm -f
574
575 %clean
576 rm -rf $RPM_BUILD_ROOT
577
578 %post   libs -p /sbin/ldconfig
579 %postun libs -p /sbin/ldconfig
580
581 %post   -n clang -p /sbin/ldconfig
582 %postun -n clang -p /sbin/ldconfig
583
584 %post   -n lldb -p /sbin/ldconfig
585 %postun -n lldb -p /sbin/ldconfig
586
587 %files
588 %defattr(644,root,root,755)
589 %doc CREDITS.TXT LICENSE.TXT README.txt %{?with_tests:llvm-testlog.txt}
590 %attr(755,root,root) %{_bindir}/bugpoint
591 %attr(755,root,root) %{_bindir}/llc
592 %attr(755,root,root) %{_bindir}/lli
593 %attr(755,root,root) %{_bindir}/lli-child-target
594 %attr(755,root,root) %{_bindir}/llvm-ar
595 %attr(755,root,root) %{_bindir}/llvm-as
596 %attr(755,root,root) %{_bindir}/llvm-bcanalyzer
597 %attr(755,root,root) %{_bindir}/llvm-cov
598 %attr(755,root,root) %{_bindir}/llvm-diff
599 %attr(755,root,root) %{_bindir}/llvm-dis
600 %attr(755,root,root) %{_bindir}/llvm-dwarfdump
601 %attr(755,root,root) %{_bindir}/llvm-extract
602 %attr(755,root,root) %{_bindir}/llvm-link
603 %attr(755,root,root) %{_bindir}/llvm-mc
604 %attr(755,root,root) %{_bindir}/llvm-mcmarkup
605 %attr(755,root,root) %{_bindir}/llvm-nm
606 %attr(755,root,root) %{_bindir}/llvm-objdump
607 %attr(755,root,root) %{_bindir}/llvm-profdata
608 %attr(755,root,root) %{_bindir}/llvm-ranlib
609 %attr(755,root,root) %{_bindir}/llvm-readobj
610 %attr(755,root,root) %{_bindir}/llvm-rtdyld
611 %attr(755,root,root) %{_bindir}/llvm-size
612 %attr(755,root,root) %{_bindir}/llvm-stress
613 %attr(755,root,root) %{_bindir}/llvm-symbolizer
614 %attr(755,root,root) %{_bindir}/llvm-tblgen
615 %attr(755,root,root) %{_bindir}/macho-dump
616 %attr(755,root,root) %{_bindir}/opt
617 %if %{with doc}
618 %{_mandir}/man1/bugpoint.1*
619 %{_mandir}/man1/lit.1*
620 %{_mandir}/man1/llc.1*
621 %{_mandir}/man1/lli.1*
622 %{_mandir}/man1/llvm-ar.1*
623 %{_mandir}/man1/llvm-as.1*
624 %{_mandir}/man1/llvm-bcanalyzer.1*
625 %{_mandir}/man1/llvm-cov.1*
626 %{_mandir}/man1/llvm-diff.1*
627 %{_mandir}/man1/llvm-dis.1*
628 %{_mandir}/man1/llvm-dwarfdump.1*
629 %{_mandir}/man1/llvm-extract.1*
630 %{_mandir}/man1/llvm-link.1*
631 %{_mandir}/man1/llvm-nm.1*
632 %{_mandir}/man1/llvm-profdata.1*
633 %{_mandir}/man1/llvm-ranlib.1*
634 %{_mandir}/man1/llvm-readobj.1*
635 %{_mandir}/man1/llvm-stress.1*
636 %{_mandir}/man1/llvm-symbolizer.1*
637 %{_mandir}/man1/opt.1*
638 %{_mandir}/man1/tblgen.1*
639 %endif
640
641 %files libs
642 %defattr(644,root,root,755)
643 %attr(755,root,root) %{_libdir}/libLLVM-%{version}.so
644 %attr(755,root,root) %{_libdir}/libLLVM-3.5.so
645
646 %files devel
647 %defattr(644,root,root,755)
648 %attr(755,root,root) %{_bindir}/llvm-config
649 %{_libdir}/libLLVM*.a
650 %ifarch %{x8664}
651 %attr(755,root,root) %{_libdir}/BugpointPasses.so
652 %attr(755,root,root) %{_libdir}/libLTO.so
653 %{_libdir}/libLTO.a
654 %endif
655 %{_includedir}/llvm
656 %{_includedir}/llvm-c
657 %dir %{_datadir}/llvm
658 %{_datadir}/llvm/cmake
659 %if %{with doc}
660 %{_mandir}/man1/llvm-config.1*
661 %endif
662
663 %files doc
664 %defattr(644,root,root,755)
665 %doc moredocs/examples moredocs/html
666
667 %if %{with apidocs}
668 %files apidocs
669 %defattr(644,root,root,755)
670 %doc apidoc/*
671 %endif
672
673 %if %{with polly}
674 %files polly
675 %defattr(644,root,root,755)
676 %doc tools/polly/{CREDITS.txt,LICENSE.txt,README}
677 %attr(755,root,root) %{_libdir}/LLVMPolly.so
678
679 %files polly-devel
680 %defattr(644,root,root,755)
681 %{_includedir}/polly
682 %endif
683
684 %files -n clang
685 %defattr(644,root,root,755)
686 %doc clang-docs/{LICENSE.TXT,NOTES.txt,README.txt} %{?with_tests:clang-testlog.txt}
687 %attr(755,root,root) %{_bindir}/c-index-test
688 %attr(755,root,root) %{_bindir}/clang
689 %attr(755,root,root) %{_bindir}/clang++
690 %attr(755,root,root) %{_bindir}/clang-check
691 %attr(755,root,root) %{_bindir}/clang-format
692 %attr(755,root,root) %{_bindir}/clang-tblgen
693 %attr(755,root,root) %{_libdir}/libclang.so
694 %dir %{_libdir}/clang
695 %dir %{_libdir}/clang/%{version}
696 %{_libdir}/clang/%{version}/include
697 %if %{with rt}
698 %{_libdir}/clang/%{version}/lib
699 %endif
700 %{_mandir}/man1/clang.1*
701
702 %files -n clang-analyzer
703 %defattr(644,root,root,755)
704 %attr(755,root,root) %{_bindir}/scan-build
705 %attr(755,root,root) %{_bindir}/scan-view
706 %{_mandir}/man1/scan-build.1*
707 %dir %{_libdir}/clang-analyzer
708
709 %dir %{_libdir}/clang-analyzer/scan-build
710 %{_libdir}/clang-analyzer/scan-build/*.css
711 %{_libdir}/clang-analyzer/scan-build/*.js
712 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/scan-build
713 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-build/*-analyzer
714
715 %dir %{_libdir}/clang-analyzer/scan-view
716 %attr(755,root,root) %{_libdir}/clang-analyzer/scan-view/scan-view
717 %{_libdir}/clang-analyzer/scan-view/Resources
718 %{_libdir}/clang-analyzer/scan-view/*.py[co]
719
720 %files -n clang-devel
721 %defattr(644,root,root,755)
722 %{_libdir}/libclang*.a
723 %{_includedir}/clang
724 %{_includedir}/clang-c
725
726 %files -n clang-doc
727 %defattr(644,root,root,755)
728 %doc tools/clang/docs/*.{css,html,png,txt}
729
730 %if %{with apidocs}
731 %files -n clang-apidocs
732 %defattr(644,root,root,755)
733 %doc clang-apidoc/*
734 %endif
735
736 %files -n clang-tools-extra
737 %defattr(644,root,root,755)
738 %doc tools/clang/tools/extra/{CODE_OWNERS.TXT,README.txt,docs/_build/html/{*.html,*.js,_static}}
739 %attr(755,root,root) %{_bindir}/clang-apply-replacements
740 %attr(755,root,root) %{_bindir}/clang-modernize
741 %attr(755,root,root) %{_bindir}/clang-query
742 %attr(755,root,root) %{_bindir}/clang-tidy
743 %attr(755,root,root) %{_bindir}/pp-trace
744 %{_libdir}/libmodernizeCore.a
745
746 %files -n lld
747 %defattr(644,root,root,755)
748 %doc tools/lld/{LICENSE.TXT,README.md}
749 %attr(755,root,root) %{_bindir}/lld
750
751 %files -n lld-devel
752 %defattr(644,root,root,755)
753 %{_libdir}/liblldCore.a
754 %{_libdir}/liblldDriver.a
755 %{_libdir}/liblldELF.a
756 %{_libdir}/liblldMachO.a
757 %{_libdir}/liblldNative.a
758 %{_libdir}/liblldPECOFF.a
759 %{_libdir}/liblldPasses.a
760 %{_libdir}/liblldReaderWriter.a
761 %{_libdir}/liblldYAML.a
762 %{_libdir}/liblld*ELFTarget.a
763 %{_includedir}/lld
764
765 %if %{with lldb}
766 %files -n lldb
767 %defattr(644,root,root,755)
768 %attr(755,root,root) %{_bindir}/lldb
769 %attr(755,root,root) %{_bindir}/lldb-gdbserver
770 %attr(755,root,root) %{_bindir}/lldb-mi
771 %attr(755,root,root) %{_bindir}/lldb-platform
772 %attr(755,root,root) %{_libdir}/liblldb.so
773 %dir %{py_sitedir}/lldb
774 %attr(755,root,root) %{py_sitedir}/lldb/_lldb.so
775 %attr(755,root,root) %{py_sitedir}/readline.so
776
777 %files -n lldb-devel
778 %defattr(644,root,root,755)
779 %{_libdir}/liblldb*.a
780 %{_includedir}/lldb
781 %endif
782
783 %if %{with ocaml}
784 %files ocaml
785 %defattr(644,root,root,755)
786 %{_libdir}/ocaml/META.llvm*
787 %attr(755,root,root) %{_libdir}/ocaml/dllllvm*.so
788 %{_libdir}/ocaml/llvm*.cma
789 %{_libdir}/ocaml/llvm*.cmi
790
791 %files ocaml-devel
792 %defattr(644,root,root,755)
793 %{_libdir}/libllvm*.a
794 %{_libdir}/ocaml/libLLVM*.a
795 %{_libdir}/ocaml/libllvm*.a
796 %{_libdir}/ocaml/llvm*.a
797 %{_libdir}/ocaml/llvm*.cmx*
798 %{_libdir}/ocaml/llvm*.mli
799
800 %files ocaml-doc
801 %defattr(644,root,root,755)
802 %doc moredocs/ocamldoc/html/*
803 %endif
This page took 0.127338 seconds and 4 git commands to generate.