]> git.pld-linux.org Git - packages/litecoin.git/blob - litecoin.spec
- updated to 0.16.3
[packages/litecoin.git] / litecoin.spec
1 Summary:        Litecoin is a peer-to-peer currency
2 Summary(pl.UTF-8):      Litecoin - waluta peer-to-peer
3 Name:           litecoin
4 Version:        0.16.3
5 Release:        1
6 License:        MIT
7 Group:          X11/Applications
8 #Sourrce0Download: https://github.com/litecoin-project/litecoin/releases
9 Source0:        https://download.litecoin.org/litecoin-%{version}/src/%{name}-%{version}.tar.gz
10 # Source0-md5:  071bf10b2077d56645cb549bc184e81d
11 URL:            http://www.litecoin.org/
12 BuildRequires:  QtCore-devel >= 4
13 BuildRequires:  QtDBus-devel >= 4
14 BuildRequires:  QtGui-devel >= 4
15 BuildRequires:  automake >= 2.60
16 BuildRequires:  autoconf
17 BuildRequires:  boost-devel >= 1.49
18 BuildRequires:  db-cxx-devel >= 4.8
19 BuildRequires:  gettext-tools
20 BuildRequires:  libevent-devel
21 BuildRequires:  libstdc++-devel >= 6:4.7
22 BuildRequires:  libtool >= 2:2
23 BuildRequires:  libunivalue-devel
24 BuildRequires:  miniupnpc-devel >= 1.5
25 BuildRequires:  openssl-devel
26 BuildRequires:  pkgconfig
27 BuildRequires:  python3 >= 1:3.4
28 BuildRequires:  protobuf-devel
29 BuildRequires:  qrencode-devel
30 BuildRequires:  qt4-linguist >= 4
31 BuildRequires:  qt4-qmake >= 4
32 BuildRequires:  zeromq-devel >= 4
33 Requires:       perl-base
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 Litecoin is a peer-to-peer currency. Peer-to-peer means that no
38 central authority issues new money or tracks transactions. These tasks
39 are managed collectively by the network.
40
41 %description -l pl.UTF-8
42 Litecoin to waluta peer-to-peer. Oznacza to, że nie ma centralnej
43 instytucji emitującej nowe pieniądze czy śledzącej transakcje. Zadania
44 te są zarządzane kolektywnie przez sieć.
45
46 %package qt
47 Summary:        Qt-based Litecoin Wallet
48 Summary(pl.UTF-8):      Portfel na litecoiny oparty na Qt
49 Group:          X11/Applications
50 Requires:       %{name} = %{version}-%{release}
51
52 %description qt
53 Qt-based Litecoin Wallet.
54
55 %description qt -l pl.UTF-8
56 Portfel na litecoiny oparty na Qt.
57
58 %prep
59 %setup -q
60
61 %build
62 %{__libtoolize}
63 %{__aclocal} -I build-aux/m4
64 %{__autoconf}
65 %{__autoheader}
66 %{__automake}
67 cd src/secp256k1
68 %{__libtoolize}
69 %{__aclocal} -I build-aux/m4
70 %{__autoconf}
71 %{__autoheader}
72 %{__automake}
73 cd ../..
74 %configure \
75         --disable-shared \
76         --disable-silent-rules \
77         --with-boost \
78         --with-gui=qt4 \
79         --with-incompatible-bdb \
80         --with-miniupnpc \
81         --with-qrencode \
82         --with-qtdbus \
83         --with-system-univalue
84 %{__make}
85
86 %install
87 rm -rf $RPM_BUILD_ROOT
88 install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_desktopdir},%{_datadir}/kde4/services}
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 # shared disabled, development packages present in bitcoin.spec and feathercoin.spec
94 %{__rm} -r $RPM_BUILD_ROOT{%{_libdir}/libbitcoinconsensus.*,%{_includedir}/bitcoinconsensus.h,%{_pkgconfigdir}/libbitcoinconsensus.pc}
95
96 # see contrib/rpm/bitcoin.spec
97
98 cat <<EOF >$RPM_BUILD_ROOT%{_desktopdir}/litecoin-qt.desktop
99 [Desktop Entry]
100 Encoding=UTF-8
101 Name=Bitcoin
102 Comment=Litecoin P2P Cryptocurrency
103 Comment[fr]=Litecoin, monnaie virtuelle cryptographique pair à pair
104 Comment[pl]=Litecoin - kryptowaluta P2P
105 Comment[tr]=Litecoin, eşten eşe kriptografik sanal para birimi
106 Exec=litecoin-qt %u
107 Terminal=false
108 Type=Application
109 Icon=bitcoin128
110 MimeType=x-scheme-handler/bitcoin;
111 Categories=Office;Finance;
112 EOF
113
114 cat <<EOF >$RPM_BUILD_ROOT%{_datadir}/kde4/services/litecoin-qt.protocol
115 [Protocol]
116 exec=litecoin-qt '%u'
117 protocol=litecoin
118 input=none
119 output=none
120 helper=true
121 listing=
122 reading=false
123 writing=false
124 makedir=false
125 deleting=false
126 EOF
127
128 cp -p share/pixmaps/bitcoin.ico $RPM_BUILD_ROOT%{_pixmapsdir}
129 cp -p share/pixmaps/nsis-*.bmp $RPM_BUILD_ROOT%{_pixmapsdir}
130
131 %clean
132 rm -rf $RPM_BUILD_ROOT
133
134 %files
135 %defattr(644,root,root,755)
136 %doc COPYING doc/{README,REST-interface,assets-attribution,benchmarking,bips,dependencies,dnsseed-policy,reduce-traffic,release-notes*,shared-libraries,tor,zmq}.md doc/release-notes
137 %attr(755,root,root) %{_bindir}/litecoind
138 %attr(755,root,root) %{_bindir}/litecoin-cli
139 %attr(755,root,root) %{_bindir}/litecoin-tx
140 %{_mandir}/man1/litecoin-cli.1*
141 %{_mandir}/man1/litecoin-tx.1*
142 %{_mandir}/man1/litecoind.1*
143
144 %files qt
145 %defattr(644,root,root,755)
146 %attr(755,root,root) %{_bindir}/litecoin-qt
147 %{_datadir}/kde4/services/litecoin-qt.protocol
148 %{_desktopdir}/litecoin-qt.desktop
149 %{_pixmapsdir}/bitcoin.ico
150 %{_pixmapsdir}/nsis-*.bmp
151 %{_mandir}/man1/litecoin-qt.1*
This page took 0.093026 seconds and 4 git commands to generate.