]> git.pld-linux.org Git - packages/linux-libc-headers.git/blob - linux-libc-headers.spec
- up to 3.9.5
[packages/linux-libc-headers.git] / linux-libc-headers.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define basever 3.9
6 %define postver 5
7 Summary:        Linux kernel headers for use with C libraries
8 Summary(pl.UTF-8):      Nagłówki jądra Linuksa do użytku z bibliotekami C
9 Name:           linux-libc-headers
10 Version:        %{basever}.%{postver}
11 Release:        1
12 Epoch:          7
13 License:        GPL v2
14 Group:          Development
15 Source0:        http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
16 # Source0-md5:  4348c9b6b2eb3144d601e87c19d5d909
17 %if "%{postver}" > "0"
18 Source1:        http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
19 # Source1-md5:  aa22187ae5cd482a69097e9e59244491
20 %endif
21 Patch0:         %{name}-esfq.patch
22 Patch1:         %{name}-wrr.patch
23 Patch2:         %{name}-fbsplash.patch
24 Patch3:         %{name}-imq.patch
25 Patch4:         %{name}-pom-set.patch
26 Patch5:         %{name}-atm-vbr.patch
27 Patch6:         vserver.patch
28 AutoReqProv:    no
29 BuildRequires:  perl-base
30 BuildRequires:  rpmbuild(macros) >= 1.568
31 Requires(pre):  fileutils
32 Provides:       alsa-driver-devel
33 Provides:       glibc-kernel-headers = %{epoch}:%{version}-%{release}
34 Obsoletes:      alsa-driver-devel
35 Obsoletes:      glibc-kernel-headers
36 Obsoletes:      glibc-kernheaders
37 Conflicts:      lm_sensors-devel < 2.8.2-2
38 ExclusiveOS:    Linux
39 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
40
41 %ifarch ppc ppc64
42 %define target_arch powerpc
43 %else
44 %define target_arch %{_target_base_arch}
45 %endif
46
47 # no objects to extract debug info from
48 %define         _enable_debug_packages  0
49
50 %description
51 This package includes the C header files that specify the interface
52 between the Linux kernel and userspace libraries and programs. The
53 header files define structures and constants that are needed for
54 building most standard programs and are also needed for rebuilding the
55 glibc package.
56
57 %description -l pl.UTF-8
58 Ten pakiet zawiera pliki nagłówkowe C, które definiują interfejs
59 między jądrem Linuksa a bibliotekami i programami działającymi w
60 przestrzeni użytkownika. Pliki nagłówkowe definiują struktury i stałe
61 potrzebne do zbudowania większości standardowych programów, są także
62 potrzebne do przebudowania pakietu glibc.
63
64 %prep
65 %setup -q -c
66 cd linux-%{basever}
67 %if "%{postver}" > "0"
68 bzip2 -dc %{SOURCE1} | patch -p1
69 %endif
70 %patch0 -p1
71 %patch1 -p1
72 %patch2 -p1
73 %patch3 -p1
74 %patch4 -p1
75 %patch5 -p1
76 %patch6 -p1
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80 %{__make} -C linux-%{basever} headers_install \
81         INSTALL_HDR_PATH=$RPM_BUILD_ROOT%{_prefix} \
82         ARCH=%{target_arch}
83
84 %if %{with tests}
85 %{__make} -C linux-%{basever} headers_check \
86         INSTALL_HDR_PATH=$RPM_BUILD_ROOT%{_prefix} \
87         ARCH=%{target_arch}
88 %endif
89
90 # provided by glibc-headers
91 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/scsi
92
93 # currently provided by libdrm-devel
94 %{__rm} -r $RPM_BUILD_ROOT%{_includedir}/drm
95
96 # trash
97 find $RPM_BUILD_ROOT%{_includedir} -type f \
98         -name '..check.cmd' -o -name '.check' -o \
99         -name '..install.cmd' -o -name '.install' \
100 | xargs %{__rm}
101
102 %clean
103 rm -rf $RPM_BUILD_ROOT
104
105 %pretrans
106 [ ! -L /usr/include/linux ] || rm -f /usr/include/linux
107 [ ! -L /usr/include/asm ] || rm -f /usr/include/asm
108 [ ! -L /usr/include/sound ] || rm -f /usr/include/sound
109
110 %files
111 %defattr(644,root,root,755)
112 %{_includedir}/asm
113 %{_includedir}/asm-generic
114 %{_includedir}/linux
115 %{_includedir}/mtd
116 %{_includedir}/rdma
117 %{_includedir}/sound
118 %{_includedir}/video
119 %{_includedir}/xen
This page took 0.075492 seconds and 4 git commands to generate.