]> git.pld-linux.org Git - packages/linux-kvm.git/blob - linux-kvm.spec
- release 19 (by relup.sh)
[packages/linux-kvm.git] / linux-kvm.spec
1 # TODO: use linux tarball when kernel 3.1 is released
2 %define rel     19
3 %define snap    20110726
4 Summary:        Native Linux KVM tool
5 Summary(pl.UTF-8):      Natywne narzędzie KVM dla Linuksa
6 Name:           linux-kvm
7 Version:        3.1
8 Release:        0.%{snap}.%{rel}
9 License:        GPL v2
10 Group:          Applications/System
11 # git://github.com/penberg/linux-kvm.git
12 Source0:        %{name}-%{version}-%{snap}.tar.bz2
13 # Source0-md5:  b0b94a75d915f70ae14a089ddc7d7abb
14 Patch0:         fix-types.patch
15 BuildRequires:  binutils-devel
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17
18 %description
19 The goal of this tool is to provide a clean, from-scratch, lightweight
20 KVM host tool implementation that can boot Linux guest images (just a
21 hobby, won't be big and professional like QEMU) with no BIOS
22 dependencies and with only the minimal amount of legacy device
23 emulation.
24
25 %description -l pl.UTF-8
26 Celem tego narzędzia jest dostarczenie czystej, lekkiej, napisanej od
27 zera implementacji hosta KVM, potrafiącego uruchamiać obrazy gościa
28 Linuksa (tylko hobby, nie będzie duża i profesjonalna jak QEMU) bez
29 zależności oD BIOS-u i z minimalną emulacją tradycyjnych urządzeń.
30
31 %prep
32 %setup -q -n %{name}
33 %patch0 -p1
34
35 %build
36 %{__make} -C tools/kvm \
37         CC="%{__cc} %{rpmcppflags} %{rpmcflags} %{rpmldflags}" \
38         WERROR=0 \
39         V=1
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 install -d $RPM_BUILD_ROOT%{_sbindir}
44
45 install tools/kvm/kvm $RPM_BUILD_ROOT%{_sbindir}
46
47 %clean
48 rm -rf $RPM_BUILD_ROOT
49
50 %files
51 %defattr(644,root,root,755)
52 %doc tools/kvm/Documentation/* tools/kvm/README
53 %attr(755,root,root) %{_sbindir}/kvm
This page took 0.095618 seconds and 3 git commands to generate.