]> git.pld-linux.org Git - packages/linux-gpib.git/commitdiff
- updated to 4.0.3
authorJakub Bogusz <qboosh@pld-linux.org>
Tue, 5 Jul 2016 15:34:10 +0000 (17:34 +0200)
committerJakub Bogusz <qboosh@pld-linux.org>
Tue, 5 Jul 2016 15:34:10 +0000 (17:34 +0200)
- updated kernel build, fixed userspace build (incl. perl, python, tcl bindings)
- added destdir patch (DESTDIR fixes for hotplug/udev files)
- added python patch (install .pyo files too)
- added perl patch (use vendordirs)

linux-gpib-destdir.patch [new file with mode: 0644]
linux-gpib-include_file.patch
linux-gpib-perl.patch [new file with mode: 0644]
linux-gpib-python.patch [new file with mode: 0644]
linux-gpib.spec

diff --git a/linux-gpib-destdir.patch b/linux-gpib-destdir.patch
new file mode 100644 (file)
index 0000000..7a6c19d
--- /dev/null
@@ -0,0 +1,37 @@
+--- linux-gpib-4.0.3/usb/Makefile.am.orig      2016-04-09 15:33:10.000000000 +0200
++++ linux-gpib-4.0.3/usb/Makefile.am   2016-07-03 17:23:55.568395058 +0200
+@@ -12,5 +12,5 @@
+ UDEV_RULES_DIR = /etc/udev/rules.d
+ install-data-local: 99-gpib-generic.rules
+-      test -d $(UDEV_RULES_DIR) && test -e $(UDEV_RULES_DIR)/99-gpib-generic.rules || $(INSTALL_DATA) -D 99-gpib-generic.rules $(UDEV_RULES_DIR)/99-gpib-generic.rules
++      test -d $(DESTDIR)$(UDEV_RULES_DIR) && test -e $(DESTDIR)$(UDEV_RULES_DIR)/99-gpib-generic.rules || $(INSTALL_DATA) -D 99-gpib-generic.rules $(DESTDIR)$(UDEV_RULES_DIR)/99-gpib-generic.rules
+--- linux-gpib-4.0.3/usb/agilent_82357a/Makefile.am.orig       2016-04-09 15:33:10.000000000 +0200
++++ linux-gpib-4.0.3/usb/agilent_82357a/Makefile.am    2016-07-03 17:25:01.641370442 +0200
+@@ -19,7 +19,7 @@
+       $(do_subst) < 99-agilent_82357a.rules.in >99-agilent_82357a.rules
+ install-data-local: 99-agilent_82357a.rules
+-      test -e $(HOTPLUG_USB_CONF_DIR)/agilent_82357a || $(INSTALL_SCRIPT) -D agilent_82357a $(HOTPLUG_USB_CONF_DIR)/agilent_82357a
+-      test -e $(HOTPLUG_USB_CONF_DIR)/agilent_82357a.usermap || $(INSTALL_DATA) -D agilent_82357a.usermap $(HOTPLUG_USB_CONF_DIR)/agilent_82357a.usermap
+-      $(INSTALL) -d $(USB_FIRMWARE_DIR)/agilent_82357a
+-      test -d $(UDEV_RULES_DIR) && test -e $(UDEV_RULES_DIR)/99-agilent_82357a.rules || $(INSTALL_DATA) -D 99-agilent_82357a.rules $(UDEV_RULES_DIR)/99-agilent_82357a.rules
++      test -e $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/agilent_82357a || $(INSTALL_SCRIPT) -D agilent_82357a $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/agilent_82357a
++      test -e $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/agilent_82357a.usermap || $(INSTALL_DATA) -D agilent_82357a.usermap $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/agilent_82357a.usermap
++      $(INSTALL) -d $(DESTDIR)$(USB_FIRMWARE_DIR)/agilent_82357a
++      test -d $(DESTDIR)$(UDEV_RULES_DIR) && test -e $(DESTDIR)$(UDEV_RULES_DIR)/99-agilent_82357a.rules || $(INSTALL_DATA) -D 99-agilent_82357a.rules $(DESTDIR)$(UDEV_RULES_DIR)/99-agilent_82357a.rules
+--- linux-gpib-4.0.3/usb/ni_usb_gpib/Makefile.am.orig  2016-04-09 15:33:10.000000000 +0200
++++ linux-gpib-4.0.3/usb/ni_usb_gpib/Makefile.am       2016-07-03 17:25:55.417745779 +0200
+@@ -19,7 +19,7 @@
+       $(do_subst) < 99-ni_usb_gpib.rules.in >99-ni_usb_gpib.rules
+ install-data-local: 99-ni_usb_gpib.rules
+-      test -e $(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib || $(INSTALL_SCRIPT) -D ni_usb_gpib $(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib
+-      test -e $(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib.usermap || $(INSTALL_DATA) -D ni_usb_gpib.usermap $(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib.usermap
+-      $(INSTALL) -d $(USB_FIRMWARE_DIR)/ni_usb_gpib
+-      test -d $(UDEV_RULES_DIR) && test -e $(UDEV_RULES_DIR)/99-ni_usb_gpib.rules || $(INSTALL_DATA) -D 99-ni_usb_gpib.rules $(UDEV_RULES_DIR)/99-ni_usb_gpib.rules
++      test -e $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib || $(INSTALL_SCRIPT) -D ni_usb_gpib $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib
++      test -e $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib.usermap || $(INSTALL_DATA) -D ni_usb_gpib.usermap $(DESTDIR)$(HOTPLUG_USB_CONF_DIR)/ni_usb_gpib.usermap
++      $(INSTALL) -d $(DESTDIR)$(USB_FIRMWARE_DIR)/ni_usb_gpib
++      test -d $(DESTDIR)$(UDEV_RULES_DIR) && test -e $(DESTDIR)$(UDEV_RULES_DIR)/99-ni_usb_gpib.rules || $(INSTALL_DATA) -D 99-ni_usb_gpib.rules $(DESTDIR)$(UDEV_RULES_DIR)/99-ni_usb_gpib.rules
index 887c12fbcefb9011068c137b1fafffba25ae8479..f48cb56ed493ac9135251c4f4d74b9e9cfb6e56e 100644 (file)
@@ -1,14 +1,14 @@
---- linux-gpib-3.2.09/drivers/gpib/include/gpib_types.h        2007-12-06 00:25:49.000000000 +0000
-+++ linux-gpib-3.2.09/drivers/gpib/include/gpib_types.h.orig   2007-12-06 00:25:24.000000000 +0000
+--- linux-gpib-4.0.3/drivers/gpib/include/gpib_types.h.orig    2016-07-02 16:36:26.318566419 +0200
++++ linux-gpib-4.0.3/drivers/gpib/include/gpib_types.h 2016-07-02 16:47:34.328280834 +0200
 @@ -24,7 +24,7 @@
   * and generic interface provided by gpib-common.
   * This really should be in a different header file.
   */
 -#include "gpib/gpib_user.h"
 +#include "gpib_user.h"
+ #include <asm/atomic.h>
  #include <linux/mutex.h>
- #include <linux/wite.h>
- #include <linux/sched.h>
+ #include <linux/wait.h>
 --- linux-gpib-3.2.09/drivers/gpib/include/gpibP.h.orig        2007-12-06 00:42:20.000000000 +0000
 +++ linux-gpib-3.2.09/drivers/gpib/include/gpibP.h     2007-12-06 00:47:22.000000000 +0000
 @@ -20,7 +20,7 @@
diff --git a/linux-gpib-perl.patch b/linux-gpib-perl.patch
new file mode 100644 (file)
index 0000000..ee11546
--- /dev/null
@@ -0,0 +1,8 @@
+--- linux-gpib-4.0.3/language/Makefile.am.orig 2016-04-09 15:33:09.000000000 +0200
++++ linux-gpib-4.0.3/language/Makefile.am      2016-07-05 15:42:10.671996823 +0200
+@@ -67,4 +67,4 @@
+       $(RM) perl/Makefile
+ perl/Makefile:
+-      -(cd perl && $(PERL) Makefile.PL)
++      -(cd perl && $(PERL) Makefile.PL INSTALLDIRS=vendor CC="$(CC)" OPTIMIZE="$(CFLAGS)")
diff --git a/linux-gpib-python.patch b/linux-gpib-python.patch
new file mode 100644 (file)
index 0000000..96b9596
--- /dev/null
@@ -0,0 +1,11 @@
+--- linux-gpib-4.0.3/language/python/Makefile.am.orig  2016-04-09 15:33:09.000000000 +0200
++++ linux-gpib-4.0.3/language/python/Makefile.am       2016-07-05 15:18:01.336515214 +0200
+@@ -15,7 +15,7 @@
+       -{ $(PYTHON) setup.py build && touch build; } || { $(RM) -r build; exit 1; }
+ install-data-local:
+-      -$(PYTHON) setup.py install --prefix=$(DESTDIR)$(prefix)
++      -$(PYTHON) setup.py install --optimize=2 --prefix=$(prefix) --root=$(DESTDIR)
+ clean-local:
+       -$(RM) -r build
index 2459d32d7ad60def4203c6a15ed2b0d59d6bb7b8..a068b3604a167b8aa474a77f0d9ad4aba800b900 100644 (file)
@@ -1,50 +1,55 @@
+# TODO:
+# - resolve udev vs hotplug issues (use /lib/udev/rules.d, don't require /etc/hotplug dir with udev)
+# - guile 2 support
+# - PHP 7 support
 #
 # Conditional build:
-%bcond_without dist_kernel     # allow non-distribution kernel
-%bcond_without kernel          # don't build kernel modules
-%bcond_without userspace       # don't build userspace module
-%bcond_with    verbose         # verbose build (V=1)
+%bcond_without kernel          # kernel modules
+%bcond_without userspace       # userspace packages
+%bcond_without verbose         # verbose modules build (V=1)
 
-%bcond_without guile           #
-%bcond_without perl
-%bcond_without php
-%bcond_without python
-%bcond_without tcl
+%bcond_without docs            # documentation build
+%bcond_without static_libs     # static library
+%bcond_with    guile           # guile binding
+%bcond_without perl            # Perl binding
+%bcond_without php             # PHP binding
+%bcond_without python          # Python binding
+%bcond_without tcl             # Tcl binding
 
-%bcond_without docs
-
-#
-# main package.
-#
-
-%define                mod_name        gpib
-
-%define                _rel    0.1
-Summary:       GPIB Linux Support
-Summary(pl.UTF-8):     Sterowniki GPIB dla Linuksa
+Summary:       GPIB (IEEE 488) Linux support
+Summary(pl.UTF-8):     Obsługa GPIB (IEEE 488) dla Linuksa
 Name:          linux-gpib
-Version:       3.2.15
-Release:       %{_rel}
-License:       GPL
+Version:       4.0.3
+%define        rel     0.1
+Release:       %{rel}
+License:       GPL v2+
 Group:         Applications/System
-Source0:       http://dl.sourceforge.net/linux-gpib/%{name}-%{version}.tar.gz
-# Source0-md5: cc90a7d6738953230bd24a18188ac2f5
+Source0:       http://downloads.sourceforge.net/linux-gpib/%{name}-%{version}.tar.gz
+# Source0-md5: 2d97191e538a57ba7350fcc011ee2596
 Patch0:                %{name}-include_file.patch
+Patch1:                %{name}-destdir.patch
+Patch2:                %{name}-python.patch
+Patch3:                %{name}-perl.patch
 URL:           http://linux-gpib.sourceforge.net/
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake
+BuildRequires: libtool
+BuildRequires: rpmbuild(macros) >= 1.614
 %if %{with kernel}
-%{?with_dist_kernel:BuildRequires:     kernel-module-build >= 3:2.6.7}
-BuildRequires: rpmbuild(macros) >= 1.153
+BuildRequires: kernel-module-build >= 3:2.6.8
 %endif
-BuildRequires: kernel-headers >= 2.6.8
-BuildRequires: python
-%{?with_guile:BuildRequires:   guile-devel}
+%if %{with userspace}
+BuildRequires: bison
+%{?with_docs:BuildRequires:    docbook-utils}
+BuildRequires: flex
+%{?with_guile:BuildRequires:   guile-devel < 5:2.0}
 %{?with_perl:BuildRequires:    perl-devel}
-%{?with_php:BuildRequires:     php-devel}
-%{?with_python:BuildRequires:  python-devel}
+%{?with_php:BuildRequires:     php-devel < 4:7}
+%{?with_python:BuildRequires:  python-devel >= 2}
+BuildRequires: readline-devel
 %{?with_tcl:BuildRequires:     tcl-devel}
-
-Requires(pre,post):    kernel >= 2.6.8
-Requires:      kernel-up >= 2.6.8
+%endif
+Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -53,86 +58,292 @@ The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
 %description -l pl.UTF-8
 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
 
-# kernel subpackages.
+%package libs
+Summary:       Shared GPIB library
+Summary(pl.UTF-8):     Biblioteka współdzielona GPIB
+Group:         Libraries
 
-%package -n kernel-%{mod_name}
-Summary:       Linux driver for %{name}
-Summary(pl.UTF-8):     Sterownik dla Linuksa do %{name}
-Release:       %{_rel}@%{_kernel_ver_str}
-Group:         Base/Kernel
-Requires(post,postun): /sbin/depmod
-%if %{with dist_kernel}
-%requires_releq_kernel_up
-Requires(postun):      %releq_kernel_up
-%endif
+%description libs
+Shared GPIB library.
+
+%description libs -l pl.UTF-8
+Biblioteka współdzielona GPIB.
+
+%package devel
+Summary:       Header file for GPIB library
+Summary(pl.UTF-8):     Plik nagłówkowy biblioteki GPIB
+Group:         Development/Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+
+%description devel
+Header file for GPIB library.
+
+%description devel -l pl.UTF-8
+Plik nagłówkowy biblioteki GPIB.
+
+%package static
+Summary:       Static GPIB library
+Summary(pl.UTF-8):     Biblioteka statyczna GPIB
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static GPIB library.
+
+%description static -l pl.UTF-8
+Biblioteka statyczna GPIB.
+
+%package -n perl-gpib
+Summary:       Perl bindings for GPIB library
+Summary(pl.UTF-8):     Wiązania Perla do biblioteki GPIB
+Group:         Development/Languages/Perl
+Requires:      %{name}-libs = %{version}-%{release}
 
-%description -n kernel-%{mod_name}
-This is driver for %{name} for Linux.
+%description -n perl-gpib
+Perl bindings for GPIB library.
 
-This package contains Linux module.
+%description -n perl-gpib -l pl.UTF-8
+Wiązania Perla do biblioteki GPIB.
 
-%description -n kernel-%{mod_name} -l pl.UTF-8
-Sterownik dla Linuksa do %{name}.
+%package -n python-gpib
+Summary:       Python bindings for GPIB library
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki GPIB
+Group:         Libraries/Python
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      python-libs
 
-Ten pakiet zawiera moduł jadra
+%description -n python-gpib
+Python bindings for GPIB library.
+
+%description -n python-gpib -l pl.UTF-8
+Wiązania Pythona do biblioteki GPIB.
+
+%package -n tcl-gpib
+Summary:       Tcl bindings for GPIB library
+Summary(pl.UTF-8):     Wiązania Tcl-a do biblioteki GPIB
+Group:         Libraries
+Requires:      %{name}-libs = %{version}-%{release}
+Requires:      tcl
+
+%description -n tcl-gpib
+Tcl bindings for GPIB library.
+
+%description -n tcl-gpib -l pl.UTF-8
+Wiązania Tcl-a do biblioteki GPIB.
+
+%package doc
+Summary:       Linux-GPIB tools and library documentation
+Summary(pl.UTF-8):     Dokumentacja narzędzi i biblioteki Linux-GPIB
+License:       GFDL v1.2+ or GPL v2+
+Group:         Documentation
+
+%description doc
+Linux-GPIB tools and library documentation.
+
+%description doc -l pl.UTF-8
+Dokumentacja narzędzi i biblioteki Linux-GPIB.
+
+%define kernel_pkg()\
+%package -n kernel%{_alt_kernel}-gpib\
+Summary:       Linux GPIB drivers\
+Summary(pl.UTF-8):     Sterowniki GPIB dla Linuksa\
+Release:       %{rel}@%{_kernel_ver_str}\
+Group:         Base/Kernel\
+Requires(post,postun): /sbin/depmod\
+%requires_releq_kernel\
+Requires(postun):      %releq_kernel\
+\
+%description -n kernel%{_alt_kernel}-gpib\
+This package contains Linux drivers for GPIB (IEEE 488) hardware.\
+\
+%description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
+Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
+\
+%if %{with kernel}\
+%files -n kernel%{_alt_kernel}-gpib\
+%defattr(644,root,root,755)\
+/lib/modules/%{_kernel_ver}/kernel/gpib\
+%endif\
+\
+%post -n kernel%{_alt_kernel}-gpib\
+%depmod %{_kernel_ver}\
+\
+%postun -n kernel%{_alt_kernel}-gpib\
+%depmod %{_kernel_ver}\
+%{nil}
+
+%define build_kernel_pkg()\
+TOPDIR=$(pwd)\
+%build_kernel_modules -C drivers/gpib -m gpib -- EARLYCPPFLAGS="-I$TOPDIR -I$TOPDIR/drivers/gpib/include -I$TOPDIR/include"\
+cd drivers/gpib\
+%install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,agilent_82357a/agilent_82357a,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,lpvo_usb_gpib/lpvo_usb_gpib,nec7210/nec7210,ni_usb/ni_usb_gpib,pc2/pc2_gpib,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882 -d kernel/gpib\
+%{nil}
+
+%define install_kernel_pkg()\
+%{nil}
+
+%{?with_kernel:%{expand:%create_kernel_packages}}
 
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+# disable modules build by default, just install userspace header
+echo 'SUBDIRS = gpib/include' > drivers/Makefile.am
+
+# need to inject -I options before $(LINUXINCLUDE), the simplest way is to override CC
+for f in drivers/gpib/*/Makefile ; do
+echo 'override CC += $(EARLYCPPFLAGS)' >> $f
+done
 
 %build
-##%if %{with kernel}
-##%{__}
-##TOPDIR="`pwd`/drivers/gpib"
-##%build_kernel_modules -C drivers/gpib -m gpib_common,cec_gpib,ines_gpib,pc2_gpib \
-##     CFLAGS="%{rpmcflags} -I$TOPDIR/include -I$TOPDIR/o/include/asm/mach-default"
-##%endif
-
-##%if %{with userspace}
-%{__aclocal} -I m4
 %{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
+%{__autoheader}
 %{__automake}
-
 %configure \
-       --disable-guile-binding \
-       --disable-perl-binding \
-       --disable-php-binding \
-       --disable-python-binding \
-       --disable-tcl-binding \
-       --disable-documentation
+%ifarch %{ix86}
+       --enable-isa \
+       --enable-pcmcia \
+%endif
+       %{!?with_docs:--disable-documentation} \
+       %{!?with_guile:--disable-guile-binding} \
+       %{!?with_perl:--disable-perl-binding} \
+       %{!?with_php:--disable-php-binding} \
+       %{!?with_python:--disable-python-binding} \
+       %{?with_static_libs:--enable-static} \
+       %{!?with_tcl:--disable-tcl-binding} \
+       --with-linux-srcdir=%{_kernelsrcdir}
 
+%if %{with userspace}
 %{__make}
-##%endif
+%endif
 
-#for i in tms9914 agilent_82350b agilent_82357a cb7210 hp82335 hp_82341 nec7210 tnt4882 cec ines pc2 sys ; do
+%if %{with kernel}
+%{expand:%build_kernel_packages}
+%endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
+install -d $RPM_BUILD_ROOT%{_examplesdir}
 
 %if %{with kernel}
-%install_kernel_modules -d misc -m gpib_common,cec_gpib,ines_gpib,pc2_gpib
-#for i in agilent_82350b agilent_82357a cb7210 hp82335 hp_82341 nec7210 tms9914 tnt4882 cec ines pc2 sys; do
+%{expand:%install_kernel_packages}
+cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
 %endif
 
 %if %{with userspace}
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT \
-       HOTPLUG_USB_CONF_DIR=$RPM_BUILD_ROOT$HOTPLUG_USB_CONF_DIR \
-       USB_FIRMWARE_DIR=$RPM_BUILD_ROOT$USB_FIRMWARE_DIR
+       DESTDIR=$RPM_BUILD_ROOT
+
+# obsoleted by pkg-config
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
+
+%if %{with perl}
+%{__make} -C language/perl pure_install \
+       DESTDIR=$RPM_BUILD_ROOT
+cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
+%{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
+%endif
+
+%if %{with python}
+%py_postclean
+%endif
+
+%if %{with tcl}
+cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
+%if %{with static_libs}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
+%endif
+%endif
+
+%if %{with docs}
+# packaged as %doc
+%{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib/html
+%endif
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -n kernel%{_alt_kernel}-%{mod_name}
-%depmod %{_kernel_ver}
+%post  libs -p /sbin/ldconfig
+%postun        libs -p /sbin/ldconfig
 
-%postun -n kernel%{_alt_kernel}-%{mod_name}
-%depmod %{_kernel_ver}
+%if %{with userspace}
+%files
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/ibterm
+%attr(755,root,root) %{_bindir}/ibtest
+%attr(755,root,root) %{_sbindir}/gpib_config
+# TODO: move to /lib/udev/rules.d
+/etc/udev/rules.d/99-agilent_82357a.rules
+/etc/udev/rules.d/99-gpib-generic.rules
+/etc/udev/rules.d/99-ni_usb_gpib.rules
+# TODO: paths to fix (scripts used also in udev .rules)
+%attr(755,root,root) /etc/hotplug/usb/agilent_82357a
+%attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
+/etc/hotplug/usb/agilent_82357a.usermap
+/etc/hotplug/usb/ni_usb_gpib.usermap
+# /lib/firmware/...; and where are the files?
+%dir %{_datadir}/usb/agilent_82357a
+%dir %{_datadir}/usb/ni_usb_gpib
 
-%if %{with kernel}
-%files -n kernel%{_alt_kernel}-%{mod_name}
+%files libs
 %defattr(644,root,root,755)
-/lib/modules/%{_kernel_ver}/misc/*.ko*
+%doc AUTHORS ChangeLog README README.HAMEG README.hp82335 TODO
+%attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libgpib.so
+%{_includedir}/gpib
+%{_pkgconfigdir}/libgpib.pc
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libgpib.a
+%endif
+
+%if %{with perl}
+%files -n perl-gpib
+%defattr(644,root,root,755)
+%doc language/perl/{Changes,README}
+%{perl_vendorarch}/LinuxGpib.pm
+%dir %{perl_vendorarch}/auto/LinuxGpib
+%attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
+%{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
+%{_mandir}/man3/LinuxGpib.3pm*
+%{_examplesdir}/perl-gpib-%{version}
+%endif
+
+%if %{with python}
+%files -n python-gpib
+%defattr(644,root,root,755)
+%doc language/python/README
+%attr(755,root,root) %{py_sitedir}/gpib.so
+%{py_sitedir}/Gpib.py[co]
+%{py_sitedir}/gpib-1.0-py*.egg-info
+%endif
+
+%if %{with tcl}
+%files -n tcl-gpib
+%defattr(644,root,root,755)
+%doc language/tcl/README
+%attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
+%attr(755,root,root) %{_libdir}/libgpib_tcl.so
+%{_examplesdir}/tcl-gpib-%{version}
+%endif
+
+%if %{with docs}
+%files doc
+%defattr(644,root,root,755)
+%doc doc/doc_html/*
+%endif
 %endif
This page took 0.11975 seconds and 4 git commands to generate.