]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
f8f7431e13b31b139ef7568c7c8ee391489d8d1d
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_pcmcia  # PCMCIA support in kernel drivers
6 %bcond_without  drivers_usb     # USB kernel drivers
7 %bcond_without  userspace       # userspace packages
8 %bcond_without  verbose         # verbose modules build (V=1)
9
10 %bcond_without  docs            # documentation build
11 %bcond_with     hotplug         # legacy hotplug support
12 %bcond_without  static_libs     # static library
13 %bcond_without  guile           # guile binding
14 %bcond_without  perl            # Perl binding
15 %bcond_with     php             # PHP binding
16 %bcond_without  python          # Python binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %undefine       with_drivers_pcmcia
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34 %define         php_name        php%{?php_suffix}
35
36 %define         rel     3
37 %define         pname   linux-gpib
38 Summary:        GPIB (IEEE 488) Linux support
39 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
40 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
41 Version:        4.2.0
42 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
43 License:        GPL v2+
44 Group:          Applications/System
45 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
46 # Source0-md5:  0241dcc2d16f6d12a7aa2c3a623a55ff
47 Patch2:         %{pname}-python.patch
48 Patch3:         %{pname}-perl.patch
49 Patch4:         %{pname}-firmwaredir.patch
50 Patch5:         %{pname}-guile2.patch
51 Patch6:         %{pname}-php7.patch
52 Patch7:         kernel-5.0.patch
53 Patch8:         kernel-5.2.patch
54 URL:            http://linux-gpib.sourceforge.net/
55 BuildRequires:  autoconf >= 2.50
56 BuildRequires:  automake
57 BuildRequires:  libtool
58 BuildRequires:  rpmbuild(macros) >= 1.614
59 %if %{with kernel}
60 BuildRequires:  kernel-module-build >= 3:2.6.8
61 %endif
62 %if %{with userspace}
63 BuildRequires:  bison
64 %{?with_docs:BuildRequires:     docbook-utils}
65 BuildRequires:  flex
66 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
67 %{?with_perl:BuildRequires:     perl-devel}
68 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
69 %{?with_python:BuildRequires:   python-devel >= 2}
70 BuildRequires:  readline-devel
71 %{?with_tcl:BuildRequires:      tcl-devel}
72 %endif
73 Requires:       %{pname}-libs = %{version}-%{release}
74 # for agilent_82357a and ni_usb_gpib
75 Suggests:       fxload
76 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
77 Suggests:       linux-gpib-firmware
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
82
83 %description -l pl.UTF-8
84 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
85
86 %package hotplug
87 Summary:        Linux GPIB support for legacy USB hotplug
88 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
89 Group:          Applications/System
90 Requires:       %{pname} = %{version}-%{release}
91 Requires:       hotplug
92
93 %description hotplug
94 Linux GPIB support for legacy USB hotplug.
95
96 %description hotplug -l pl.UTF-8
97 Obsługa Linux GPIB dla starego systemu hotplug USB.
98
99 %package libs
100 Summary:        Shared GPIB library
101 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
102 Group:          Libraries
103
104 %description libs
105 Shared GPIB library.
106
107 %description libs -l pl.UTF-8
108 Biblioteka współdzielona GPIB.
109
110 %package devel
111 Summary:        Header file for GPIB library
112 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
113 Group:          Development/Libraries
114 Requires:       %{pname}-libs = %{version}-%{release}
115
116 %description devel
117 Header file for GPIB library.
118
119 %description devel -l pl.UTF-8
120 Plik nagłówkowy biblioteki GPIB.
121
122 %package static
123 Summary:        Static GPIB library
124 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
125 Group:          Development/Libraries
126 Requires:       %{pname}-devel = %{version}-%{release}
127
128 %description static
129 Static GPIB library.
130
131 %description static -l pl.UTF-8
132 Biblioteka statyczna GPIB.
133
134 %package -n guile-gpib
135 Summary:        Guile bindings for GPIB library
136 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
137 Group:          Development/Languages/Perl
138 Requires:       %{pname}-libs = %{version}-%{release}
139 Requires:       guile-libs
140
141 %description -n guile-gpib
142 Guile bindings for GPIB library.
143
144 %description -n guile-gpib -l pl.UTF-8
145 Wiązania Guile do biblioteki GPIB.
146
147 %package -n perl-gpib
148 Summary:        Perl bindings for GPIB library
149 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
150 Group:          Development/Languages/Perl
151 Requires:       %{pname}-libs = %{version}-%{release}
152
153 %description -n perl-gpib
154 Perl bindings for GPIB library.
155
156 %description -n perl-gpib -l pl.UTF-8
157 Wiązania Perla do biblioteki GPIB.
158
159 %package -n %{php_name}-gpib
160 Summary:        PHP bindings for GPIB library
161 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
162 Group:          Development/Languages/PHP
163 Provides:       php(gpib) = %{version}
164 Requires:       %{pname}-libs = %{version}-%{release}
165 %{?requires_php_extension}
166
167 %description -n %{php_name}-gpib
168 PHP bindings for GPIB library.
169
170 %description -n %{php_name}-gpib -l pl.UTF-8
171 Wiązania PHP do biblioteki GPIB.
172
173 %package -n python-gpib
174 Summary:        Python bindings for GPIB library
175 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GPIB
176 Group:          Libraries/Python
177 Requires:       %{pname}-libs = %{version}-%{release}
178 Requires:       python-libs
179
180 %description -n python-gpib
181 Python bindings for GPIB library.
182
183 %description -n python-gpib -l pl.UTF-8
184 Wiązania Pythona do biblioteki GPIB.
185
186 %package -n tcl-gpib
187 Summary:        Tcl bindings for GPIB library
188 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
189 Group:          Libraries
190 Requires:       %{pname}-libs = %{version}-%{release}
191 Requires:       tcl
192
193 %description -n tcl-gpib
194 Tcl bindings for GPIB library.
195
196 %description -n tcl-gpib -l pl.UTF-8
197 Wiązania Tcl-a do biblioteki GPIB.
198
199 %package doc
200 Summary:        Linux-GPIB tools and library documentation
201 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
202 License:        GFDL v1.2+ or GPL v2+
203 Group:          Documentation
204
205 %description doc
206 Linux-GPIB tools and library documentation.
207
208 %description doc -l pl.UTF-8
209 Dokumentacja narzędzi i biblioteki Linux-GPIB.
210
211 %define kernel_pkg()\
212 %package -n kernel%{_alt_kernel}-gpib\
213 Summary:        Linux GPIB drivers\
214 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
215 Release:        %{rel}@%{_kernel_ver_str}\
216 Group:          Base/Kernel\
217 Requires(post,postun):  /sbin/depmod\
218 %requires_releq_kernel\
219 Requires(postun):       %releq_kernel\
220 \
221 %description -n kernel%{_alt_kernel}-gpib\
222 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
223 \
224 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
225 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
226 \
227 %if %{with kernel}\
228 %files -n kernel%{_alt_kernel}-gpib\
229 %defattr(644,root,root,755)\
230 /lib/modules/%{_kernel_ver}/kernel/gpib\
231 %endif\
232 \
233 %post -n kernel%{_alt_kernel}-gpib\
234 %depmod %{_kernel_ver}\
235 \
236 %postun -n kernel%{_alt_kernel}-gpib\
237 %depmod %{_kernel_ver}\
238 %{nil}
239
240 %define build_kernel_pkg()\
241 %configure \\\
242         %{?with_drivers_isa:--enable-isa} \\\
243         %{?with_drivers_pcmcia:--enable-pcmcia} \\\
244         %{!?with_docs:--disable-documentation} \\\
245         %{!?with_guile:--disable-guile-binding} \\\
246         %{!?with_perl:--disable-perl-binding} \\\
247         %{!?with_python:--disable-python-binding} \\\
248         %{!?with_tcl:--disable-tcl-binding} \\\
249         --with-linux-srcdir=%{_kernelsrcdir}\
250 %{__make}\
251 cd drivers/gpib\
252 %ifarch %{ix86}\
253 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
254 %else\
255 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
256 %endif\
257 cd ../..\
258 %{nil}
259
260 %define install_kernel_pkg()\
261 %{nil}
262
263 %{?with_kernel:%{expand:%create_kernel_packages}}
264
265 %prep
266 %setup -q -n %{pname}-%{version}
267 %if %{with userspace}
268 tar xzf linux-gpib-user-%{version}.tar.gz
269 cd linux-gpib-user-%{version}
270 %patch2 -p1
271 %patch3 -p1
272 %patch4 -p1
273 %patch5 -p1
274 #%patch6 -p1
275 cd ..
276 %endif
277
278 %if %{with kernel}
279 tar xzf linux-gpib-kernel-%{version}.tar.gz
280 cd linux-gpib-kernel-%{version}
281 %patch7 -p1
282 %ifarch %{ix86}
283 %patch8 -p1
284 %endif
285
286 # disable modules build by default, just install userspace header
287 echo 'SUBDIRS = gpib/include' > drivers/Makefile.am
288
289 # need to inject -I options before $(LINUXINCLUDE), the simplest way is to override CC
290 for f in drivers/gpib/*/Makefile ; do
291 echo 'override CC += $(EARLYCPPFLAGS)' >> $f
292 done
293 %endif
294
295 %build
296 %if %{with userspace}
297 cd linux-gpib-user-%{version}
298 %{__libtoolize}
299 %{__aclocal}
300 %{__autoconf}
301 %{__autoheader}
302 %{__automake}
303 %if %{with guile}
304 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.2"
305 %endif
306 %configure \
307         %{?with_drivers_isa:--enable-isa} \
308         %{?with_drivers_pcmcia:--enable-pcmcia} \
309         %{!?with_docs:--disable-documentation} \
310         %{!?with_guile:--disable-guile-binding} \
311         %{!?with_perl:--disable-perl-binding} \
312         %{!?with_php:--disable-php-binding} \
313         %{!?with_python:--disable-python-binding} \
314         %{?with_static_libs:--enable-static} \
315         %{!?with_tcl:--disable-tcl-binding}
316
317 %{__make}
318 cd ..
319 %endif
320
321 %if %{with kernel}
322 cd linux-gpib-kernel-%{version}
323 %{expand:%build_kernel_packages}
324 %endif
325
326 %install
327 rm -rf $RPM_BUILD_ROOT
328 install -d $RPM_BUILD_ROOT%{_examplesdir}
329
330 %if %{with kernel}
331 cd linux-gpib-kernel-%{version}
332 %{expand:%install_kernel_packages}
333 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
334 cd ..
335 %endif
336
337 %if %{with userspace}
338 cd linux-gpib-user-%{version}
339 %{__make} install \
340         DESTDIR=$RPM_BUILD_ROOT \
341         HOTPLUG_USB_CONF_DIR=/lib/udev \
342         UDEV_RULES_DIR=/lib/udev/rules.d \
343         USB_FIRMWARE_DIR=/lib/firmware
344
345 %if %{with hotplug}
346 # use udev paths as base and legacy hotplug as addon (not the opposite)
347 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
348 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
349 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
350 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
351 %else
352 %{__rm} $RPM_BUILD_ROOT/lib/udev/*.usermap
353 %endif
354
355 # obsoleted by pkg-config
356 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
357
358 %if %{with guile}
359 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
360 %if %{with static_libs}
361 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
362 %endif
363 %endif
364
365 %if %{with perl}
366 %{__make} -C language/perl pure_install \
367         DESTDIR=$RPM_BUILD_ROOT
368
369 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
370
371 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
372 %endif
373
374 %if %{with php}
375 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
376 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
377 ; Enable gpib extension module
378 extension=gpib_php.so
379 EOF
380
381 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
382 %if %{with static_libs}
383 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
384 %endif
385 %endif
386
387 %if %{with python}
388 %py_postclean
389 %endif
390
391 %if %{with tcl}
392 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
393
394 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
395 %if %{with static_libs}
396 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
397 %endif
398 %endif
399
400 %if %{with docs}
401 # packaged as %doc
402 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib-user/html
403 %endif
404 %endif
405
406 %clean
407 rm -rf $RPM_BUILD_ROOT
408
409 %post   libs -p /sbin/ldconfig
410 %postun libs -p /sbin/ldconfig
411
412 %post   -n guile-gpib -p /sbin/ldconfig
413 %postun -n guile-gpib -p /sbin/ldconfig
414
415 %post   -n tcl-gpib -p /sbin/ldconfig
416 %postun -n tcl-gpib -p /sbin/ldconfig
417
418 %post   -n %{php_name}-gpib
419 %php_webserver_restart
420
421 %postun -n %{php_name}-gpib
422 if [ "$1" = 0 ]; then
423         %php_webserver_restart
424 fi
425
426 %if %{with userspace}
427 %files
428 %defattr(644,root,root,755)
429 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/gpib.conf
430 %attr(755,root,root) %{_bindir}/ibterm
431 %attr(755,root,root) %{_bindir}/ibtest
432 %attr(755,root,root) %{_sbindir}/gpib_config
433 /lib/udev/rules.d/99-agilent_82357a.rules
434 /lib/udev/rules.d/99-gpib-generic.rules
435 /lib/udev/rules.d/99-ni_usb_gpib.rules
436 %attr(755,root,root) /lib/udev/agilent_82357a
437 %attr(755,root,root) /lib/udev/ni_usb_gpib
438
439 %if %{with hotplug}
440 %files hotplug
441 %defattr(644,root,root,755)
442 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
443 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
444 /etc/hotplug/usb/agilent_82357a.usermap
445 /etc/hotplug/usb/ni_usb_gpib.usermap
446 %endif
447
448 %files libs
449 %defattr(644,root,root,755)
450 %doc linux-gpib-user-%{version}/{AUTHORS,ChangeLog,README,README.HAMEG,README.hp82335,TODO}
451 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
452 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
453
454 %files devel
455 %defattr(644,root,root,755)
456 %attr(755,root,root) %{_libdir}/libgpib.so
457 %{_includedir}/gpib
458 %{_pkgconfigdir}/libgpib.pc
459
460 %if %{with static_libs}
461 %files static
462 %defattr(644,root,root,755)
463 %{_libdir}/libgpib.a
464 %endif
465
466 %if %{with guile}
467 %files -n guile-gpib
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
470 %attr(755,root,root) %{_libdir}/libgpib-guile.so
471 %endif
472
473 %if %{with perl}
474 %files -n perl-gpib
475 %defattr(644,root,root,755)
476 %doc linux-gpib-user-%{version}/language/perl/{Changes,README}
477 %{perl_vendorarch}/LinuxGpib.pm
478 %dir %{perl_vendorarch}/auto/LinuxGpib
479 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
480 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
481 %{_mandir}/man3/LinuxGpib.3pm*
482 %{_examplesdir}/perl-gpib-%{version}
483 %endif
484
485 %if %{with php}
486 %files -n %{php_name}-gpib
487 %defattr(644,root,root,755)
488 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
489 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
490 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
491 %endif
492
493 %if %{with python}
494 %files -n python-gpib
495 %defattr(644,root,root,755)
496 %doc linux-gpib-user-%{version}/language/python/README
497 %attr(755,root,root) %{py_sitedir}/gpib.so
498 %{py_sitedir}/Gpib.py[co]
499 %{py_sitedir}/gpib-1.0-py*.egg-info
500 %endif
501
502 %if %{with tcl}
503 %files -n tcl-gpib
504 %defattr(644,root,root,755)
505 %doc linux-gpib-user-%{version}/language/tcl/README
506 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
507 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
508 %{_examplesdir}/tcl-gpib-%{version}
509 %endif
510
511 %if %{with docs}
512 %files doc
513 %defattr(644,root,root,755)
514 %doc linux-gpib-user-%{version}/doc/doc_html/*
515 %endif
516 %endif
This page took 0.084011 seconds and 2 git commands to generate.