]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
- rebuild with perl 5.24.0
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_pcmcia  # PCMCIA support in kernel drivers
6 %bcond_without  drivers_usb     # USB kernel drivers
7 %bcond_without  userspace       # userspace packages
8 %bcond_without  verbose         # verbose modules build (V=1)
9
10 %bcond_without  docs            # documentation build
11 %bcond_with     hotplug         # legacy hotplug support
12 %bcond_without  static_libs     # static library
13 %bcond_without  guile           # guile binding
14 %bcond_without  perl            # Perl binding
15 %bcond_with     php             # PHP binding
16 %bcond_without  python          # Python binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %undefine       with_drivers_pcmcia
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34 %define         php_name        php%{?php_suffix}
35
36 %define         rel     8
37 %define         pname   linux-gpib
38 Summary:        GPIB (IEEE 488) Linux support
39 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
40 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
41 Version:        4.0.3
42 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
43 License:        GPL v2+
44 Group:          Applications/System
45 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
46 # Source0-md5:  2d97191e538a57ba7350fcc011ee2596
47 Patch0:         %{pname}-include_file.patch
48 Patch1:         %{pname}-destdir.patch
49 Patch2:         %{pname}-python.patch
50 Patch3:         %{pname}-perl.patch
51 Patch4:         %{pname}-firmwaredir.patch
52 Patch5:         %{pname}-guile2.patch
53 Patch6:         %{pname}-php7.patch
54 URL:            http://linux-gpib.sourceforge.net/
55 BuildRequires:  autoconf >= 2.50
56 BuildRequires:  automake
57 BuildRequires:  libtool
58 BuildRequires:  rpmbuild(macros) >= 1.614
59 %if %{with kernel}
60 BuildRequires:  kernel-module-build >= 3:2.6.8
61 %endif
62 %if %{with userspace}
63 BuildRequires:  bison
64 %{?with_docs:BuildRequires:     docbook-utils}
65 BuildRequires:  flex
66 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
67 %{?with_perl:BuildRequires:     perl-devel}
68 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
69 %{?with_python:BuildRequires:   python-devel >= 2}
70 BuildRequires:  readline-devel
71 %{?with_tcl:BuildRequires:      tcl-devel}
72 %endif
73 Requires:       %{pname}-libs = %{version}-%{release}
74 # for agilent_82357a and ni_usb_gpib
75 Suggests:       fxload
76 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
77 Suggests:       linux-gpib-firmware
78 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
79
80 %description
81 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
82
83 %description -l pl.UTF-8
84 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
85
86 %package hotplug
87 Summary:        Linux GPIB support for legacy USB hotplug
88 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
89 Group:          Applications/System
90 Requires:       %{pname} = %{version}-%{release}
91 Requires:       hotplug
92
93 %description hotplug
94 Linux GPIB support for legacy USB hotplug.
95
96 %description hotplug -l pl.UTF-8
97 Obsługa Linux GPIB dla starego systemu hotplug USB.
98
99 %package libs
100 Summary:        Shared GPIB library
101 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
102 Group:          Libraries
103
104 %description libs
105 Shared GPIB library.
106
107 %description libs -l pl.UTF-8
108 Biblioteka współdzielona GPIB.
109
110 %package devel
111 Summary:        Header file for GPIB library
112 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
113 Group:          Development/Libraries
114 Requires:       %{pname}-libs = %{version}-%{release}
115
116 %description devel
117 Header file for GPIB library.
118
119 %description devel -l pl.UTF-8
120 Plik nagłówkowy biblioteki GPIB.
121
122 %package static
123 Summary:        Static GPIB library
124 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
125 Group:          Development/Libraries
126 Requires:       %{pname}-devel = %{version}-%{release}
127
128 %description static
129 Static GPIB library.
130
131 %description static -l pl.UTF-8
132 Biblioteka statyczna GPIB.
133
134 %package -n guile-gpib
135 Summary:        Guile bindings for GPIB library
136 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
137 Group:          Development/Languages/Perl
138 Requires:       %{pname}-libs = %{version}-%{release}
139 Requires:       guile-libs
140
141 %description -n guile-gpib
142 Guile bindings for GPIB library.
143
144 %description -n guile-gpib -l pl.UTF-8
145 Wiązania Guile do biblioteki GPIB.
146
147 %package -n perl-gpib
148 Summary:        Perl bindings for GPIB library
149 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
150 Group:          Development/Languages/Perl
151 Requires:       %{pname}-libs = %{version}-%{release}
152
153 %description -n perl-gpib
154 Perl bindings for GPIB library.
155
156 %description -n perl-gpib -l pl.UTF-8
157 Wiązania Perla do biblioteki GPIB.
158
159 %package -n %{php_name}-gpib
160 Summary:        PHP bindings for GPIB library
161 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
162 Group:          Development/Languages/PHP
163 Provides:       php(gpib) = %{version}
164 Requires:       %{pname}-libs = %{version}-%{release}
165 %{?requires_php_extension}
166
167 %description -n %{php_name}-gpib
168 PHP bindings for GPIB library.
169
170 %description -n %{php_name}-gpib -l pl.UTF-8
171 Wiązania PHP do biblioteki GPIB.
172
173 %package -n python-gpib
174 Summary:        Python bindings for GPIB library
175 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GPIB
176 Group:          Libraries/Python
177 Requires:       %{pname}-libs = %{version}-%{release}
178 Requires:       python-libs
179
180 %description -n python-gpib
181 Python bindings for GPIB library.
182
183 %description -n python-gpib -l pl.UTF-8
184 Wiązania Pythona do biblioteki GPIB.
185
186 %package -n tcl-gpib
187 Summary:        Tcl bindings for GPIB library
188 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
189 Group:          Libraries
190 Requires:       %{pname}-libs = %{version}-%{release}
191 Requires:       tcl
192
193 %description -n tcl-gpib
194 Tcl bindings for GPIB library.
195
196 %description -n tcl-gpib -l pl.UTF-8
197 Wiązania Tcl-a do biblioteki GPIB.
198
199 %package doc
200 Summary:        Linux-GPIB tools and library documentation
201 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
202 License:        GFDL v1.2+ or GPL v2+
203 Group:          Documentation
204
205 %description doc
206 Linux-GPIB tools and library documentation.
207
208 %description doc -l pl.UTF-8
209 Dokumentacja narzędzi i biblioteki Linux-GPIB.
210
211 %define kernel_pkg()\
212 %package -n kernel%{_alt_kernel}-gpib\
213 Summary:        Linux GPIB drivers\
214 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
215 Release:        %{rel}@%{_kernel_ver_str}\
216 Group:          Base/Kernel\
217 Requires(post,postun):  /sbin/depmod\
218 %requires_releq_kernel\
219 Requires(postun):       %releq_kernel\
220 \
221 %description -n kernel%{_alt_kernel}-gpib\
222 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
223 \
224 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
225 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
226 \
227 %if %{with kernel}\
228 %files -n kernel%{_alt_kernel}-gpib\
229 %defattr(644,root,root,755)\
230 /lib/modules/%{_kernel_ver}/kernel/gpib\
231 %endif\
232 \
233 %post -n kernel%{_alt_kernel}-gpib\
234 %depmod %{_kernel_ver}\
235 \
236 %postun -n kernel%{_alt_kernel}-gpib\
237 %depmod %{_kernel_ver}\
238 %{nil}
239
240 %define build_kernel_pkg()\
241 TOPDIR=$(pwd)\
242 %build_kernel_modules -C drivers/gpib -m gpib -- EARLYCPPFLAGS="-I$TOPDIR -I$TOPDIR/drivers/gpib/include -I$TOPDIR/include"\
243 cd drivers/gpib\
244 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
245 cd ../..\
246 %{nil}
247
248 %define install_kernel_pkg()\
249 %{nil}
250
251 %{?with_kernel:%{expand:%create_kernel_packages}}
252
253 %prep
254 %setup -q -n %{pname}-%{version}
255 %patch0 -p1
256 %patch1 -p1
257 %patch2 -p1
258 %patch3 -p1
259 %patch4 -p1
260 %patch5 -p1
261 %patch6 -p1
262
263 # disable modules build by default, just install userspace header
264 echo 'SUBDIRS = gpib/include' > drivers/Makefile.am
265
266 # need to inject -I options before $(LINUXINCLUDE), the simplest way is to override CC
267 for f in drivers/gpib/*/Makefile ; do
268 echo 'override CC += $(EARLYCPPFLAGS)' >> $f
269 done
270
271 %build
272 %{__libtoolize}
273 %{__aclocal} -I m4
274 %{__autoconf}
275 %{__autoheader}
276 %{__automake}
277 %if %{with guile}
278 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.0"
279 %endif
280 %configure \
281         %{?with_drivers_isa:--enable-isa} \
282         %{?with_drivers_pcmcia:--enable-pcmcia} \
283         %{!?with_docs:--disable-documentation} \
284         %{!?with_guile:--disable-guile-binding} \
285         %{!?with_perl:--disable-perl-binding} \
286         %{!?with_php:--disable-php-binding} \
287         %{!?with_python:--disable-python-binding} \
288         %{?with_static_libs:--enable-static} \
289         %{!?with_tcl:--disable-tcl-binding} \
290         --with-linux-srcdir=%{_kernelsrcdir}
291
292 %if %{with userspace}
293 %{__make}
294 %endif
295
296 %if %{with kernel}
297 %{expand:%build_kernel_packages}
298 %endif
299
300 %install
301 rm -rf $RPM_BUILD_ROOT
302 install -d $RPM_BUILD_ROOT%{_examplesdir}
303
304 %if %{with kernel}
305 %{expand:%install_kernel_packages}
306 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
307 %endif
308
309 %if %{with userspace}
310 %{__make} install \
311         DESTDIR=$RPM_BUILD_ROOT \
312         HOTPLUG_USB_CONF_DIR=/lib/udev \
313         UDEV_RULES_DIR=/lib/udev/rules.d \
314         USB_FIRMWARE_DIR=/lib/firmware
315
316 %if %{with hotplug}
317 # use udev paths as base and legacy hotplug as addon (not the opposite)
318 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
319 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
320 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
321 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
322 %else
323 %{__rm} $RPM_BUILD_ROOT/lib/udev/*.usermap
324 %endif
325
326 # obsoleted by pkg-config
327 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
328
329 %if %{with guile}
330 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
331 %if %{with static_libs}
332 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
333 %endif
334 %endif
335
336 %if %{with perl}
337 %{__make} -C language/perl pure_install \
338         DESTDIR=$RPM_BUILD_ROOT
339
340 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
341
342 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
343 %endif
344
345 %if %{with php}
346 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
347 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
348 ; Enable gpib extension module
349 extension=gpib_php.so
350 EOF
351
352 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
353 %if %{with static_libs}
354 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
355 %endif
356 %endif
357
358 %if %{with python}
359 %py_postclean
360 %endif
361
362 %if %{with tcl}
363 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
364
365 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
366 %if %{with static_libs}
367 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
368 %endif
369 %endif
370
371 %if %{with docs}
372 # packaged as %doc
373 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib/html
374 %endif
375 %endif
376
377 %clean
378 rm -rf $RPM_BUILD_ROOT
379
380 %post   libs -p /sbin/ldconfig
381 %postun libs -p /sbin/ldconfig
382
383 %post   -n guile-gpib -p /sbin/ldconfig
384 %postun -n guile-gpib -p /sbin/ldconfig
385
386 %post   -n tcl-gpib -p /sbin/ldconfig
387 %postun -n tcl-gpib -p /sbin/ldconfig
388
389 %post   -n %{php_name}-gpib
390 %php_webserver_restart
391
392 %postun -n %{php_name}-gpib
393 if [ "$1" = 0 ]; then
394         %php_webserver_restart
395 fi
396
397 %if %{with userspace}
398 %files
399 %defattr(644,root,root,755)
400 %attr(755,root,root) %{_bindir}/ibterm
401 %attr(755,root,root) %{_bindir}/ibtest
402 %attr(755,root,root) %{_sbindir}/gpib_config
403 /lib/udev/rules.d/99-agilent_82357a.rules
404 /lib/udev/rules.d/99-gpib-generic.rules
405 /lib/udev/rules.d/99-ni_usb_gpib.rules
406 %attr(755,root,root) /lib/udev/agilent_82357a
407 %attr(755,root,root) /lib/udev/ni_usb_gpib
408
409 %if %{with hotplug}
410 %files hotplug
411 %defattr(644,root,root,755)
412 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
413 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
414 /etc/hotplug/usb/agilent_82357a.usermap
415 /etc/hotplug/usb/ni_usb_gpib.usermap
416 %endif
417
418 %files libs
419 %defattr(644,root,root,755)
420 %doc AUTHORS ChangeLog README README.HAMEG README.hp82335 TODO
421 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
422 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
423
424 %files devel
425 %defattr(644,root,root,755)
426 %attr(755,root,root) %{_libdir}/libgpib.so
427 %{_includedir}/gpib
428 %{_pkgconfigdir}/libgpib.pc
429
430 %if %{with static_libs}
431 %files static
432 %defattr(644,root,root,755)
433 %{_libdir}/libgpib.a
434 %endif
435
436 %if %{with guile}
437 %files -n guile-gpib
438 %defattr(644,root,root,755)
439 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
440 %attr(755,root,root) %{_libdir}/libgpib-guile.so
441 %endif
442
443 %if %{with perl}
444 %files -n perl-gpib
445 %defattr(644,root,root,755)
446 %doc language/perl/{Changes,README}
447 %{perl_vendorarch}/LinuxGpib.pm
448 %dir %{perl_vendorarch}/auto/LinuxGpib
449 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
450 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
451 %{_mandir}/man3/LinuxGpib.3pm*
452 %{_examplesdir}/perl-gpib-%{version}
453 %endif
454
455 %if %{with php}
456 %files -n %{php_name}-gpib
457 %defattr(644,root,root,755)
458 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
459 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
460 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
461 %endif
462
463 %if %{with python}
464 %files -n python-gpib
465 %defattr(644,root,root,755)
466 %doc language/python/README
467 %attr(755,root,root) %{py_sitedir}/gpib.so
468 %{py_sitedir}/Gpib.py[co]
469 %{py_sitedir}/gpib-1.0-py*.egg-info
470 %endif
471
472 %if %{with tcl}
473 %files -n tcl-gpib
474 %defattr(644,root,root,755)
475 %doc language/tcl/README
476 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
477 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
478 %{_examplesdir}/tcl-gpib-%{version}
479 %endif
480
481 %if %{with docs}
482 %files doc
483 %defattr(644,root,root,755)
484 %doc doc/doc_html/*
485 %endif
486 %endif
This page took 0.428276 seconds and 3 git commands to generate.