]> git.pld-linux.org Git - packages/linux-gpib.git/blob - linux-gpib.spec
903541e9e9068f037f0c9912506faa1d8992fb8b
[packages/linux-gpib.git] / linux-gpib.spec
1 #
2 # Conditional build:
3 %bcond_without  kernel          # kernel modules
4 %bcond_without  drivers_isa     # ISA kernel drivers [ix86 only]
5 %bcond_without  drivers_pcmcia  # PCMCIA support in kernel drivers
6 %bcond_without  drivers_usb     # USB kernel drivers
7 %bcond_without  userspace       # userspace packages
8 %bcond_without  verbose         # verbose modules build (V=1)
9
10 %bcond_without  docs            # documentation build
11 %bcond_with     hotplug         # legacy hotplug support
12 %bcond_without  static_libs     # static library
13 %bcond_without  guile           # guile binding
14 %bcond_without  perl            # Perl binding
15 %bcond_with     php             # PHP binding
16 %bcond_without  python          # Python binding
17 %bcond_without  tcl             # Tcl binding
18
19 # The goal here is to have main, userspace, package built once with
20 # simple release number, and only rebuild kernel packages with kernel
21 # version as part of release number, without the need to bump release
22 # with every kernel change.
23 %if 0%{?_pld_builder:1} && %{with kernel} && %{with userspace}
24 %{error:kernel and userspace cannot be built at the same time on PLD builders}
25 exit 1
26 %endif
27
28 %ifnarch %{ix86}
29 %undefine       with_drivers_isa
30 %undefine       with_drivers_pcmcia
31 %endif
32
33 %include        /usr/lib/rpm/macros.perl
34 %define         php_name        php%{?php_suffix}
35
36 %define         rel     3
37 %define         pname   linux-gpib
38 Summary:        GPIB (IEEE 488) Linux support
39 Summary(pl.UTF-8):      Obsługa GPIB (IEEE 488) dla Linuksa
40 Name:           %{pname}%{?_pld_builder:%{?with_kernel:-kernel}}%{_alt_kernel}
41 Version:        4.1.0
42 Release:        %{rel}%{?_pld_builder:%{?with_kernel:@%{_kernel_ver_str}}}
43 License:        GPL v2+
44 Group:          Applications/System
45 Source0:        http://downloads.sourceforge.net/linux-gpib/%{pname}-%{version}.tar.gz
46 # Source0-md5:  2614bb6dcfde4bf01f6047fdf0ea021f
47 Patch0:         %{pname}-include_file.patch
48 Patch1:         %{pname}-destdir.patch
49 Patch2:         %{pname}-python.patch
50 Patch3:         %{pname}-perl.patch
51 Patch4:         %{pname}-firmwaredir.patch
52 Patch5:         %{pname}-guile2.patch
53 Patch6:         %{pname}-php7.patch
54 Patch7:         kernel-4.11.patch
55 Patch8:         kernel-4.15.patch
56 URL:            http://linux-gpib.sourceforge.net/
57 BuildRequires:  autoconf >= 2.50
58 BuildRequires:  automake
59 BuildRequires:  libtool
60 BuildRequires:  rpmbuild(macros) >= 1.614
61 %if %{with kernel}
62 BuildRequires:  kernel-module-build >= 3:2.6.8
63 %endif
64 %if %{with userspace}
65 BuildRequires:  bison
66 %{?with_docs:BuildRequires:     docbook-utils}
67 BuildRequires:  flex
68 %{?with_guile:BuildRequires:    guile-devel >= 1.4}
69 %{?with_perl:BuildRequires:     perl-devel}
70 %{?with_php:BuildRequires:      %{php_name}-devel >= 3:5}
71 %{?with_python:BuildRequires:   python-devel >= 2}
72 BuildRequires:  readline-devel
73 %{?with_tcl:BuildRequires:      tcl-devel}
74 %endif
75 Requires:       %{pname}-libs = %{version}-%{release}
76 # for agilent_82357a and ni_usb_gpib
77 Suggests:       fxload
78 # for agilent_82357a, agilent/hp_82341, agilent/hp_82350a, ni_usb_gpib
79 Suggests:       linux-gpib-firmware
80 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
81
82 %description
83 The Linux GPIB package provides support for GPIB (IEEE 488) hardware.
84
85 %description -l pl.UTF-8
86 Pakiet Linux GPIB służy do obsługi sprzętu GPIB (IEEE 488).
87
88 %package hotplug
89 Summary:        Linux GPIB support for legacy USB hotplug
90 Summary(pl.UTF-8):      Obsługa Linux GPIB dla starego systemu hotplug USB
91 Group:          Applications/System
92 Requires:       %{pname} = %{version}-%{release}
93 Requires:       hotplug
94
95 %description hotplug
96 Linux GPIB support for legacy USB hotplug.
97
98 %description hotplug -l pl.UTF-8
99 Obsługa Linux GPIB dla starego systemu hotplug USB.
100
101 %package libs
102 Summary:        Shared GPIB library
103 Summary(pl.UTF-8):      Biblioteka współdzielona GPIB
104 Group:          Libraries
105
106 %description libs
107 Shared GPIB library.
108
109 %description libs -l pl.UTF-8
110 Biblioteka współdzielona GPIB.
111
112 %package devel
113 Summary:        Header file for GPIB library
114 Summary(pl.UTF-8):      Plik nagłówkowy biblioteki GPIB
115 Group:          Development/Libraries
116 Requires:       %{pname}-libs = %{version}-%{release}
117
118 %description devel
119 Header file for GPIB library.
120
121 %description devel -l pl.UTF-8
122 Plik nagłówkowy biblioteki GPIB.
123
124 %package static
125 Summary:        Static GPIB library
126 Summary(pl.UTF-8):      Biblioteka statyczna GPIB
127 Group:          Development/Libraries
128 Requires:       %{pname}-devel = %{version}-%{release}
129
130 %description static
131 Static GPIB library.
132
133 %description static -l pl.UTF-8
134 Biblioteka statyczna GPIB.
135
136 %package -n guile-gpib
137 Summary:        Guile bindings for GPIB library
138 Summary(pl.UTF-8):      Wiązania Guile do biblioteki GPIB
139 Group:          Development/Languages/Perl
140 Requires:       %{pname}-libs = %{version}-%{release}
141 Requires:       guile-libs
142
143 %description -n guile-gpib
144 Guile bindings for GPIB library.
145
146 %description -n guile-gpib -l pl.UTF-8
147 Wiązania Guile do biblioteki GPIB.
148
149 %package -n perl-gpib
150 Summary:        Perl bindings for GPIB library
151 Summary(pl.UTF-8):      Wiązania Perla do biblioteki GPIB
152 Group:          Development/Languages/Perl
153 Requires:       %{pname}-libs = %{version}-%{release}
154
155 %description -n perl-gpib
156 Perl bindings for GPIB library.
157
158 %description -n perl-gpib -l pl.UTF-8
159 Wiązania Perla do biblioteki GPIB.
160
161 %package -n %{php_name}-gpib
162 Summary:        PHP bindings for GPIB library
163 Summary(pl.UTF-8):      Wiązania PHP do biblioteki GPIB
164 Group:          Development/Languages/PHP
165 Provides:       php(gpib) = %{version}
166 Requires:       %{pname}-libs = %{version}-%{release}
167 %{?requires_php_extension}
168
169 %description -n %{php_name}-gpib
170 PHP bindings for GPIB library.
171
172 %description -n %{php_name}-gpib -l pl.UTF-8
173 Wiązania PHP do biblioteki GPIB.
174
175 %package -n python-gpib
176 Summary:        Python bindings for GPIB library
177 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki GPIB
178 Group:          Libraries/Python
179 Requires:       %{pname}-libs = %{version}-%{release}
180 Requires:       python-libs
181
182 %description -n python-gpib
183 Python bindings for GPIB library.
184
185 %description -n python-gpib -l pl.UTF-8
186 Wiązania Pythona do biblioteki GPIB.
187
188 %package -n tcl-gpib
189 Summary:        Tcl bindings for GPIB library
190 Summary(pl.UTF-8):      Wiązania Tcl-a do biblioteki GPIB
191 Group:          Libraries
192 Requires:       %{pname}-libs = %{version}-%{release}
193 Requires:       tcl
194
195 %description -n tcl-gpib
196 Tcl bindings for GPIB library.
197
198 %description -n tcl-gpib -l pl.UTF-8
199 Wiązania Tcl-a do biblioteki GPIB.
200
201 %package doc
202 Summary:        Linux-GPIB tools and library documentation
203 Summary(pl.UTF-8):      Dokumentacja narzędzi i biblioteki Linux-GPIB
204 License:        GFDL v1.2+ or GPL v2+
205 Group:          Documentation
206
207 %description doc
208 Linux-GPIB tools and library documentation.
209
210 %description doc -l pl.UTF-8
211 Dokumentacja narzędzi i biblioteki Linux-GPIB.
212
213 %define kernel_pkg()\
214 %package -n kernel%{_alt_kernel}-gpib\
215 Summary:        Linux GPIB drivers\
216 Summary(pl.UTF-8):      Sterowniki GPIB dla Linuksa\
217 Release:        %{rel}@%{_kernel_ver_str}\
218 Group:          Base/Kernel\
219 Requires(post,postun):  /sbin/depmod\
220 %requires_releq_kernel\
221 Requires(postun):       %releq_kernel\
222 \
223 %description -n kernel%{_alt_kernel}-gpib\
224 This package contains Linux drivers for GPIB (IEEE 488) hardware.\
225 \
226 %description -n kernel%{_alt_kernel}-gpib -l pl.UTF-8\
227 Ten pakiet zawiera sterowniki dla Linuksa do urządzeń GPIB (IEEE 488).\
228 \
229 %if %{with kernel}\
230 %files -n kernel%{_alt_kernel}-gpib\
231 %defattr(644,root,root,755)\
232 /lib/modules/%{_kernel_ver}/kernel/gpib\
233 %endif\
234 \
235 %post -n kernel%{_alt_kernel}-gpib\
236 %depmod %{_kernel_ver}\
237 \
238 %postun -n kernel%{_alt_kernel}-gpib\
239 %depmod %{_kernel_ver}\
240 %{nil}
241
242 %define build_kernel_pkg()\
243 TOPDIR=$(pwd)\
244 %build_kernel_modules -C drivers/gpib -m gpib -- EARLYCPPFLAGS="-I$TOPDIR -I$TOPDIR/drivers/gpib/include -I$TOPDIR/include"\
245 cd drivers/gpib\
246 %install_kernel_modules -D installed -m agilent_82350b/agilent_82350b,cb7210/cb7210,cec/cec_gpib,hp_82335/hp82335,hp_82341/hp_82341,ines/ines_gpib,nec7210/nec7210,sys/gpib_common,tms9914/tms9914,tnt4882/tnt4882%{?with_drivers_isa:,pc2/pc2_gpib}%{?with_drivers_usb:,agilent_82357a/agilent_82357a,lpvo_usb_gpib/lpvo_usb_gpib,ni_usb/ni_usb_gpib} -d kernel/gpib\
247 cd ../..\
248 %{nil}
249
250 %define install_kernel_pkg()\
251 %{nil}
252
253 %{?with_kernel:%{expand:%create_kernel_packages}}
254
255 %prep
256 %setup -q -n %{pname}-%{version}
257 %patch0 -p1
258 %patch1 -p1
259 %patch2 -p1
260 %patch3 -p1
261 %patch4 -p1
262 %patch5 -p1
263 %patch6 -p1
264 %patch7 -p1
265 %patch8 -p1
266
267 # disable modules build by default, just install userspace header
268 echo 'SUBDIRS = gpib/include' > drivers/Makefile.am
269
270 # need to inject -I options before $(LINUXINCLUDE), the simplest way is to override CC
271 for f in drivers/gpib/*/Makefile ; do
272 echo 'override CC += $(EARLYCPPFLAGS)' >> $f
273 done
274
275 %build
276 %{__libtoolize}
277 %{__aclocal} -I m4
278 %{__autoconf}
279 %{__autoheader}
280 %{__automake}
281 %if %{with guile}
282 CPPFLAGS="%{rpmcppflags} -I/usr/include/guile/2.0"
283 %endif
284 %configure \
285         %{?with_drivers_isa:--enable-isa} \
286         %{?with_drivers_pcmcia:--enable-pcmcia} \
287         %{!?with_docs:--disable-documentation} \
288         %{!?with_guile:--disable-guile-binding} \
289         %{!?with_perl:--disable-perl-binding} \
290         %{!?with_php:--disable-php-binding} \
291         %{!?with_python:--disable-python-binding} \
292         %{?with_static_libs:--enable-static} \
293         %{!?with_tcl:--disable-tcl-binding} \
294         --with-linux-srcdir=%{_kernelsrcdir}
295
296 %if %{with userspace}
297 %{__make}
298 %endif
299
300 %if %{with kernel}
301 %{expand:%build_kernel_packages}
302 %endif
303
304 %install
305 rm -rf $RPM_BUILD_ROOT
306 install -d $RPM_BUILD_ROOT%{_examplesdir}
307
308 %if %{with kernel}
309 %{expand:%install_kernel_packages}
310 cp -a drivers/gpib/installed/* $RPM_BUILD_ROOT
311 %endif
312
313 %if %{with userspace}
314 %{__make} install \
315         DESTDIR=$RPM_BUILD_ROOT \
316         HOTPLUG_USB_CONF_DIR=/lib/udev \
317         UDEV_RULES_DIR=/lib/udev/rules.d \
318         USB_FIRMWARE_DIR=/lib/firmware
319
320 %if %{with hotplug}
321 # use udev paths as base and legacy hotplug as addon (not the opposite)
322 install -d $RPM_BUILD_ROOT/etc/hotplug/usb
323 %{__mv} $RPM_BUILD_ROOT/lib/udev/*.usermap $RPM_BUILD_ROOT/etc/hotplug/usb
324 ln -snf /lib/udev/agilent_82357a $RPM_BUILD_ROOT/etc/hotplug/usb/agilent_82357a
325 ln -snf /lib/udev/ni_usb_gpib $RPM_BUILD_ROOT/etc/hotplug/usb/ni_usb_gpib
326 %else
327 %{__rm} $RPM_BUILD_ROOT/lib/udev/*.usermap
328 %endif
329
330 # obsoleted by pkg-config
331 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib.la
332
333 %if %{with guile}
334 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.la
335 %if %{with static_libs}
336 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib-guile.a
337 %endif
338 %endif
339
340 %if %{with perl}
341 %{__make} -C language/perl pure_install \
342         DESTDIR=$RPM_BUILD_ROOT
343
344 cp -pr language/perl/examples $RPM_BUILD_ROOT%{_examplesdir}/perl-gpib-%{version}
345
346 %{__rm} -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/LinuxGpib/.packlist
347 %endif
348
349 %if %{with php}
350 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
351 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/gpib.ini
352 ; Enable gpib extension module
353 extension=gpib_php.so
354 EOF
355
356 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.la
357 %if %{with static_libs}
358 %{__rm} $RPM_BUILD_ROOT%{php_extensiondir}/gpib_php.a
359 %endif
360 %endif
361
362 %if %{with python}
363 %py_postclean
364 %endif
365
366 %if %{with tcl}
367 cp -pr language/tcl/examples $RPM_BUILD_ROOT%{_examplesdir}/tcl-gpib-%{version}
368
369 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.la
370 %if %{with static_libs}
371 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libgpib_tcl.a
372 %endif
373 %endif
374
375 %if %{with docs}
376 # packaged as %doc
377 %{__rm} -r $RPM_BUILD_ROOT%{_datadir}/linux-gpib/html
378 %endif
379 %endif
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %post   libs -p /sbin/ldconfig
385 %postun libs -p /sbin/ldconfig
386
387 %post   -n guile-gpib -p /sbin/ldconfig
388 %postun -n guile-gpib -p /sbin/ldconfig
389
390 %post   -n tcl-gpib -p /sbin/ldconfig
391 %postun -n tcl-gpib -p /sbin/ldconfig
392
393 %post   -n %{php_name}-gpib
394 %php_webserver_restart
395
396 %postun -n %{php_name}-gpib
397 if [ "$1" = 0 ]; then
398         %php_webserver_restart
399 fi
400
401 %if %{with userspace}
402 %files
403 %defattr(644,root,root,755)
404 %attr(755,root,root) %{_bindir}/ibterm
405 %attr(755,root,root) %{_bindir}/ibtest
406 %attr(755,root,root) %{_sbindir}/gpib_config
407 /lib/udev/rules.d/99-agilent_82357a.rules
408 /lib/udev/rules.d/99-gpib-generic.rules
409 /lib/udev/rules.d/99-ni_usb_gpib.rules
410 %attr(755,root,root) /lib/udev/agilent_82357a
411 %attr(755,root,root) /lib/udev/ni_usb_gpib
412
413 %if %{with hotplug}
414 %files hotplug
415 %defattr(644,root,root,755)
416 %attr(755,root,root) /etc/hotplug/usb/agilent_82357a
417 %attr(755,root,root) /etc/hotplug/usb/ni_usb_gpib
418 /etc/hotplug/usb/agilent_82357a.usermap
419 /etc/hotplug/usb/ni_usb_gpib.usermap
420 %endif
421
422 %files libs
423 %defattr(644,root,root,755)
424 %doc AUTHORS ChangeLog README README.HAMEG README.hp82335 TODO
425 %attr(755,root,root) %{_libdir}/libgpib.so.*.*.*
426 %attr(755,root,root) %ghost %{_libdir}/libgpib.so.0
427
428 %files devel
429 %defattr(644,root,root,755)
430 %attr(755,root,root) %{_libdir}/libgpib.so
431 %{_includedir}/gpib
432 %{_pkgconfigdir}/libgpib.pc
433
434 %if %{with static_libs}
435 %files static
436 %defattr(644,root,root,755)
437 %{_libdir}/libgpib.a
438 %endif
439
440 %if %{with guile}
441 %files -n guile-gpib
442 %defattr(644,root,root,755)
443 %attr(755,root,root) %{_libdir}/libgpib-guile-%{version}.so
444 %attr(755,root,root) %{_libdir}/libgpib-guile.so
445 %endif
446
447 %if %{with perl}
448 %files -n perl-gpib
449 %defattr(644,root,root,755)
450 %doc language/perl/{Changes,README}
451 %{perl_vendorarch}/LinuxGpib.pm
452 %dir %{perl_vendorarch}/auto/LinuxGpib
453 %attr(755,root,root) %{perl_vendorarch}/auto/LinuxGpib/LinuxGpib.so
454 %{perl_vendorarch}/auto/LinuxGpib/autosplit.ix
455 %{_mandir}/man3/LinuxGpib.3pm*
456 %{_examplesdir}/perl-gpib-%{version}
457 %endif
458
459 %if %{with php}
460 %files -n %{php_name}-gpib
461 %defattr(644,root,root,755)
462 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/gpib.ini
463 %attr(755,root,root) %{php_extensiondir}/gpib_php-%{version}.so
464 %attr(755,root,root) %{php_extensiondir}/gpib_php.so
465 %endif
466
467 %if %{with python}
468 %files -n python-gpib
469 %defattr(644,root,root,755)
470 %doc language/python/README
471 %attr(755,root,root) %{py_sitedir}/gpib.so
472 %{py_sitedir}/Gpib.py[co]
473 %{py_sitedir}/gpib-1.0-py*.egg-info
474 %endif
475
476 %if %{with tcl}
477 %files -n tcl-gpib
478 %defattr(644,root,root,755)
479 %doc language/tcl/README
480 %attr(755,root,root) %{_libdir}/libgpib_tcl-%{version}.so
481 %attr(755,root,root) %{_libdir}/libgpib_tcl.so
482 %{_examplesdir}/tcl-gpib-%{version}
483 %endif
484
485 %if %{with docs}
486 %files doc
487 %defattr(644,root,root,755)
488 %doc doc/doc_html/*
489 %endif
490 %endif
This page took 0.052583 seconds and 2 git commands to generate.