]> git.pld-linux.org Git - packages/lin_tape.git/commitdiff
- initial commit auto/th/lin_tape-1.74.0-1
authorJan Rękorajski <baggins@pld-linux.org>
Sat, 29 Sep 2012 12:00:43 +0000 (14:00 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Sat, 29 Sep 2012 12:00:43 +0000 (14:00 +0200)
lin_tape.spec [new file with mode: 0644]
use-module-dir.patch [new file with mode: 0644]

diff --git a/lin_tape.spec b/lin_tape.spec
new file mode 100644 (file)
index 0000000..f4988b0
--- /dev/null
@@ -0,0 +1,85 @@
+#
+# Conditional build:
+%bcond_without dist_kernel     # allow non-distribution kernel
+%bcond_with    verbose         # verbose build (V=1)
+#
+%define                rel     1
+%define                pname   lin_tape
+Summary:       IBM Tape SCSI Device Driver for Linux
+Name:          %{pname}%{_alt_kernel}
+Version:       1.74.0
+Release:       %{rel}
+License:       GPL v2/LGPL
+Group:         Base/Kernel
+Source0:       %{pname}-%{version}.tgz
+# Source0-md5: 675822326c2b12390b5164a4e2b14aec
+Patch0:                use-module-dir.patch
+# System Storage, Tape systems, Tape drivers and software, Tape device drivers (Linux)
+URL:           http://www.ibm.com/support/fixcentral/
+%{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
+BuildRequires: rpmbuild(macros) >= 1.379
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
+
+%description
+The IBM Tape Device Driver, lin_tape, product is a device driver that
+provides attachment for the IBM TotalStorage and System Storage tape
+devices to Linux compatible platforms.
+
+%package -n kernel%{_alt_kernel}-scsi-lin_tape
+Summary:       IBM Tape SCSI Device Driver for Linux
+Release:       %{rel}@%{_kernel_ver_str}
+Group:         Base/Kernel
+Requires(post,postun): /sbin/depmod
+%if %{with dist_kernel}
+%requires_releq_kernel
+Requires(postun):      %releq_kernel
+%endif
+
+%description -n kernel%{_alt_kernel}-scsi-lin_tape
+The IBM Tape Device Driver, lin_tape, product is a device driver that
+provides attachment for the IBM TotalStorage and System Storage tape
+devices to Linux compatible platforms.
+
+%prep
+%setup -q -n %{pname}-%{version}
+%patch0 -p1
+%ifarch %ix86 ia64
+proc="Intel"
+%endif
+%ifarch %x8664
+proc="AMD"
+%endif
+%ifarch ppc ppc64 powerpc powerpc64
+proc="pSeries"
+%endif
+%ifarch s390 s390x
+proc="zSeries"
+%endif
+
+%{__cp} -af lin_tape_359X_${proc}.ReadMe lin_tape_359X.ReadMe
+%{__cp} -af lin_tape_Ultrium_${proc}.ReadMe lin_tape_Ultrium.ReadMe
+
+%{__mv} Makefile Makefile.IBM
+%{__cp} -af Makefile.GPL Makefile
+
+%build
+%build_kernel_modules -m lin_tape
+
+%install
+rm -rf $RPM_BUILD_ROOT
+
+%install_kernel_modules -m lin_tape -d kernel/drivers/scsi
+
+%clean
+rm -rf $RPM_BUILD_ROOT
+
+%post  -n kernel%{_alt_kernel}-scsi-lin_tape
+%depmod %{_kernel_ver}
+
+%postun        -n kernel%{_alt_kernel}-scsi-lin_tape
+%depmod %{_kernel_ver}
+
+%files -n kernel%{_alt_kernel}-scsi-lin_tape
+%defattr(644,root,root,755)
+%doc lin_tape.fixlist lin_tape_Ultrium.ReadMe lin_tape_359X.ReadMe
+/lib/modules/%{_kernel_ver}/kernel/drivers/scsi/lin_tape.ko*
diff --git a/use-module-dir.patch b/use-module-dir.patch
new file mode 100644 (file)
index 0000000..938b18b
--- /dev/null
@@ -0,0 +1,33 @@
+--- lin_tape-1.74.0/Makefile~  2012-08-21 19:32:26.000000000 +0200
++++ lin_tape-1.74.0/Makefile   2012-09-29 13:26:24.816711524 +0200
+@@ -5,7 +5,7 @@
+ #include $(PWD)/Kbuild
+ else
+-VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' lin_tape_tape.h)
++VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' $(M)/lin_tape_tape.h)
+ endif
+ obj-m := lin_tape.o
+--- lin_tape-1.74.0/Makefile.GPL~      2012-08-21 19:32:26.000000000 +0200
++++ lin_tape-1.74.0/Makefile.GPL       2012-09-29 13:26:42.136710913 +0200
+@@ -5,7 +5,7 @@
+ #include $(PWD)/Kbuild
+ else
+-VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' lin_tape_tape.h)
++VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' $(M)/lin_tape_tape.h)
+ endif
+ obj-m := lin_tape.o
+--- lin_tape-1.74.0/Makefile.supported~        2012-08-21 19:32:27.000000000 +0200
++++ lin_tape-1.74.0/Makefile.supported 2012-09-29 13:26:59.573376965 +0200
+@@ -5,7 +5,7 @@
+ #include $(PWD)/Kbuild
+ else
+-VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' lin_tape_tape.h)
++VERSIONRELEASE := $(shell sed --regexp-extended -e '{/\#define LIN_TAPE_VERSION/ s/.*"([0-9.]*)-?([A-Za-z0-9.]*)"/\1 \2/p;d}' $(M)/lin_tape_tape.h)
+ endif
+ obj-m := lin_tape.o
This page took 0.03773 seconds and 4 git commands to generate.