]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
- build fixes
[packages/lilypond.git] / lilypond.spec
1 # TODO:
2 #       - probably gui bcond is meaningless
3 #
4 # Conditional build:
5 %bcond_with     gui     # enable experimental GUI
6 %bcond_with     docs    # build docs
7 #
8 Summary:        Music typesetter
9 Summary(pl.UTF-8):      Program do składania nut
10 Name:           lilypond
11 Version:        2.12.2
12 Release:        1
13 License:        GPL
14 Group:          Applications/Sound
15 Source0:        http://lilypond.org/download/v2.12/%{name}-%{version}.tar.gz
16 # Source0-md5:  681dfbecf8a3710d1400cf9488be716b
17 Patch0:         %{name}-info.patch
18 Patch1:         %{name}-sh.patch
19 Patch3:         %{name}-afm.patch
20 Patch4:         %{name}-aclocal.patch
21 Patch5:         %{name}-bad_cast.patch
22 URL:            http://www.lilypond.org/
23 %{?with_docs:BuildRequires:     ImageMagick}
24 %{?with_docs:BuildRequires:     ImageMagick-coder-png}
25 BuildRequires:  automake
26 BuildRequires:  bison >= 1.29
27 BuildRequires:  flex >= 2.5.4a
28 BuildRequires:  fontconfig
29 BuildRequires:  fontconfig-devel >= 1:2.2.0
30 BuildRequires:  fontforge >= 20060125
31 BuildRequires:  fonts-Type1-urw
32 BuildRequires:  gettext-devel >= 0.17
33 BuildRequires:  ghostscript >= 8.15
34 %{?with_docs:BuildRequires:     ghostscript >= 8.60}
35 BuildRequires:  ghostscript-fonts-std
36 %{?with_gui:BuildRequires:      gtk+2-devel >= 2:2.4.0}
37 BuildRequires:  guile-devel >= 5:1.8.2
38 BuildRequires:  kpathsea-devel
39 BuildRequires:  libltdl-devel
40 BuildRequires:  libstdc++-devel >= 5:3.4
41 BuildRequires:  mftrace >= 1.1.19
42 %{?with_docs:BuildRequires:     netpbm-progs}
43 BuildRequires:  pango-devel >= 1.12.0
44 BuildRequires:  perl-base
45 BuildRequires:  pkgconfig >= 1:0.9.0
46 BuildRequires:  python-devel >= 2.4
47 %{?with_docs:BuildRequires:     rsync}
48 BuildRequires:  texlive-dvips
49 BuildRequires:  texlive-fonts-cm
50 BuildRequires:  texlive-fonts-cmextra
51 BuildRequires:  texlive-fonts-jknappen
52 %{?with_docs:BuildRequires:     texlive-latex-bibtex}
53 BuildRequires:  texlive-metapost
54 BuildRequires:  texinfo >= 4.11
55 %{?with_docs:BuildRequires:     texinfo-texi2dvi}
56 BuildConflicts: lilypond < 1.6.0
57 Requires:       ghostscript >= 8.15
58 Requires:       guile >= 5:1.8.2
59 Requires:       python >= 2.4
60 Requires:       texlive-latex
61 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
62
63 %define         texmfdir        %{_datadir}/texmf
64 %define         texfontsdir     %{texmfdir}/fonts
65
66 %description
67 LilyPond is a music typesetter. It produces beautiful sheet music
68 using a high level description file as input. It excels at typesetting
69 classical music, but you can also print pop-songs. With LilyPond we
70 hope to make music publication software available to anyone on the
71 internet.
72
73 %description -l pl.UTF-8
74 LilyPond jest programem do składu muzycznego. Produkuje piękne
75 partytury używając języka wysokiego poziomu jako wejście. Służy przede
76 wszystkim do składania nut muzyki klasycznej, ale można drukować także
77 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
78 wszystkim oprogramowania do publikacji muzycznych.
79
80 %package -n emacs-lilypond-mode-pkg
81 Summary:        LilyPond mode for Emacs
82 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
83 Group:          Applications/Editors/Emacs
84 Requires:       %{name} = %{version}-%{release}
85 Requires:       emacs
86
87 %description -n emacs-lilypond-mode-pkg
88 LilyPond mode for Emacs.
89
90 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
91 Tryb edycji plików LilyPond dla Emacsa.
92
93 %package -n vim-syntax-lilypond
94 Summary:        LilyPond files support for Vim
95 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
96 Group:          Applications/Editors/Vim
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       vim-rt >= 4:6.4.001-2
99
100 %description -n vim-syntax-lilypond
101 LilyPond files support for Vim.
102
103 %description -n vim-syntax-lilypond -l pl.UTF-8
104 Obsługa plików LilyPonda dla Vima.
105
106 %prep
107 %setup -q
108 %patch0 -p1
109 %patch1 -p1
110 %patch3 -p1
111 %patch4 -p1
112 %patch5 -p1
113
114 %build
115 cp -f /usr/share/automake/config.* stepmake/bin
116 %{__autoconf}
117 %configure \
118         %{?debug:--disable-optimising} \
119         %{?with_gui:--enable-gui}
120 %{__make} -j1
121 %{?with_docs:%{__make} -j1 web}
122
123 %install
124 rm -rf $RPM_BUILD_ROOT
125 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm,type1}}
126
127 %{__make} install \
128         DESTDIR=$RPM_BUILD_ROOT
129 %if %{with docs}
130 %{__make} -j1 web-install \
131         DESTDIR=$RPM_BUILD_ROOT
132 %endif
133 cp -aL out/share/lilypond/current/fonts/tfm \
134         $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
135
136 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
137
138 # ?
139 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
140         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
141 # for latex and dvips
142 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
143         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
144 # both for lilypond and dvips
145 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
146         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
147 ln -sf %{_datadir}/lilypond/%{version}/ps \
148         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
149 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips
150
151 # vim syntax/etc. files
152 install -d $RPM_BUILD_ROOT%{_datadir}/vim
153 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
154         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
155
156 # lilypond/stepmake build system - not needed at runtime
157 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
158
159 %find_lang %{name}
160
161 %clean
162 rm -rf $RPM_BUILD_ROOT
163
164 %pre
165 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
166
167 %post
168 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
169 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
170 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
171
172 %postun
173 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
174 [ ! -x /usr/bin/texhash ] || /usr/bin/texhash 1>&2
175 [ ! -x /usr/bin/scrollkeeper-update ] || /usr/bin/scrollkeeper-update
176
177 %files -f %{name}.lang
178 %defattr(644,root,root,755)
179 %doc AUTHORS.txt DEDICATION NEWS.txt README.txt THANKS
180 %attr(755,root,root) %{_bindir}/abc2ly
181 %attr(755,root,root) %{_bindir}/convert-ly
182 %attr(755,root,root) %{_bindir}/etf2ly
183 %attr(755,root,root) %{_bindir}/lilymidi
184 %attr(755,root,root) %{_bindir}/lilypond
185 %attr(755,root,root) %{_bindir}/lilypond-book
186 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
187 %attr(755,root,root) %{_bindir}/lilysong
188 %attr(755,root,root) %{_bindir}/midi2ly
189 %attr(755,root,root) %{_bindir}/musicxml2ly
190 %dir %{_libdir}/lilypond
191 %dir %{_libdir}/lilypond/%{version}
192 %dir %{_libdir}/lilypond/%{version}/python
193 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
194 %dir %{_datadir}/lilypond
195 %dir %{_datadir}/lilypond/%{version}
196 %{_datadir}/lilypond/%{version}/fonts
197 %{_datadir}/lilypond/%{version}/ly
198 %{_datadir}/lilypond/%{version}/ps
199 %dir %{_datadir}/lilypond/%{version}/python
200 %{_datadir}/lilypond/%{version}/python/*.py
201 %{_datadir}/lilypond/%{version}/python/*.pyc
202 %{_datadir}/lilypond/%{version}/scm
203 %{_infodir}/*.info*
204 %{_mandir}/man1/*
205
206 %{texfontsdir}/source/lilypond
207 %{texfontsdir}/tfm/lilypond
208 %{texfontsdir}/type1/lilypond
209 %{texmfdir}/dvips/lilypond
210 %{texmfdir}/tex/lilypond
211
212 %{_datadir}/omf/lilypond
213 %{?with_docs:/usr/share/doc/lilypond}
214
215 %files -n emacs-lilypond-mode-pkg
216 %defattr(644,root,root,755)
217 %{_datadir}/emacs/site-lisp/*.el
218
219 %files -n vim-syntax-lilypond
220 %defattr(644,root,root,755)
221 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
222 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
223 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
224 %{_datadir}/vim/vimfiles/indent/lilypond.vim
225 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.093177 seconds and 4 git commands to generate.