]> git.pld-linux.org Git - packages/lilypond.git/blob - lilypond.spec
070a38ff4de05b2c84b23e0ec501a7da17ac6d8d
[packages/lilypond.git] / lilypond.spec
1 #
2 # Conditional build:
3 %bcond_with     guile2  # 'highly experimental' guile2 support
4 %bcond_without  doc     # build docs
5 #
6 Summary:        Music typesetter
7 Summary(pl.UTF-8):      Program do składania nut
8 Name:           lilypond
9 Version:        2.19.33
10 Release:        0.1
11 License:        GPL
12 Group:          Applications/Sound
13 Source0:        http://download.linuxaudio.org/lilypond/sources/v2.19/%{name}-%{version}.tar.gz
14 # Source0-md5:  942ac963423b08903d0df21fb22fbe70
15 Patch0:         %{name}-info.patch
16 Patch1:         %{name}-sh.patch
17 Patch2:         %{name}-aclocal.patch
18 URL:            http://www.lilypond.org/
19 BuildRequires:  autoconf
20 BuildRequires:  automake
21 BuildRequires:  bison >= 1.29
22 BuildRequires:  flex >= 2.5.4a
23 BuildRequires:  fontconfig
24 BuildRequires:  fontconfig-devel >= 1:2.4.0
25 BuildRequires:  fontforge >= 20110222
26 BuildRequires:  fonts-TTF-DejaVu
27 BuildRequires:  fonts-Type1-urw
28 BuildRequires:  freetype >= 1:2.1.10
29 BuildRequires:  gettext-tools >= 0.17
30 BuildRequires:  ghostscript-fonts-std
31 %if %{with guile2}
32 BuildRequires:  guile-devel >= 5:2.0.0
33 %else
34 BuildRequires:  guile1-devel
35 %endif
36 BuildRequires:  kpathsea-devel
37 BuildRequires:  libstdc++-devel >= 5:3.4
38 BuildRequires:  pango-devel >= 1.12.0
39 BuildRequires:  perl-base
40 BuildRequires:  pkgconfig >= 1:0.9.0
41 BuildRequires:  python-devel >= 1:2.4
42 BuildRequires:  python-modules
43 BuildRequires:  rpm-pythonprov
44 BuildRequires:  t1utils
45 BuildRequires:  texinfo >= 4.11
46 BuildRequires:  texlive-fonts-other
47 BuildRequires:  texlive-metapost
48 %if %{with doc}
49 BuildRequires:  ImageMagick
50 BuildRequires:  ImageMagick-coder-png
51 BuildRequires:  dblatex
52 BuildRequires:  ghostscript >= 8.60
53 BuildRequires:  guile1 >= 1.8.0
54 BuildRequires:  netpbm-progs
55 BuildRequires:  rsync
56 BuildRequires:  texi2html
57 BuildRequires:  texinfo
58 BuildRequires:  texinfo-texi2dvi
59 BuildRequires:  texlive
60 BuildRequires:  texlive-fonts-lh
61 BuildRequires:  texlive-format-pdflatex
62 BuildRequires:  texlive-latex-bibtex
63 BuildRequires:  zip
64 %endif
65 BuildConflicts: lilypond < 1.6.0
66 Requires:       fonts-TTF-DejaVu
67 Requires:       ghostscript >= 8.60
68 Requires:       python-modules >= 1:2.4
69 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
70
71 %define         texmfdir        %{_datadir}/texmf
72 %define         texmfdistdir    %{texmfdir}-dist
73 %if "%{pld_release}" != "th"
74 %define         texfontsdir     %{texmfdir}/fonts
75 %else
76 %define         texfontsdir     %{texmfdistdir}/fonts
77 %endif
78
79 %description
80 LilyPond is a music typesetter. It produces beautiful sheet music
81 using a high level description file as input. It excels at typesetting
82 classical music, but you can also print pop-songs. With LilyPond we
83 hope to make music publication software available to anyone on the
84 internet.
85
86 %description -l pl.UTF-8
87 LilyPond jest programem do składu muzycznego. Produkuje piękne
88 partytury używając języka wysokiego poziomu jako wejście. Służy przede
89 wszystkim do składania nut muzyki klasycznej, ale można drukować także
90 piosenki pop. Autorzy udostępniają LilyPond z nadzieją dostarczenia
91 wszystkim oprogramowania do publikacji muzycznych.
92
93 %package -n emacs-lilypond-mode-pkg
94 Summary:        LilyPond mode for Emacs
95 Summary(pl.UTF-8):      Tryb edycji plików LilyPond dla Emacsa
96 Group:          Applications/Editors/Emacs
97 Requires:       %{name} = %{version}-%{release}
98 Requires:       emacs
99
100 %description -n emacs-lilypond-mode-pkg
101 LilyPond mode for Emacs.
102
103 %description -n emacs-lilypond-mode-pkg -l pl.UTF-8
104 Tryb edycji plików LilyPond dla Emacsa.
105
106 %package -n vim-syntax-lilypond
107 Summary:        LilyPond files support for Vim
108 Summary(pl.UTF-8):      Obsługa plików LilyPonda dla Vima
109 Group:          Applications/Editors/Vim
110 Requires:       %{name} = %{version}-%{release}
111 Requires:       vim-rt >= 4:6.4.001-2
112
113 %description -n vim-syntax-lilypond
114 LilyPond files support for Vim.
115
116 %description -n vim-syntax-lilypond -l pl.UTF-8
117 Obsługa plików LilyPonda dla Vima.
118
119 %prep
120 %setup -q
121 #%%patch0 -p1
122 %patch1 -p1
123 %patch2 -p1
124
125 %build
126 %{__autoconf}
127 %configure \
128         %{?debug:--disable-optimising} \
129         %{__enable_disable guile2} \
130         --with-texgyre-dir=/usr/share/texmf-dist/fonts/opentype/public/tex-gyre/ \
131         %{__enable_disable doc documentation}
132 %{__make} -j1
133
134 %install
135 rm -rf $RPM_BUILD_ROOT
136 install -d $RPM_BUILD_ROOT{%{texmfdir}/{dvips,tex},%{texfontsdir}/{source,tfm,type1}}
137
138 %{__make} install \
139         DESTDIR=$RPM_BUILD_ROOT
140
141 %if %{with doc}
142 %{__make} -C Documentation omf-local-install \
143         DESTDIR=$RPM_BUILD_ROOT \
144         local_package_omfdir=%{_datadir}/omf/lilypond
145 %endif
146
147 cp -aL out/share/lilypond/current/fonts/tfm \
148         $RPM_BUILD_ROOT%{texfontsdir}/tfm/lilypond
149
150 find $RPM_BUILD_ROOT -name fonts.cache-1 | xargs rm -f
151
152 # ?
153 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/fonts/source \
154         $RPM_BUILD_ROOT%{texfontsdir}/source/lilypond
155 # for latex and dvips
156 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/tex \
157         $RPM_BUILD_ROOT%{texmfdir}/tex/lilypond
158 # both for lilypond and dvips
159 ln -sf %{_datadir}/lilypond/%{version}/fonts/type1 \
160         $RPM_BUILD_ROOT%{texfontsdir}/type1/lilypond
161 ln -sf %{_datadir}/lilypond/%{version}/ps \
162         $RPM_BUILD_ROOT%{texmfdir}/dvips/lilypond
163 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/dvips
164
165 # vim syntax/etc. files
166 install -d $RPM_BUILD_ROOT%{_datadir}/vim
167 mv -f $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/vim \
168         $RPM_BUILD_ROOT%{_datadir}/vim/vimfiles
169
170 # lilypond/stepmake build system - not needed at runtime
171 rm -rf $RPM_BUILD_ROOT%{_datadir}/lilypond/%{version}/make
172
173 %find_lang %{name}
174
175 %clean
176 rm -rf $RPM_BUILD_ROOT
177
178 %pre
179 test -h %{texmfdir}/dvips/lilypond || rm -rf %{texmfdir}/dvips/lilypond
180
181 %post
182 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
183 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
184 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
185
186 %postun
187 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
188 [ ! -x %{_bindir}/texhash ] || %{_bindir}/texhash 1>&2
189 [ ! -x %{_bindir}/scrollkeeper-update ] || %{_bindir}/scrollkeeper-update
190
191 %files -f %{name}.lang
192 %defattr(644,root,root,755)
193 %doc AUTHORS.txt DEDICATION NEWS.txt README.txt ROADMAP
194 %attr(755,root,root) %{_bindir}/abc2ly
195 %attr(755,root,root) %{_bindir}/convert-ly
196 %attr(755,root,root) %{_bindir}/etf2ly
197 %attr(755,root,root) %{_bindir}/lilymidi
198 %attr(755,root,root) %{_bindir}/lilypond
199 %attr(755,root,root) %{_bindir}/lilypond-book
200 %attr(755,root,root) %{_bindir}/lilypond-invoke-editor
201 %attr(755,root,root) %{_bindir}/lilysong
202 %attr(755,root,root) %{_bindir}/midi2ly
203 %attr(755,root,root) %{_bindir}/musicxml2ly
204 %dir %{_libdir}/lilypond
205 %dir %{_libdir}/lilypond/%{version}
206 %dir %{_libdir}/lilypond/%{version}/python
207 %attr(755,root,root) %{_libdir}/lilypond/%{version}/python/midi.so
208 %dir %{_datadir}/lilypond
209 %dir %{_datadir}/lilypond/%{version}
210 %{_datadir}/lilypond/%{version}/fonts
211 %{_datadir}/lilypond/%{version}/ly
212 %{_datadir}/lilypond/%{version}/ps
213 %dir %{_datadir}/lilypond/%{version}/python
214 %{_datadir}/lilypond/%{version}/python/*.py
215 %{_datadir}/lilypond/%{version}/python/*.pyc
216 %{_datadir}/lilypond/%{version}/scm
217
218 %{texfontsdir}/source/lilypond
219 %{texfontsdir}/tfm/lilypond
220 %{texfontsdir}/type1/lilypond
221 %{texmfdir}/dvips/lilypond
222 %{texmfdir}/tex/lilypond
223
224 %if %{with doc}
225 %{_infodir}/*.info*
226 %{_mandir}/man1/*
227 %{_datadir}/omf/lilypond
228 %endif
229
230 %files -n emacs-lilypond-mode-pkg
231 %defattr(644,root,root,755)
232 %{_datadir}/emacs/site-lisp/*.el
233
234 %files -n vim-syntax-lilypond
235 %defattr(644,root,root,755)
236 %{_datadir}/vim/vimfiles/compiler/lilypond.vim
237 %{_datadir}/vim/vimfiles/ftdetect/lilypond.vim
238 %{_datadir}/vim/vimfiles/ftplugin/lilypond.vim
239 %{_datadir}/vim/vimfiles/indent/lilypond.vim
240 %{_datadir}/vim/vimfiles/syntax/lilypond*
This page took 0.081027 seconds and 2 git commands to generate.