]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
mod_vhostdb backends are bcond dependant
authorElan Ruusamäe <glen@pld-linux.org>
Sun, 22 Oct 2017 12:12:42 +0000 (15:12 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Sun, 22 Oct 2017 12:12:42 +0000 (15:12 +0300)
lighttpd.spec
mod_vhostdb.conf

index 9ebe6a928cbc71a575f7e6067880efcff4e65eeb..65b70a4b2ef5030d25e21470f62343f2528c36c7 100644 (file)
@@ -1,9 +1,9 @@
-
 # TODO:
 # - provide or autogenerate self signed cert in post, so after installing
 #   lighttpd-ssl server will still work
 # - patch with mod_websocket: https://github.com/Juniper/lighttpd-for-juise
 # - lighttpd-mod_fd_transfer: https://redmine.lighttpd.net/boards/3/topics/4992
 # TODO:
 # - provide or autogenerate self signed cert in post, so after installing
 #   lighttpd-ssl server will still work
 # - patch with mod_websocket: https://github.com/Juniper/lighttpd-for-juise
 # - lighttpd-mod_fd_transfer: https://redmine.lighttpd.net/boards/3/topics/4992
+# - add db specific mod_vhostdb_* - packages
 #
 # Conditional build:
 %bcond_with            tests           # build with tests
 #
 # Conditional build:
 %bcond_with            tests           # build with tests
 %bcond_without ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
 %bcond_without largefile       # largefile support (see notes above)
 %bcond_without ssl             # ssl support
 %bcond_without ipv6            # IPv4-only version (doesn't require IPv6 in kernel)
 %bcond_without largefile       # largefile support (see notes above)
 %bcond_without ssl             # ssl support
-%bcond_without mysql           # mysql support in mod_mysql_vhost
+%bcond_without mysql           # mysql support in mod_mysql_vhost, mod_vhostdb_mysql
 %bcond_without geoip           # GeoIP support
 %bcond_with    krb5            # krb5 support (does not work with heimdal)
 %bcond_without geoip           # GeoIP support
 %bcond_with    krb5            # krb5 support (does not work with heimdal)
-%bcond_without ldap            # ldap support in mod_auth
+%bcond_without ldap            # ldap support in mod_auth, mod_vhostdb_ldap
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
 %bcond_without lua             # LUA support in mod_cml (needs LUA >= 5.1)
 %bcond_with    memcache        # memcached support in mod_cml / mod_trigger_b4_dl
 %bcond_with    gamin           # gamin for reducing number of stat() calls.
@@ -1497,8 +1497,12 @@ fi
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_vhostdb.conf
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb.so
 %defattr(644,root,root,755)
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/conf.d/*mod_vhostdb.conf
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb.so
+%if %{with ldap}
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_ldap.so
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_ldap.so
+%endif
+%if %{with mysql}
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_mysql.so
 %attr(755,root,root) %{pkglibdir}/mod_vhostdb_mysql.so
+%endif
 
 %files mod_webdav
 %defattr(644,root,root,755)
 
 %files mod_webdav
 %defattr(644,root,root,755)
index fc928e14c868d5b9b72c7c1c5d9ac951d95d1125..d5b71729c9aedc362b0d34aff7863291c0425fe2 100644 (file)
@@ -3,5 +3,7 @@
 # Documentation: https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModVhostDB
 
 server.modules += (
 # Documentation: https://redmine.lighttpd.net/projects/lighttpd/wiki/Docs_ModVhostDB
 
 server.modules += (
-       "mod_vhostdb"
+       "mod_vhostdb",
+#      "mod_vhostdb_ldap",
+#      "mod_vhostdb_mysql",
 )
 )
This page took 0.081811 seconds and 4 git commands to generate.