]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
- filter out configure.in and SConstruct
authorElan Ruusamäe <glen@pld-linux.org>
Wed, 16 Jan 2008 15:59:39 +0000 (15:59 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    branch.sh -> 1.2

branch.sh

index 6d345d32dceae291c852de05fe34839a9e24492c..c729aa13e324433bd23f73482bb598d3b0bbbcb8 100644 (file)
--- a/branch.sh
+++ b/branch.sh
@@ -1,5 +1,14 @@
 #!/bin/sh
-svn=svn://svn.lighttpd.net/lighttpd/
+set -e
+svn=svn://svn.lighttpd.net/lighttpd
 tag=lighttpd-1.4.18
 branch=lighttpd-1.4.x
-svn diff --old=$svn/tags/$tag --new=$svn/branches/$branch > lighttpd-branch.diff
+
+old=$svn/tags/$tag
+new=$svn/branches/$branch
+echo "Running diff: $old -> $new"
+LC_ALL=C svn diff --old=$old --new=$new > lighttpd-branch.diff
+
+echo "exclude files which change version"
+filterdiff -x 'configure.in' -x 'SConstruct' lighttpd-branch.diff > lighttpd-branch.diff.tmp
+mv -f lighttpd-branch.diff.tmp lighttpd-branch.diff
This page took 0.110094 seconds and 4 git commands to generate.