]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
fix fastcgi.balance config not accepted auto/th/lighttpd-1.4.49-3
authorElan Ruusamäe <glen@pld-linux.org>
Fri, 20 Apr 2018 12:02:51 +0000 (15:02 +0300)
committerElan Ruusamäe <glen@pld-linux.org>
Fri, 20 Apr 2018 12:02:52 +0000 (15:02 +0300)
fixes: https://redmine.lighttpd.net/issues/2882

bug-2882.patch [new file with mode: 0644]
lighttpd.spec

diff --git a/bug-2882.patch b/bug-2882.patch
new file mode 100644 (file)
index 0000000..2f5d7e3
--- /dev/null
@@ -0,0 +1,34 @@
+From 24886e58e141ff51b5efc3cdc2e8293e54c31037 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Elan=20Ruusam=C3=A4e?= <glen@pld-linux.org>
+Date: Fri, 20 Apr 2018 15:01:19 +0300
+Subject: [PATCH] fcgi: process fastcgi.balance option
+
+refs: https://redmine.lighttpd.net/issues/2882
+---
+ src/mod_fastcgi.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/mod_fastcgi.c b/src/mod_fastcgi.c
+index b442214e..988a2e50 100644
+--- a/src/mod_fastcgi.c
++++ b/src/mod_fastcgi.c
+@@ -463,6 +463,7 @@ static int fcgi_patch_connection(server *srv, connection *con, plugin_data *p) {
+       PATCH(exts_auth);
+       PATCH(exts_resp);
+       PATCH(debug);
++      PATCH(balance);
+       PATCH(ext_mapping);
+       /* skip the first, the global context */
+@@ -483,6 +484,8 @@ static int fcgi_patch_connection(server *srv, connection *con, plugin_data *p) {
+                               PATCH(exts_resp);
+                       } else if (buffer_is_equal_string(du->key, CONST_STR_LEN("fastcgi.debug"))) {
+                               PATCH(debug);
++                      } else if (buffer_is_equal_string(du->key, CONST_STR_LEN("fastcgi.balance"))) {
++                              PATCH(balance);
+                       } else if (buffer_is_equal_string(du->key, CONST_STR_LEN("fastcgi.map-extensions"))) {
+                               PATCH(ext_mapping);
+                       }
+-- 
+2.16.2
+
index 6cc23afaed312c419f1c93316a3aede5e07e9a52..64601442d7d30394b5b98746d5afe63104e64bbf 100644 (file)
@@ -40,7 +40,7 @@ Summary:      Fast and light HTTP server
 Summary(pl.UTF-8):     Szybki i lekki serwer HTTP
 Name:          lighttpd
 Version:       1.4.49
-Release:       2
+Release:       3
 License:       BSD
 Group:         Networking/Daemons/HTTP
 Source0:       https://download.lighttpd.net/lighttpd/releases-1.4.x/%{name}-%{version}.tar.xz
@@ -121,6 +121,7 @@ Patch4:             systemd.patch
 Patch6:                test-port-setup.patch
 Patch7:                env-documentroot.patch
 Patch8:                lighttpd-bug-2876.patch
+Patch9:                bug-2882.patch
 URL:           https://www.lighttpd.net/
 %{?with_geoip:BuildRequires:   GeoIP-devel}
 %{?with_xattr:BuildRequires:   attr-devel}
@@ -956,6 +957,7 @@ Plik monitrc do monitorowania serwera www lighttpd.
 %patch6 -p1
 #%patch7 -p1 probably fixed upstream
 %patch8 -p1
+%patch9 -p1
 
 rm -f src/mod_ssi_exprparser.h # bad patching: should be removed by is emptied instead
 
This page took 0.103304 seconds and 4 git commands to generate.