]> git.pld-linux.org Git - packages/lighttpd.git/commitdiff
- exclude files that were not present in tarball
authorElan Ruusamäe <glen@pld-linux.org>
Thu, 16 Apr 2009 21:52:57 +0000 (21:52 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    branch.sh -> 1.10
    lighttpd-branch.diff -> 1.50

branch.sh
lighttpd-branch.diff

index 402c676a68efbac39fa5204f3bc5e2547f04fcb3..87efcd85b93ed46888dae6c35166b2dad95d2af1 100644 (file)
--- a/branch.sh
+++ b/branch.sh
@@ -7,8 +7,9 @@ branch=lighttpd-1.4.x
 old=$svn/tags/$tag
 new=$svn/branches/$branch
 echo "Running diff: $old -> $new"
-LC_ALL=C svn diff --old=$old --new=$new > lighttpd-branch.diff
+LC_ALL=C svn diff --old=$old --new=$new > lighttpd-branch.diff.tmp
 
 echo "Excluding files which change version or were not in dist tarball"
-filterdiff -x 'configure.in' -x 'SConstruct' -x 'CMakeLists.txt' lighttpd-branch.diff > lighttpd-branch.diff.tmp
-mv -f lighttpd-branch.diff.tmp lighttpd-branch.diff
+filterdiff -x 'configure.in' -x 'SConstruct' -x 'CMakeLists.txt' -x 'src/CMakeLists.txt' -x 'src/config.h.cmake' -x 'src/mod_uploadprogress.c' lighttpd-branch.diff.tmp > lighttpd-branch.diff.tmp2
+mv -f lighttpd-branch.diff.tmp2 lighttpd-branch.diff
+rm -f lighttpd-branch.diff.tmp
index 42747f75569e60d446cfa608d6f1acabea61f293..1e062b638f88e6b8f847d66daa52382872da2ab1 100644 (file)
@@ -1517,16 +1517,6 @@ Index: src/Makefile.am
 +
 Index: src/config.h.cmake
 ===================================================================
---- src/config.h.cmake (.../tags/lighttpd-1.4.22)      (revision 2475)
-+++ src/config.h.cmake (.../branches/lighttpd-1.4.x)   (revision 2475)
-@@ -30,6 +30,7 @@
- #cmakedefine HAVE_PTHREAD_H
- #cmakedefine HAVE_INET_ATON
- #cmakedefine HAVE_IPV6
-+#cmakedefine HAVE_ISSETUGID
- /* XATTR */
- #cmakedefine HAVE_ATTR_ATTRIBUTES_H
 Index: src/mod_expire.c
 ===================================================================
 --- src/mod_expire.c   (.../tags/lighttpd-1.4.22)      (revision 2475)
@@ -1804,61 +1794,6 @@ Index: src/mod_indexfile.c
        p->name        = buffer_init_string("indexfile");
 Index: src/mod_uploadprogress.c
 ===================================================================
---- src/mod_uploadprogress.c   (.../tags/lighttpd-1.4.22)      (revision 2475)
-+++ src/mod_uploadprogress.c   (.../branches/lighttpd-1.4.x)   (revision 2475)
-@@ -51,7 +51,7 @@
-  */
- /* init the plugin data */
--connection_map *connection_map_init() {
-+static connection_map *connection_map_init() {
-       connection_map *cm;
-       cm = calloc(1, sizeof(*cm));
-@@ -59,7 +59,7 @@
-       return cm;
- }
--void connection_map_free(connection_map *cm) {
-+static void connection_map_free(connection_map *cm) {
-       size_t i;
-       for (i = 0; i < cm->size; i++) {
-               connection_map_entry *cme = cm->ptr[i];
-@@ -75,7 +75,7 @@
-       free(cm);
- }
--int connection_map_insert(connection_map *cm, connection *con, buffer *con_id) {
-+static int connection_map_insert(connection_map *cm, connection *con, buffer *con_id) {
-       connection_map_entry *cme;
-       size_t i;
-@@ -108,7 +108,7 @@
-       return 0;
- }
--connection *connection_map_get_connection(connection_map *cm, buffer *con_id) {
-+static connection *connection_map_get_connection(connection_map *cm, buffer *con_id) {
-       size_t i;
-       for (i = 0; i < cm->used; i++) {
-@@ -123,7 +123,7 @@
-       return NULL;
- }
--int connection_map_remove_connection(connection_map *cm, connection *con) {
-+static int connection_map_remove_connection(connection_map *cm, connection *con) {
-       size_t i;
-       for (i = 0; i < cm->used; i++) {
-@@ -418,6 +418,7 @@
- /* this function is called at dlopen() time and inits the callbacks */
-+int mod_uploadprogress_plugin_init(plugin *p);
- int mod_uploadprogress_plugin_init(plugin *p) {
-       p->version     = LIGHTTPD_VERSION_ID;
-       p->name        = buffer_init_string("uploadprogress");
 Index: src/mod_fastcgi.c
 ===================================================================
 --- src/mod_fastcgi.c  (.../tags/lighttpd-1.4.22)      (revision 2475)
@@ -2038,89 +1973,6 @@ Index: src/mod_fastcgi.c
        p->name         = buffer_init_string("fastcgi");
 Index: src/CMakeLists.txt
 ===================================================================
---- src/CMakeLists.txt (.../tags/lighttpd-1.4.22)      (revision 2475)
-+++ src/CMakeLists.txt (.../branches/lighttpd-1.4.x)   (revision 2475)
-@@ -29,6 +29,18 @@
- OPTION(WITH_GDBM "gdbm storage for mod_trigger_b4_dl [default: off]")
- OPTION(WITH_MEMCACHE "memcached storage for mod_trigger_b4_dl [default: off]")
-+IF(CMAKE_COMPILER_IS_GNUCC)
-+      OPTION(BUILD_EXTRA_WARNINGS "extra warnings")
-+
-+      IF(BUILD_EXTRA_WARNINGS)
-+              SET(WARN_FLAGS "-g -O2 -g2 -Wall -Wmissing-declarations -Wdeclaration-after-statement -Wno-pointer-sign -Wcast-align -Winline -Wsign-compare -Wnested-externs -Wpointer-arith -Wformat-security")
-+              # -Wl,--as-needed
-+              # -Werror -Wbad-function-cast -Wmissing-prototypes
-+      ELSE(BUILD_EXTRA_WARNINGS)
-+              SET(WARN_FLAGS "")
-+      ENDIF(BUILD_EXTRA_WARNINGS)
-+ENDIF(CMAKE_COMPILER_IS_GNUCC)
-+
- OPTION(BUILD_STATIC "build a static lighttpd with all modules added")
- IF(BUILD_STATIC)
-@@ -133,6 +145,7 @@
-               struct sockaddr_in6 s; struct in6_addr t=in6addr_any; int i=AF_INET6; s; t.s6_addr[0] = 0;
-               return 0;
-       }" HAVE_IPV6)
-+CHECK_FUNCTION_EXISTS(issetugid HAVE_ISSETUGID)
- ## refactor me
- MACRO(XCONFIG _package _include_DIR _link_DIR _link_FLAGS _cflags)
-@@ -161,7 +174,9 @@
- IF(WITH_XATTR)
-   CHECK_INCLUDE_FILES(attr/attributes.h HAVE_ATTR_ATTRIBUTES_H)
--  CHECK_LIBRARY_EXISTS(attr attr_get "" HAVE_XATTR)
-+  IF(HAVE_ATTR_ATTRIBUTES_H)
-+    CHECK_LIBRARY_EXISTS(attr attr_get "" HAVE_XATTR)
-+  ENDIF(HAVE_ATTR_ATTRIBUTES_H)
- ENDIF(WITH_XATTR)
- IF(WITH_MYSQL)
-@@ -421,8 +436,9 @@
- SET(L_INSTALL_TARGETS)
--ADD_EXECUTABLE(spawn-fcgi spawn-fcgi.c)
--SET(L_INSTALL_TARGETS ${L_INSTALL_TARGETS} spawn-fcgi)
-+ADD_EXECUTABLE(lighttpd-angel lighttpd-angel.c)
-+SET(L_INSTALL_TARGETS ${L_INSTALL_TARGETS} lighttpd-angel)
-+ADD_TARGET_PROPERTIES(lighttpd-angel COMPILE_FLAGS "-DSBIN_DIR=\\\\\"${CMAKE_INSTALL_PREFIX}/${SBINDIR}\\\\\"")
- ADD_EXECUTABLE(lighttpd
-       server.c
-@@ -468,7 +484,7 @@
- ADD_AND_INSTALL_LIBRARY(mod_staticfile mod_staticfile.c)
- ADD_AND_INSTALL_LIBRARY(mod_status mod_status.c)
- ADD_AND_INSTALL_LIBRARY(mod_trigger_b4_dl mod_trigger_b4_dl.c)
--ADD_AND_INSTALL_LIBRARY(mod_uploadprogress mod_uploadprogress.c)
-+# ADD_AND_INSTALL_LIBRARY(mod_uploadprogress mod_uploadprogress.c)
- ADD_AND_INSTALL_LIBRARY(mod_userdir mod_userdir.c)
- ADD_AND_INSTALL_LIBRARY(mod_usertrack mod_usertrack.c)
- ADD_AND_INSTALL_LIBRARY(mod_webdav mod_webdav.c)
-@@ -494,10 +510,10 @@
- ADD_TARGET_PROPERTIES(mod_cml LINK_FLAGS ${LUA_LDFLAGS})
- ADD_TARGET_PROPERTIES(mod_cml COMPILE_FLAGS ${LUA_CFLAGS})
--IF(HAVE_MYSQL_H AND HAVE_LIBMYSQL)
-+IF(HAVE_MYSQL_H AND HAVE_MYSQL)
-   TARGET_LINK_LIBRARIES(mod_mysql_vhost mysqlclient)
-   INCLUDE_DIRECTORIES(/usr/include/mysql)
--ENDIF(HAVE_MYSQL_H AND HAVE_LIBMYSQL)
-+ENDIF(HAVE_MYSQL_H AND HAVE_MYSQL)
- SET(L_MOD_WEBDAV)
- IF(HAVE_SQLITE3_H)
-@@ -545,7 +561,7 @@
- ENDIF(HAVE_MEMCACHE_H)
- IF(CMAKE_COMPILER_IS_GNUCC)
--  SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -g -Wshadow -W -pedantic")
-+  SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu99 -Wall -g -Wshadow -W -pedantic ${WARN_FLAGS}")
-   SET(CMAKE_C_FLAGS_RELEASE        "${CMAKE_C_FLAGS_RELEASE}     -O2")
-   SET(CMAKE_C_FLAGS_DEBUG          "${CMAKE_C_FLAGS_DEBUG}       -O0")
-   SET(CMAKE_C_FLAGS_RELWITHDEBINFO "${CMAKE_C_FLAGS_WITHDEBINFO} -O2")
 Index: src/mod_access.c
 ===================================================================
 --- src/mod_access.c   (.../tags/lighttpd-1.4.22)      (revision 2475)
This page took 0.132996 seconds and 4 git commands to generate.